footnote formatting: nested lists and bold, italics etc

First a heartfelt thank you to the entire literature and latte crew. Scrivener 3.x for the mac is a great! It really has improved my writing and organizing I need to write. Thank you All. Amber and nontroppo a special callout thank you for the help in infobox formatting you delivered last year.

Presently, I’m trying to have both bold/italic/linking formatting and texted bulleted lists in regular footnotes. I can get the formatting just fine as is via the “convert rich text to MultiMarkdown” option in compile. And I can get the nested lists when I compile using "convert tables and lists to MultiMarkdown’*.

Is there any way to get both the formatting and the nested list together in regular footnotes (which I need to execute in the end state of WordPress footnotes designed to be inline and popup footnotes (see for examples.

*in both cases I’m compiling using the MultiMarkdown-> Web Page (.html) compile option. Used to take my writings to a standard WordPress Blog environment, where I just copy and past the .html out of bbedit into WordPress 5.x. This work flow works very well.

doe anybody have any ideas on this one?

Yeah, this looks doable, but only if you use Markdown lists and inline footnotes. There are two problems that necessitate this approach, from what I can tell in a few simple tests:

  1. Inspector footnotes don’t take styles (which you’d need to preserve raw markup) or preserve formatting (which is a fallback tool for raw markup). Not that it really matters, since they don’t take lists either.
  2. You have to use Markdown here because RTF blows up at the concept of having a list in a footnote, nested or no. At least, I got varying results in different word processors, but more importantly the RTF parser Scrivener uses has no idea how to approach this from what I can tell—the MMD conversion is damaged beyond repair.

But thankfully MMD supports complex formatting in footnotes, and you don’t have to worry too much about the underlying tricks to make that work as Scrivener will handle that for you when generating multi-paragraph footnotes in general. This is what a working solution looks like:


Since not everything going on in there may be obvious at first glance, here are some notable gotchas:

  • You’re typing Markdown inside the footnote, so make sure your “paragraphs” are properly spaced, as demonstrated by the empty line following the “What you need to know:” bit.
  • The second footnote is bluish because Format ▸ Preserve Formatting has been applied to the entirety of it (right-click and “Select Footnote” to do that easily). It’s important that the entire footnote is shaded blue. If you leave a bit of the last line grey, Scrivener’s auto-spacing routine will kick in and push the last bullet line down. This doesn’t break Markdown—but it does trigger paragraph mode in lists, which will usually interact with stylesheets negatively, causing the list to be too spaced out for what it needs.
  • For Preserve Formatting to pass this through as raw markup, enable Treat “Preserve Formatting” as raw markup, in the general options compile tab.

This technique works with full conversion, and it also works with the simpler tables & lists conversion—but in that case you wouldn’t need preserve formatting since everything other than tables & lists is treated as properly formatted Markdown anyway.