Footnote - indented block quotes & compile

Hi all,

I’m trying to figure out a footnote formatting problem.

My footnotes occasionally require indented block quotes. There’s no way to manage indents directly in the Inspector–that much I’ve figured out. If you do a regular “Paste” of text from the main edit window, though, it will bring over the styles including the indents / margins etc.

Or at least, it appears to bring over the styles. They certainly appear in the inspector window with block quotes, emphasis, etc. as they appeared in the main composition window. But here’s the problem: When I compile directly to PDF, it doesn’t retain the formatting. And when I compile to Word or RTF, it does keep the block quote indents. . . it but messes up various other aspects of the formatting that require a fair bit of time to fix.

I’ve looked through lots of posts both here and elsewhere and haven’t found anything on this particular question. (Footnotes certainly do seem to be a persistently challenging feature though!)

Many thanks for any thoughts anyone can offer.

EDIT: I’m going to try to add comparison pictures to show what I mean.

Scrivener Inspector window:



PDF Output
:

bump

Scrivener inspector footnotes do not offer the same types of formatting control as the main text does, and it seems this is an example of this. One way to solve this would be if Scrivener supported styling in footnotes, then compiling with the styles exported. But this would be a feature request as currently you cannot use styles in footnotes. Keith would know if this is a fundamental limitation or something that could be improved (I assume the reason footnotes have been restricted is that there is some RTF limitation?)

In general it is going to be easier to format complex footnotes in the main editor, and thus make use of the inline footnotes feature. The sidebar footnote area is necessarily restricted for technical reasons.

In a simple test, I used the Block Quote style within a footnote, compile to RTF and opened the result in Nisus Writer Pro. The style assignment was intact within the footnote, and displayed as expected.

As you note, this isn’t something supported by Scrivener’s PDF output. It is necessarily simpler than the sort of full layout environment you get in more complex desktop publishing and word processor software.

Thanks - I appreciate the reply. And now I finally understand why anyone would want to use inline footnotes! I will give those a try and see how it works.

One question, though. You said: “I used the Block Quote style within a footnote, compile to RTF and opened the result in Nisus Writer Pro. The style assignment was intact within the footnote, and displayed as expected.” For what it’s worth, that’s not what happens for me. When I do a Block Quote style in the footnote and compile to RTF, the indenting and spacing format vanishes when I open the RTF in a separate word processor. (I use Word.) Is there something else I should be doing to have the format carry over to an RTF?

Check Word’s autoformatting options. They can be quite aggressive, and will override anything in the source document.

Katherine

The only special thing you would need to be aware of is the Include styles information in exported file checkbox, at the bottom of the Styles format compile pane. That is on by default however, and of course if you have it disabled then all styles will be stripped out, not just those in footnotes.

Otherwise I don’t see anything special that needs doing. I get styles in footnotes with Pages and LibreOffice as well. In theory there is no problem assigning styles to text in footnotes—after all most word processors handle footnote formatting by styling it as “Footnote” or similar.

Thanks guys - this is super helpful leads. Much appreciated! I will fiddle and see what further I can figure out . . .