Footnote marker problem

Greetings. I’m having some trouble with inspector footnotes. I dislike the highlighting feature and was very happy to discover that I could set my text preferences to insert a footnote marker. Problem is that I can’t get Scrivener to apply this setting consistently.

Scrivener inserts markers in some documents but in others it continues to highlight the nearest word. In at least one document I was able to insert footnote markers for a while but now suddenly I’m getting highlights again.

Any advice?


This isn’t a global preference but a project preference (it’s set under Project > Text Preferences…; anything under “Project” affects the current project only). So you will need to set the option for each project separately. (If it were global and someone sent you a project with a different marker, things wouldn’t work as expected.)

Hope that helps.

All the best,

Thanks for the reply.

I understand that it’s a project setting. I’ve been seeing the inconsistency among the documents of the one (very large) project that I’m working on.

I think I found the problem. I had reassigned the footnote keyboard shortcut to command-shift-F without reassigning the inline footnote shortcut. It occurred to me that perhaps there was a conflict creating the footnote weirdness, so I reassigned the inline footnote command to command-control-8, quit Scrivener, and relaunched. Problem solved.

Glad you got it sorted!