Footnote marker stopped working

This is a bit weird and not a serious bug, but worth reporting anyway.

  1. I have a customized footnote marker set as a default for all my projects. I hadn’t been creating new footnotes for a few weeks, but then when I wanted to add one it anchored the new inspector footnote to the last word (the behavior before the 2.1 or 2.2 update I believe). I didn’t change the preferences and I checked that Project/Text preferences, the marker option was ticked.

  2. I created a new project. Typed “hello”, inserted an inspector footnote and it worked alright (i.e. anchored the footnote to the marker).

  3. Went back to my old project, added an inspector footnote and worked as expected.

The only thing that I can think of is that I keep syncing this project between computers. But I do so as a zipped backup file and this has never been an issue in the past.

Any clues?

Hi,

I’m a bit confused because in both your examples you say it worked as expected, so I’m not sure what the problem is?

Note, though, that footnote markers are set per-project - there’s no preference to make this apply to all projects, and it must be set again for every new project (unless you create a project template with it set of course).

All the best,
Keith

Hi,

In both cases it worked, but in the first one it was not as expected.

I had set the project to work with footnote markers a long time ago (as soon as the option became avaialble) and worked flawlessly ever since.

But when I opened the project earlier today, without any change from me, it switched to the select-and-anchor behavior. When I created a new project and inserted a new footnote, then my project reverted to (the expected) insert-marker-and-anchor behavior.

I hope it makes sense now.

Hi,

Sorry, I’m still confused. :slight_smile: I think we may have a terminology problem. You say that the “insert-marker-and-anchor” behaviour was expected in a new project, but it’s not - in a new project, a marker should not be inserted unless you have specified one in the Text Preferences.

As for the old project, did you check the Text Preferences?

Also, note that if you select some text, the footnote will be anchored to the selection - an anchor is only ever inserted if there is no selection.

All the best,
Keith

In the project I work on I have the footnote marker option ticked. I made it the default behavior. I insert a footnote without selecting anything and I get the select-and-anchor behavior (i.e. the last word is selected and anchored to the note). To further clarify: I didn’t have any text selected when I inserted the footnote and I double checked the Text Preferences window. I tried this repeatedly with no change.

I then created a new project, verified that Text Preferences was exactly the same as in the previous project. I inserted a footnote under exactly the same conditions (no selections + checked that Text Preferences had the footnote marker option ticked) and I got the expected behavior: a marker was created and the footnote was anchored to it.

Went back to the original project, repeated and now it worked.

Under the same circumstances step 1 and step 2 produced different results, but it seems as if step 2 unlocked the problem… I’m sorry I can’t make this more clear.

Thanks for the clarification - I understand you now.

Does it only ever happen with this one project, or can you repeat it with others? I just tried it out and everything worked fine. I tried creating a project, setting using the footnote marker as the default, and then testing that it worked. Then I closed the project and reopened it and it was still working. In your case, it seems that you are saying that every time you reopen this one particular project, the footnote markers no longer work. What happens if you close and reopen the test project you made? Does that project continue to work? If it is only affecting one project, could you please zip it up and send it to us?

Actually, I can reproduce it in my two computers every time, and it’s not related to the project but to Page View, more specifically inserting footnotes beyond the first page.

  1. Create new project
  2. Text preferences: footnote marker=^^
  3. View/Page view = hide page view
  4. Populate the text window with random words that exceed what you’d get in one page (say 500 words).
  5. Insert footnote at the beginning and at the end of the text: footnotes are anchored to ^^
  6. Select View/Page view/Show Page View
  7. Insert footnote in the first page: footnotes are anchored to ^^
    8: Move to the next page: insert a footnote and the new footnote is anchored to the last word. (Double checked: I’m not selecting the last word)

I hope this helps!

[edited to clarify point 8]

That more than helps, that tells me exactly what the problem is and has enabled me to fix it!

Basically, in page layout view, the first page is sort of the “template” for all other pages - that page stores all the settings and all subsequent pages take their settings from it. But it turns out that some of the code was taking settings from the current page rather than from the first page, and thus some settings - mainly footnote markers and comment and footnote fonts - were not working after the first page in page layout view.

This should now be fixed for the next update, and I’ve uploaded a beta with this fix so that you can test it here:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

Thanks for bringing this to my attention, and I hope this fixes it - please let me know either way.

All the best,
Keith

You really make every other software firm look bad when you provide this kind of support. Can’y you at least fake some delay in there? Make the rest of them not seem quote so evil? Please?

You fixed it, thanks!!!