Footnote numbers not appearing in inspector

Hi,

I just updated to 2.2 and noticed mention in the changelog of footnote numbering in the inspector after compile. I guess this was added in 2.1, though I didn’t notice it then. I use Scrivener for academic work and always have a ton of footnotes, so I’m very happy about this feature (or, would be, if I could get it to work)!

Unfortunately, I don’t see any numbers appearing in the footnote inspector after I compile.

I wondered if it had to do with my project or compile settings, so I tried again with a blank project. I added some text to the draft, added some inspector footnotes to the text, and compiled to RTF (also tried PDF). In the footnote/annotations compile options I had all the boxes unchecked. I tried toggling the ‘prompt before updating footnote numbers’ option set in Format > Options - the prompt does show up on compile, I click yes, but nothing seems to change in inspector. No footnote numbering.

Am I doing something wrong? Missing some option somewhere?

Thanks!
Thomas

Hi Thomas,

My sincere apologies - it looks like a change I made to the code subsequently has broken this feature altogether. I’ve fixed it and will post a new build to the beta testing forum in the next couple of days. Sorry for the inconvenience, and thanks for bringing this to my attention.

All the best,
Keith

Thanks for the quick response Keith - definitely looking forward to this feature.

Thomas

I’ve noticed this as well so I will be watching out for the patch too.
I am using it for academic stuff as well so numbering footnotes is kind of crucial! :open_mouth:

Note that this only shows compiled footnote numbers - the numbers that were assigned during the last compile. Footnotes are still numbered correctly on print or export - it has no effect on that.

Anyway, the beta fixing this has been available for a few days:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1