Footnotes and Comments Shift to the Right

Hi,

First off, as this is my first time posting to this site, please allow to say what a wonderful product Scrivener is – it is really a tremendous tool that has helped me immensely with my writing.

That said, I have encountered a strange problem that I see no reference to elsewhere: Occasionally, when I reopen a chapter in Binder, I find that all of the footnotes and comments have shifted one space to the right. In other words, if a footnote ended at the period, the shading would now extend one space to the right of the period. If I exported the text, the actual number would also appear one space to the right of where it had been previously. Similarly, comment boxes would also be shifted one space to the right. So, if I had written a comment on the word “sample”, the yellow box that originally had encompassed that word would now start on the “a” instead of the “s” and end on the space after the word instead of after the letter “e.”

This has only happened two or three times on a project I have been working on for nearly a year. I only noticed it after the most recent update. I have tried to reproduce it and cannot. It happens so infrequently that I have not been able to identify even a possible trigger. When it does happen, it only happens to the chapter I am currently working on; no other part of of the file is effected.

I am running OS 10.6.6 on an Intel iMac.

Any help you could provide on this issue would be greatly appreciated, as it can be a real chore to go back and move 30+ footnotes – particularly when you’ve already congratulated yourself on finishing the chapter :wink:

Hi,

Thanks for the kind words. We have had one or two other isolated reports of something like this happening, but no one has been able to reproduce it and I haven’t been able to find an obvious culprit in the code. I’ll go back over the code, but if you can think of any more information that might be helpful I’d be grateful. For instance, do you have any special characters in the file, or did you import the text in the affected chapters from somewhere else? Are there or were there any special characters in these chapters?

What it sounds like is that somehow the text getting loaded is losing some invisible characters that might have come in. The way text is saved is this:

• The text itself is saved in an RTF file inside the .scriv package.
• The comments and footnotes are stored in a .links file alongside the RTF file. The .links file saves the comments and the range of text they are associated with - e.g. “this comment starts at the 75th letter and lasts for 6 letters”.

To me, it sounds as though the original text may have had some odd characters in it that maybe the RTF-saving procedures didn’t save or stripped out somehow - or maybe the RTF added something else in, given that things moved right rather than left. So that when the file was then reloaded it somehow had an extra character in it, so that the links, being assigned by character number, were now applied to the wrong letters.

The key will lie in finding what it is in the original text that causes the odd RTF saving, though, so anything you can think of would be really helpful.

Thanks!

All the best,
Keith

Wow! Thanks for your quick reply.

I went back and looked at the last chapter this occurred in, and it did include a couple “é” characters, including one that was part of a footnote. Special characters do not appear in most of my other chapters, so perhaps that could have something to do with it – though the problem effected all of the notes and comments in that file, not just the one with that character.

As for the other suspected cause, I am sure I copied text from an e-mail and pasted it in this file as well, but I have done that in almost every chapter and only encountered this problem in a couple of them (unfortunately, I can’t remember which chapter I first encountered this issue in, so it is hard to look for a common denominator).

I will pay closer attention going forward and let you know if I encounter this issue again.

Thanks for your help!

Best,

Bryce

Hi Bryce,

If there was a problem character, it would affect all the text from that point onwards, because the offsets for all comments after it would be off. The “é” character could be part of the problem, although there must be something else at work too because I can’t reproduce the issue and this would be really common among anyone using languages other than English if it was just a matter of diacritics. So, it may be this in combination with the program it was pasted in from, or that may just be a red herring and it could be that invisible characters have got into the file somehow.

Could you possibly e-mail us the project with a problem file in it? If everything had shifted to the right then there may still be a gremlin in the file somewhere.

Thanks and all the best,
Keith

Unfortunately, I’ve already reformatted the chapter. However, if this problem occurs again, I will try to do that.

Hi there,

scrivener is really a wonderful software, helping me handling all the stuff writing my new book. so thanx in advance.

There’s exactly the same bug occuring in my files and notes. The only thing I may say is, it’s occurs for shure, if the computer crashes and I have to restart scrivener. But sometimes it occurs after quitting scrivener and restarting it.

there are only new files affected.

sometimes the comments shift just one character to the right (see first attachment), sometimes the footnotes are wandering a little bit :slight_smile:
see second attachment.

beste regars,
christian
Bildschirmfoto 2011-05-18 um 11.15.47.png
Bildschirmfoto 2011-05-18 um 11.14.00.png

Hi Christian,

Thanks for the kind words. Can you find a way to reproduce this bug? It is very, very rare and I haven’t been able to see it for myself at all yet, which makes it difficult to fix. Thanks!

All the best,
Keith

hi keith,
no, I’m sorry, I tried to, but it failed.
So I have an eye on this and will come back as soon as I may report some details.
best regards, christian

the only thing I know is: the bug occurs, while working on a file / having just worked on a file.
after having finished it, nothing happens with the footnotes / comments.
best regards, christian aka anko

hi there,
even now I used the command “Documents > Duplicate > without Subdocuments” and all footnotes and comments shiftet to the right.
perhaps that may help.
best regards, anko

Does this always occur with a particular document? For me, duplication without subdocuments works fine, so there must be something specific here. Could you please zip up and send me a sample project that exhibits this behaviour?

Thanks!

All the best,
Keith

oops - it’s quite a big project and must be finsihed in two weeks.
the titel oft the book fits perfectly:

“do it wrong - and you will be right!” :slight_smile:

best regards, anko

Hi anko,

What happens if you create a new, blank project and drag the document that had problems to the binder of the new project? If you duplicate it in the blank project, does the problem still occur?

Thanks,
Keith

I just tried - and everthing remains at it was: the footnotes are still shifted to the right.
best regards, anko

No, I mean, take the original document that wasn’t shifted to the right (the original, not the duplicate), drag that to another project, then try duplicating it to see if duplicating causes the right-shift again. I’m trying to find a reproducible case in a smaller project that you’ll be able to send me.

Thanks!

sorry, a missunderstanding.

and there occured an intersting effect:

  • after moving the original file with the correct footnotes to the new project, SOME of the footnotes shifted to the right. these footnotes were new one I made today. old one remain correct.

that’s an effect I noticed serveral times: only NEW footnotes shift right, old ones remain stable.
so there might be a problem saving the file correct at the first time – but after some routines everything is ok.

best regards, anko

Thanks. Now that you’ve done this, can you find a circumstance where it always happens? That is, do you think you could write some numbered steps that would allow me to see the problem for myself?

Thanks!
Keith

ok, I’ll try - it may last a few days.
best regards, anko

Great, thanks!

I am also having a problem with footnotes shifting to the right. Unlike the previous user, however, the problem was not induced by moving my file between machines. I closed my Scrivener project file last night when I went to bed, and I reopened it this morning to find all my footnotes shifted to the right. I am using Scrivener 2.2 on Mac OS Lion 10.7.4.

Thanks,
Vivek