Footnotes removed in 'compile' also disappear in project?

This is what happened to me and I’m wondering whether that’s what supposed to happen or whether it’s a glitch. Either way I’m sobbing - so much work to replace them. If it’s supposed to happen perhaps make a note that it will also remove them from the project?

No, that’s not the way it is supposed to work. Nothing in compile should touch the data of the project, that’s its whole premise. In the Contents pane those checkboxes will set the original item’s state, for things like page breaks and whether or not to include it, but none of the options that convert or reformat text will change the original. In fact, I can’t think of anything that would strip out all footnotes without take multiple steps to do so, and that’s not something done with the compiler anyway. You’d have to use a special copy command in the Edit menu and then replace the text with the copied data, you can’t even do it to multiple items at once, you’d have to go through each item in the outline, one by one, stripping out footnotes. So I doubt that’s the problem.

How were your footnotes typed in, did you use the Inspector type of the inline type?

It was the inspector type.

I just tried to replicate it with duplicated documents and the footnotes are okay. Very mysterious.

I have no idea what could cause that, but you should be able to load a backup of your project. If you go the “Backup” tab in the preferences pane and click the button at the bottom to reveal the backup folder, you’ll find zipped copies of your project there. The easiest thing to do would be to just point you to the spot in the manual on restoring. It’s in §7.8.4, pg. 64.

Yes, thanks, just worked that one out myself a moment ago. Many thanks for your responses.