For my next annoying question: Ruler arrows

When I bring up the ruler to set my indents and margins, I am unable to make any arrows appear, let alone move them. Is this because its a template and I can’t modify it?


You most definitely can modify the ruler in a template.

Indents are downward pointing arrows, tabs are arrows that point left and right. Margins are set in the Page Setup pane.

(Margins define the edges of the printable page. Indents position the text within the area defined by the margins.)


Try clicking inside the text area for which you want to modify indents. This makes sure the pane is active.

Another way to do this is to use the menu command Format->Paragraph->Tabs and Indents… . But again, you’ll need to be sure the text pane you want is active. You’ll see a thin blue or possibly pink line beneath the header denoting the active pane. If there’s no line, the formatting commands will be greyed out.

Hope this helps!

Addendum: The commands won’t work unless you have some text selected, or at least have your cursor in a paragraph (the first line in an empty doc will do). I’m not clear on what you mean by template; there are two kinds in Scrivener. One is a template for a whole project, and the other is a template for a particular kind of new document within a project, like a character sketch. Did you mean one of those, or were you trying to describe something else?

Hi! I have a ruler problem in my Mac version. (I have it figured out in the Windows version but am new to the Mac version and still haven’t figured this out.)

I did manage to figure out how to get rid of all the crazy tab stops that were automatically in my documents, but I can’t seem to MOVE the ruler. The “0” starting point is more than a third of the way across the screen. How can I reset that starting point more to the left of the writing window? Here’s a screenshot:

You have found what IMO is the most annoying default value in Mac Scrivener. :smiley: To fix it, (in detail because you’re new to Mac—apologies if I cover stuff you’ve already learned)

  • from the Scrivener menu, select Preferences…
  • Open the Appearance panel
  • Click on Main Editor in the sidebar
  • Click on the Options button
  • Untick “Use fixed width editor”.

Hope this helps!

That totally worked! THANKS!

And yikes, I would never never never have figured that out. :mrgreen:

I’m no newbie to computers (34 years and counting!), so this was a little vexing. And it’s odd that the ruler issues are found under View/Text Editing, and the tab issues are found under Format/Paragraph, and the margins/indents are covered under Scrivener/Preferences/etc.

To me, those three types of fiddling/tweaking are related and should be in the same spot.

But hey, maybe that’s just me. 8)

THANK YOU again!

Also, I’ve used Macs at several jobs for many years (since 1987), but at home have always owned PCs. I bought this little refurbed MacBook Pro so I could use Vellum and the Mac version of Scrivener (having heard it’s superior to the Windows version, which I haven’t found to be true just yet). :slight_smile:

Aha. The answer to your conundrum is that Scrivener’s editor width, editor margins, and whether the ruler is visible have no effect on either the text file or the output, hence are not “formatting”. They are strictly for your visual convenience. Things like tabs, indents, etc. are stored with the text and conceivably will affect the compiled output, so are “formatting.” So ruler visibility is controlled in the View menu because presumably you may want to have that different for each project, and may want to change it often. Whether you use a fixed width editor or not is presumed to be a visual preference you’ll want across all your projects, and so is controlled in Scrivener-wide preferences.

I presume you know this from your Windows Scrivener use, but Scrivener is NOT a WYSIWYG writing environment.