Format of Spell Catcher shorthands in Scrivener editor

I started using Spell Catcher, and it has a handy option, where you can define abbreviations to be extended to the ‘proper’ word, which is quite nice, because i have to use veeery long words over and over again. Now, I was wondering about the format. My main body of text is formatted as Times New Roman, comments and footnotes (inspector) are Verdana by default. When I use my Spell Catcher shorthands in comments& footnotes, the full word comes out in Verdana (and even in italics, as in a stroke of beginner’s luck I’ve managed to define it that way in Spell Catcher). However, in the main body, they end up as “Helvetica” “Oblique”… Does anybody have an idea why, and more importantly how and where to change it? Thew fact that it works in the inspector but not in the editor is what confuses me.
All the best :smiley:

No ideas? (pushing the question back up again) :question:

The reason it might work in the inspector footnotes is that it might only accept plain text, and so the font info is thrown out when you Spell Catcher pastes the text in. What it sounds like to me is that Spell Catcher stores not only the characters associated with the expanded words, but also the font information. Are you pasting those words into Spell Catcher (when you set up a new word/phrase/whatever) from another editor or from web pages?

In Scrivener, if you have your default editor fonts set the way you like them, you can convert whatever documents you select in the binder to those font settings. Also, if you allow the compile settings to override your fonts, then no matter how big of a mess the fonts are in, they’ll come out uniform out of the compile – except if something is bold or italic where you didn’t intend for it to be.

G’d morning, and thanks for your answer.
No, I don’t paste the words into Spell Catcher, I just write them into Spell Catcher itself. I think that is where the problem is, because I just found that there is a format defined for “shorthand extensions” and that’s how it appears in Scrivener: I.e. I type WH in Scrivener (in my usual editor font, times new roman), and out comes Warthog in Helvetica. I’m just wondering if I couldn’t tell Scrivener to do like “past and match style” for this.
On the other hand, as you said, it will all be sorted out when compiling, so it really is not a big issue (it’s just something that bugs me :wink: )


I can sympathize with the annoyance of seeing your fonts all messed up. The “convert to default formatting” option for documents selected in the binder is the only way to easily normalize the font settings inside Scrivener. Well, you could select all of the text in your document, and then use your font toolbar to select the correct font and font size, but the convert option is easier in my opinion.

I don’t think there’s anything that Scrivener can do about how another program enters text into it. Now, if SC actually invokes the CMD-P keyboard shortcut to paste over your shorthand for a word, then you could use the Mac’s Keyboard preferences to swap out the shortcuts for Paste and Match Style with plain-old “Paste”. Your best bet for solving this is either to change the font that SC uses to match your preferred Scrivener font, or contact Spell Catcher’s developer to see if there’s a way to get it to behave the way you want.

Many thanks again for your help :smiley: . I’ve decided to be all Zen about it and fix it with styles afterwards, and when I’ve finished this :imp: chapter, I’ll go with your suggestion and ask the Spell Catcher people about this.