Format toolbar won't change font and keyboard shortcut for ruler doesn't work

Great work with Scrivener 3. It’s been a pleasure to see. I have found two bugs:

  1. If I use the format toolbar to change the font, it won’t display the font change. It will say that the text is in the new font, but it will display in the old font. Opening and closing Scrivener won’t result in any change. If I change the font with Format → Font → Show Fonts, the font will successfully change.

  2. If I use my own keyboard shortcuts (kept from the previous version, with no conflicts listed), the one for the ruler won’t work (Ctrl+Shift+R). If I set the shortcuts to the defaults, the shortcut (Alt+Shift+R) works. So, the issue is that it won’t accept the new shortcut. All my other custom shortctus seem to work fine. This is a very minor issue, since I just will go with the new shortcut for this one.

I’m not seeing this. Perhaps you are using a font that is visually similar to the one you changed from? You are typing in the space with the new font?

Doublecheck the keyboard settings. Using my old keyboard settings, the Ctrl+Shift+R was not there. Assigning it back fixed the issue.

Thanks for the responses! The issue is there no matter which fonts I switch between. I tried very different font styles, and it certainly doesn’t switch. When I type new text, it also appears in the old font.

Yes, I checked that, but I still had the issue. I seemed to have fixed this issue. After importing the old keyboard settings, I clicked the “Reset” button for the keyboard shortcut for “Reveal Draft Folder”, even though no keyboard shortcut was listed for it. So, the program must have thought there was a conflict with the shortcut, since Ctrl+Shift+R is the default for “Reveal Draft Folder” prior to importing the old keyboard settings. So, the issue here seems perhaps to be that, after importing keyboard settings, the program will retain some of the default keyboard shortcuts without displaying that those keyboard shortcuts are in place. I guess another option could be that something was messed up with my keyboard shortcut file.

One thing I tested: if I change the font in a document with the format toolbar, close Scrivener, and then open the RTF for that document, the correct font will display. So Scrivener is changing the font. It’s just that changing the font in this way doesn’t display in Scrivener itself for some reason.

I’m having the same issue with the font not changing in Scrivener 3 when using the Format toolbar. If I select some text, change it with the format toolbar, the name changes but the font does not. If I then right click on the selected text, select Font then Show Fonts, the font that I chose is displayed and when I click OK, the selected text font does change. I’ve tried different combinations of fonts and changing the font just doesn’t work with the Format toolbar.