Formatting Changing

I created a glossary in the “Resources” folder, but the formatting keeps changing. Some entries become underlined, others bolded, etc.

I am having a similar issue. In certain windows, and only certain ones, my text continually italicizes itself. But the issue is limited to character thoughts. What I mean is:

Blah blah blah, he thought.

That’s how it should look. But instead I get:

Blah blah blah, he thought. Followed by the entire paragraph italicized.

I’m running off a .docx file, and when I import it, it looks fine. But as soon as I try to split it by chapters, the italics go screwy. If I simply copy/paste individual chapters from the .docx, it looks fine, but as soon as I close the program, it goes back to italics. It’s quite odd.

I’m running 0.2.3, but the issue was happening in 0.2.2 as well. I did an uninstall when upgrading to 0.2.3. Thanks for all your hard work!

UPDATE: When I manually change the formatting individually, it seems to stick through a program restart. Of course, going through the manuscript (@150,000 words) and changing every one will take ages. I’ll likely do it for now, but it’s still an annoying bug. Thanks again.

UPDATE 2: After more testing, when I import the docx, it looks good. As soon as I split it it in any way, both the pasted text AND the whole original docx lose their proper formatting. I don’t do tons of beta testing, so if this is superfluous, I apologize.

Thanks for the report! There seems to be an issue with certain invisible characters (carriage returns) picking up character attributes like italics, underlining, and highlighting, and then refusing to let them go, which then causes the rest of the paragraph or an adjacent paragraph to pick up that formatting. Thus far I’ve only seen it happen when the formatting is applied to the start of the paragraph, which I gather is what you’re indicating as well with your example of character thoughts–but if that’s not what you’re seeing, please correct me.

No, you’re correct. When the italics occur further into a paragraph, they look perfect. It’s only when they lead the paragraph. If you need any more info, just let me know!

UPDATE: I’ve tried converting my original docx to .doc, .rtf, pdf, and html in hopes of circumventing this issue. (At this point it would have been faster to just muscle through the damn thing haha) But every time the same thing happens. The imported document looks fine, but as soon as I split it into chapters in any way (split function or just copy/paste), I lose my italics formatting. Can’t wait for release candidates! Thanks!

Hi, I am experiencing a similar issue. The formatting problem doesn’t appear to be linked to the first paragraph / first line for me. I am copy-pasting from MS Word document with existing formatting directly into Scrivener.

This is an example of what I paste. The first word is unbolded. The rest is bolded.

Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. Test in bold. "

Later this will appear as the below example (ALL in bold, including rest of paragraphs):
Test in bold. Test in bold etc etc etc "

Changing the formatting inside of Scrivener seems to fix the problem, however still means that you will have a challenge to directly copy / paste text with formatting into Scrivener.

This bug also seems to have issues that leak over and make the compiler do some odd things.

For example, I copy/paste from a file that has the first word italicized, then the rest of the paragraph non-italicized, and then the carriage return at the end of the paragraph also italicized (odd behavior to begin with and easily corrected in the source document, I know). When it is pasted into Scrivener and the compiler run (with convert italics to underline per the manuscript mode), the first word comes out underlined (correct behavior), the rest of the paragraph italicized (incorrect behavior regardless of if Scrivener considers the text italicized or not), and some of the double spacing between paragraphs as blank underlines (just plain odd behavior).

I’m having the same issue with underlining. I started out trying to do this:

Theme: blah blah blah

After I saved, clicked to another file, clicked back, the entire file was underlined. I tried to take away all underlining, and now the first line of every file is underlined after each autosave. Hope this is helpful information.