Formatting Endnotes, Missing Heading Border, and TOC

Hi,

I’ve hit a few snags trying to compile an ebook (Mobi).

Firstly, I seem to have a problem formatting endnotes. The inline footnotes convert to endnotes fine, but some are out of alignment. I realised (strangely) that this is because the footnoted text in each case is part of a block quote, and for some reason the corresponding endnote is also indented! However, I can’t seem to find a way to change this.

Secondly, I am trying to use the “with border” section heading format for some headings. However, sometimes this works, and sometimes it doesn’t. Is there something that I’m (not) doing that might cause this?

Lastly, I have an autogenerated table of contents. How do I create this so that I can format the page heading? It seems the only way I can display any sort of TOC is if I set the section layout to “as is”. The contents page section type is set as “contents page” (as defined in Scriv’s non-fitcion template).

Thank you all in advance,

Gareth.

OK, update:

I’ve managed to work out how to add borders to headings (doh - sorry, I’m new to this), so don’t worry about that.

I’ve managed to insert a table of contents through the “copy documents as structured link list” - so that appears to be working, now.

However, I’m still having trouble with formatting the endnotes… Applying my own created styles doesn’t seem to work.

Any chance you can create a small test file (a zipped SCRIV file) with gibberish text that depicts your Endnotes problem? If yes, I will be happy to look at it.

Thanks, but I can’t seem to attach scriv or ebook files - it’s saying that it’s an invalid file extension. Any ideas?

Anyway, if you want to recreate the error:

  1. create a project from the general non-fiction template
  2. create a few paragraphs of dummy text in a file in the chapter folder
  3. apply the “blockquote” style to one of these paragraphs
  4. create some footnotes (to appear in the comments, not inline footnotes) - some in the blockquote paragraph, some in the normal, unindented paragraphs
  5. make sure there is an endnotes page in the back matter
  6. compile as ebook (.mobi or .epub - doesn’t matter)

As you’ll see, the footnotes that are attached to the blockquote paragraph seem to inherit the indent. It does not seem to matter where in the indented paragraph the footnote is placed. Obviously, there are workarounds for this - I could import the ebook into Calibre, and edit the HTML - but this isn’t ideal.

Thank you.

G.

You need to zip the SCRIV file, then attach the zipped file to your post.

Ah! Here you go.
Footnote-bug.zip (9.06 KB)

It looks like you zipped the MOBI file instead of the SCRIV file, but that’s ok. I was able to recreate your SCRIV file.

When I open your MOBI file in Kindle Previewer 3 For Mac, I see the BEFORE image below. The SCRIV file that I created produces the AFTER image below.

If you download and open my SCRIV file, you will see that:

  1. I created a Project Format named Mobi Test. To see this, go to File > Compile.
  2. I then edited the Mobi Test format. To do this, highlight the format, then right-click and select Edit.
  3. I then created an Endnotes style for the endnotes entries. To see this, highlight the Styles tab.
  4. I then assigned the Endnotes style to the footnotes. To see this, highlight the Footnotes & Comments tab.

Keep in mind that I cannot see the settings in your SCRIV file, but if you compile my SCRIV file (attached), then open the resulting Mobi file in Kindle Previewer For Mac, you should get the same result. I hope this helps.

Mobi Test.scriv.zip (128 KB)

Hi again,

Thanks for this. Apologies for sending the wrong file.

The steps you describe are the ones I’ve been taking. To test, I’ve followed them in relation to the Footnote-bug scriv file, but with the same problem. I’ve attached the scriv file.

Thanks again for your help.

G.
Footnote-bug.zip (305 KB)

OK, I think I’ve got it. In your SCRIV file, do this pls:

  1. In File > Compile > Ebook Copy > Edit Format > Styles, delete the Block Quote and Endnotes styles.
  2. In File > Compile > Ebook Copy > Edit Format > Styles, create a new paragraph style with a unique name to format your endnotes.
  3. In File > Compile > Ebook Copy > Edit Format > Footnotes & Comments, apply the new style.

Then compile to MOBI and you should be good-to-go. Your SCRIV file with the three changes applied is attached.

As FYI, what I think is happening is that the Block Quote style within Compile (not the one applied in Editor), is overriding the endnotes style. So deleting the Block Quote style from within Compile fixes the problem.

A further FYI: When working with Scrivener, I tend to delete all the styles within Compile, and only add back those that I absolutely need. Otherwise, I tend to get confused between the styles in Editor, and the identically-named styles in Compile. That’s why in the first SCRIV file that I sent you yesterday, you would have seen almost no styles in Compile. You probably know that you need to add a style in Compile ONLY if you need to override a style in Editor.



Footnote-bug New.scriv.zip (331 KB)

It worked! You are a star. :smiley:

That was driving me absolutely insane. Actually, after deleting those two styles, simply specifying the existing footnotes style in Footnotes & Comments worked.

I shall play around, and see the best way to do blockquoting, but at least now I now that the problem is resolvable.

Thank you so, so much! I owe you! Let me know how you want payment… :wink:

G,

As an extra FYI to anyone reading this thread, users don’t need to create a page in the binder for endnotes in an ebook. They just need to set a page title during compile, rather than create an actual page / file. Sample file attached.

(Super sleuthing by @pomme4mois above. Respect.)

NoEndnotesPage.zip (125 KB)