Formatting folder titles to center doesn't work

When I export with File/Export Draft… and choose the Formatting Tab I can choose to export the titles of the folders centered. But only the title of the first older is centered and not the others. Is it a bug or am I doing something wrong?

I’m having the same problem with version 1.1. Is it a bug or is it me?

As a workaround, I open the exported doc in MS Word and do a find/replace on the page breaks (put [color=darkred]^m? in the “find what” box, check “use wildcards”, and, with the cursor in the “replace with” box, select from the format bar: Format>Paragraph>Alignment>Center).

I assume you have “Override text formatting” unchecked? In that case, the settings in the Formatting tab have no real effect. I suppose centre titles should still have an effect. I wonder if the fonts of titles should still apply in that case, too? Probably so…

Hey, Keith. Thanks for getting 1.1 out. I am not using it with Leopard yet, though I will eventually - when version 10.5.1 comes out.

To clarify, I am not exporting the titles of folders, but those of text documents in the binder are meant to appear centered at the top of a new page, as chapter titles.

[color=darkblue]Override text formatting is checked under the Formatting tab in the Compile Draft window, and [color=darkblue]Center is checked on all three boxes. Under the [color=darkblue]Content tab, [color=darkblue]Keep is unchecked for all but the first text document.

In the main window, [color=darkblue]Preserve Formatting is unchecked for all documents in the Draft folder.

Everything else in my text-only, novel-length export comes through great in a .doc export, but all the text document titles are left-aligned, not centered.

This wasn’t an issue for me with 1.09. Has this happened with anyone else?

I think I’ve tracked this. If you have “Do not indent titles” checked, that overrides the centering so that titles appear unindented on the left instead of centered. Obviously this is not the correct behaviour - if “Center” is checked, the title should be centered - “Do not indent titles” should only have any effect if “Center” is not checked.

I’ve fixed this for 1.11.

I’ve also changed the behaviour so that title font and center settings have effect even if you don’t override the text formatting. This seems to make more sense.

All the best,

Thanks Keith!

Your responsiveness to even these small issues is one of the things that makes your software stand out above the alternatives.

You’re already working on 1.11? Dude, take a break already!

1.11 is just a bug-fix release for 1.10, the same as 1.03 was for 1.02.

P.S. If you could try unchecking “Do not indent titles” to confirm that this restores centering, that would be really helpful so that I know I’ve fixed this…

Yes, unchecking “Do not Indent Titles” fixed it.