Formatting for Kindle

I wondered if anyone can help me. I recently uploaded my first book to Amazon after having formatted it in Scrivener. I also used the Kindle Previewer in order to make sure it looked right.

Now when I look at the book preview on Amazon, the indents are all gone even though it looks fine on my kindle paperwhite.

This makes me think that I am going to get complaints about the content not appearing correctly.

has anyone else run into this problem using Scrivener?

Seen plenty of complaints here about inconsistencies in presentation on various Kindle devices. Bugs in the viewer, bugs in the Kindles themselves, different device capabilities all screw up mobi display. If it looks okay on your paperwhite then the last thing that should be blamed is Scrivener.

One thing to check: are they actually indents in Scrivener, or are they paragraphs with a Tab inserted at the beginning of each one? Tabs are not at all HTML friendly, and speaking from a purist standpoint, shouldn’t be used in word processors for purposes of indenting, either. So if that’s what you have, you could strip them all out with the Format/Convert/Strip Leading Tabs menu command, and switch to use ruler indents either in the Formatting compile option pane, or fix your text as well (as stripping out tabs may cause the result to be a bit unreadable anyway).

Hello AmberV,

To be honest, I don’t know what I’m using. Here is a screenshot with in invisibles turned on.

If you could help me, I’d really appreciate it.

Regards

I’m thinking it should more like this.

If so, is there a way to strip away all those indents and line returns?

Regards

Hi Jason,

You are right - all of your paragraphs start with a tab rather than an indent, and tabs are ignored by HTML so won’t come out as indents. And all of your paragraphs end with line breaks rather than paragraph returns. To fix it, try this:

  1. Open the Find panel (Cmd-F).

  2. With the caret in the “Find” field, go to Edit > Insert > Line Break.

  3. Put the caret in the “Replace” field, hold down the Option key, and hit return. (Holding down Option allows you to enter returns and tabs into text fields in OS X without dismissing the panel or moving to the next field.)

  4. Click on “Replace All”.

Then, do the same for tabs. To replace tabs:

  • In the “Find” field, hold down Option and hit the tab key to enter a tab.

  • Leave the “Replace” field empty, so that when you hit “Replace All”, it deletes all tabs.

Then, you can select all the paragraphs you want to indent (you can select non-contiguous paragraphs by holding down Command if necessary) and change the indent in the ruler. Alternatively, if the whole document uses the same formatting, you can just use Documents > Convert > Convert Formatting to Default Text Style.

Hope that helps.

All the best,
Keith

That’s great, Keith. Thanks. :slight_smile: