Formatting has a mind of its own

I recently upgraded from 2.0 to 2.0.1, and also fiddled around with my settings to fix a line spacing problem. I don’t know which of them has done this, or if it’s unrelated. But here is what’s happening:

First, I noticed that all of my bulleted lists are messed up. The text is now on the line below the bullet. This is only true for existing pages; if I make a new one and add a bulleted list, it’s fine. But I can’t seem to fix the existing ones, or add new ones on existing pages.

Then I tried adding a new folder with a new page in it. I have had my default font set to Helvetica, but it decided to go with Courier. After some experimentation I found that if I create a new page in one of the folders I have been working in, it will use Helvetica, but if I create one in an empty folder (pre-existing or not) it will use Courier. I have reset the default in Preferences/Formatting but it doesn’t help (though it had been changed, it seems, because the first time I reset it the formatting of the font sample changed).

Things I know I did:

  • changed the line height multiple in the document to 1.0
  • created a custom compile format which sets line height multiple to 1.0, line height to “at least” 20 and before paragraph spacing to 10
  • I vaguely recall doing something to stop paragraphs from indenting the first line, but I don’t recall what it was and can’t find any setting like that now (whatever it was, I suspect this is how I killed my bulleted lists)
  • I am fairly confident that I didn’t do anything with the font (at least not intentionally)

I have Time Machine and can restore old versions of plists, if that would help get things back to a sane state? I will try that tomorrow if no-one has any better suggestions.

Did you happen to accidentally switch to Scriptwriting mode? This defaults the font to Courier and would be creating your new folders and new documents within them in script mode. Scrivener remembers your most recently used settings for this, however, so clicking in your pre-existing “normal” folders in order to create new documents within them would load the non-scriptwriting mode and would thus create new documents in regular mode (using your default Helvetica). If you happened to have the editor locked on a script document when you did this so the folder didn’t load, the new document created there would be a script.

To check, in one of your courier documents go to Format>Scriptwriting and see if Script Mode has a checkmark next to it. If it does, uncheck it.

You’ll need to do this for all the pre-existing script documents to switch them back to regular mode. To identify them, the document icon in the binder will be yellow and look like it’s got a three holes punched down the left side. (Also, new script-mode documents get titled “New Scene” by default.)

Another way to tell if you’re in script mode is to check the editor footer. If instead of your word count and the progress target icon you see a bunch of crazy stuff like “[Tab] Action, [Enter] Action” and so on, you’re in script mode. :wink:

It does indeed sound as though you have script mode on. A few users seem to enter scriptwriting mode accidentally, but I have no idea how. :slight_smile: Did you experiment with keyboard shortcuts at all? (Cmd-8 enters scriptwriting mode.) The only other way you can enter scriptwriting mode is very deliberately, via the Format > Scriptwriting menu or by adding the item to your toolbar and clicking on it.


Trying to type Cmd-I and overreaching, hitting Cmd-8 instead, looks like an easy way to do it.

You’d have to have giant fingers to do that! I wanted to change the scriptwriting shortcut to something you couldn’t accidentally hit - ctrl-cmd-Y or suchlike - but scriptwriters objected.

Nope, not in Screenwriting mode.

I used Time Machine to restore the last good version and then the very first bad version of the document, and compared the Settings folders. Most of the differences are not very readable, but one that stood out was that the bad version contained a file called projectpreferences.xml, which the good one did not. So I removed that file and now the font funkiness seems to have gone away.

My lists are still messed up, but I think the easiest way to fix this is going to be to go through and un-list and re-list each one; that does work.

The projectpreferences.xml file is attached (I tried pasting the contents here but the forum software mangles it). It’s not clear to me what the problem is - it sets the footnote font to courier, but at a different size than I was getting so I don’t think that was the problem (not to mention I wasn’t making footnotes!).
projectpreferences.xml (713 Bytes)

Re: the bullet spacing problem, if you do a “convert formatting to default text style” on a document that has a bulleted list and don’t select to preserve tabs and indents, it will mess up the list as you describe, placing the text a line below the bullet. Might that have been what happened? If you try to continue the list after the conversion, it will keep up the weird behavior (which I expect is just due to Apple’s most excellently implemented, fully-featured list text styles! /sarcasm) although starting a new list somewhere else in that document should work all right. This is unrelated to the whole changing font business, but it’s a possible explanation for that bit, since with all that you may have done some formatting converting in an attempt to restore your settings.

Okay, also your preference file suggests that at some point you selected to override text formatting for the project; presumably the courier font was set in that. (It is different from the footnotes, but that’s not as user-readable as the actual tag in the preference. However, it’s clearly set to override the default Preference formatting, so that seems to have been the problem). I can’t quite see why this would make some of your documents still default to Helvetica, but there you go. For future reference, this is an option in Project>Text Preferences… It allows you to use different formatting per-project if you happen to not want to use your global preferences.

It’s possible… I did something along those lines. I’ve fixed them all now and will be more careful in that department in the future! :slight_smile: