Formatting Issue??

I have Mac OS X Lion 10.7.5 (11G63). When I opened my novel one scene looked like it does below:

{\rtf1\ansi\ansicpg1252\cocoartf1138\cocoasubrtf510
{\fonttbl\f0\fnil\fcharset0 Cochin;}
{\colortbl;\red255\green255\blue255;}
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\fi360\sl288\slmult1\pardirnatural

\f0\fs28 \cf0 As I pedal the streets to my boarding house I pass the three blocks of the Delphi plant. It’92s

The other scenes were just as I had written them.

Thanks for any guidance.

That looks like raw RTF format.

Were you opening the project in Scrivener, or another editor, and which one?

Katherine

Katherine,

I was in Scrivener. No other editor (that I know of)
Jim

Yes, I agree with Katherine: this is raw rtf: what you would see if you opened a .rtf file in a plain text editor. For some reason, Scrivener is treating this document as if it is text only. It is possible the rtf formatting code is screwed up, since your other documents in the same project render OK.

If you have backups, open the latest in scrivener and see if that one has the screwy document also. You only care about this one document. If the latest backup also has the rtf raw code, try earlier backups if you have them. If you can find one that has a copy of this document that looks right, copy it over into the current project and delete the screwy one.

If that document has new changes you really want, there are a couple things you could try. The first I would essay would be to select all, copy, and paste the text - raw formatting codes and all - into a blank text document in a text-only editor. Try to save it and then in Finder rename the extension as rtf rather than txt. Open the rtf version in TextEdit to see if it looks all right. It probably won’t since both textedit and scrivener use the same core text code in OSX. But it is worth a try.

If that does happen, try to open the txt - rtf file in MS Word or other word processor. Word is likely your best bet since MicroSoft invented the rtf format.

If all else fails, and you really want to recover any changes made to that document since your last good-looking backup, remember that rtf such as this is really only your text plus formatting codes. The formatting is all enclosed inside {curly braces} so with some work, you can go through the document and delete all the code until you get back to your own writing.

Good luck.

  • asotir

Have you been synchronizing Scrivener with an external folder or anything like that? As asotir said, this is what you would see if you opened an RTF file in a plain text editor. Which suggests that, somewhere along the line, the file extension might have been changed from RTF to TXT.

If looking through your backup files doesn’t help, you might also try this:

  • Use the File -> Backup -> Backup Now command to make a backup of your Scrivener project, in case something goes wrong.

  • With Scrivener closed, find the project in Finder. Right-click, and select the option to Show Package Contents.

  • Look in the Files/Docs subfolder. You’ll see a long list of files with names like “123.rtf.”

  • Sort by Kind, and scroll down to see all files with the .txt extension.

  • Using QuickLook, look to see if one of these is your problem file. If you find it, drag it out of the project to a location like your Desktop, rename it with the .RTF extension, and try opening it in TextEdit.

  • If that restores it to “normal,” then you can re-import it back into the Scrivener project. If not, then the RTF formatting is probably damaged.

Katherine

Another approach that doesn’t require editing the project contents itself:

  1. Open TextEdit and set it to plain-text mode, with Format/Make Plain Text.
  2. Copy and paste what you see in Scrivener into this TextEdit window.
  3. Save the document with File/Save…, and be sure to give it a name ending in “.rtf”. The software will complain, saying that this isn’t a normal text file extension. Ignore it by clicking the Use .rtf button.

Now drag that the file you saved in step 3 into Scrivener—it should hopefully be okay at this point.

Was this project edited with the Windows version of Scrivener, by chance? There was a bug that could cause this to happen, a while back, under certain specific conditions.