Formatting issues since the new update

Fixed the Documents ▸ Convert ▸ Text to Default Formatting… behaviour to retain text colour and highlighting. (Text with a character style applied will revert to the style’s defined formatting.) Also fixed the conversion of text with a paragraph-only style, which was losing all character formatting including bold and italic.

Okay, well, none of this was happening to me before, but it is now. If I use convert to default formatting OR paste and match style, I lose bold and italics along with any other set styles such as block quotes, which wasn’t happening prior to this update: Version: 3.1.3.0 (1861504) 64-bit - 06 Dec 2022

Paste and match style isn’t even working properly for me within the same document much less between two projects or from a .doc or .rtf file.

For instance, if I copy a block quote from one document in my binder and use Paste and Match Style in a new document, It removes the block quote, the italics, pastes in an entirely different font AND loses my indents. So basically, it strips the formatting entirely. That is the opposite of what I needed to do.

And before you say this is only my issue, it’s not. It’s happening to my co-author as well, and also to another author friend of mine. I haven’t asked around, but I suspect if I did, I’d find more people who have had the issue.

Here’s some visual proof.

Now for something else fun, the following shows how Paste and Match Style is working for me within the same project, and in fact, on the same exact document.

This is not good. Just not good. It cost me half a day of rebuilding 10 chapters to get back my italics and other formatting. Not fun. Please address and fix.

“Match style” meaning to match how the paragraph is formatted in the destination document (the one paragraph where your cursor is when pasting - not the source one), it actually does exactly what it should.
It is unfortunately you who has the wrong definition of things.
(No rudeness intended.)

If you want the text in the clipboard to paste as it was where you copied it from, just paste it (Ctrl-V) ; nevermind the “match style” part.

Else, what you quoted only mentions text color and highlight… (Aside the paragraph only style situation.)
…and nothing at all as regard to Paste and match style.

2 Likes

Okay, for one, I’ve been using Scrivener for years and I have copied and pasted using paste and match style between separate projects, from Word documents, and from plain text documents as well as within the same project and it has never removed italics the way it does now. I use that setting specifically when I don’t want to remove italics or bold because it works…or it did before I updated this time.

And the quote I quoted specifically mentioned italics and bold.

You can believe I’m an idiot if you want to, but I have been moving text between two projects and also within the same projects for a long time using paste and match style for smaller sections and setting documents to default text for multiple documents.

I have discovered after I posted that I can sort of force the conversion to default to retain italics if I leave everything else unchecked in the options box except for the three lower boxes (alignment, tabs and indents, and line spacing). Those were not the settings I used previously and they don’t remain checked each time. I never used to have to check boxes every time I wanted to convert before. I’m fine with it if I have to now. But Alignment, Tabs and Indents, and Line Spacing would not have immediately jumped to mind as a way to preserve italics.

And just for fun, guess what happens if I make a new document, then set the style to Block Quote, and the text dropdown to Text Italic and then copy some text and then Paste and Match Style. By your response, I should have had new text on that page that is an italicized block quote.

NOPE.
I get the block quote, but no italics and the Text Italic choice returns to Text only. Works that way if I pull the text from any source including other projects, this project, a docx, an rtf, or just a plain text file.

But now that I can make it retain italics when it converts to default, I’m happy and I will avoid paste and match style entirely.

We could do without that part.
For the moment I am not reading any further.

image

2 Likes

Just to confirm, Paste and Match Style has always had the same exact function as pasting formatted text into Notepad.exe, cutting it from there, and then pasting it into a program with formatting. It is just a shortcut for that method. The result is pure plain text, with no trace of any of the original formatting even theoretically possible.

And yes, when pasting text without formatting into a context with formatting, whatever formatting is under the cursor will be continued—no different than typing at that point would.

Right. So when I used to use it to paste text from my co-authors projects (she uses Sitka text and I use TNR) it would match my formatting which in default is actually very simple. And it would keep italics or bold text.

Now, if I paste it into a document that is formatted for italic text, it removes the italics and resets the dropdown from Text Italic back to just plain Text. That’s not how it acted before.

It’s fine. I figured out how to work around it enough to do what I need to do.

Just to clarify, you’re saying that if you paste some text using Paste and Match Style into a range of text that is already italic, the pasted text isn’t italic? I don’t see that happening, nor should it—that would fall under the second description I gave above, where the result would be the same as manually typing in the text you are pasting, without touching any formatting controls. There may be some odd edge case you’re running into that we could look into fixing, if that’s the case. But I’d first check and make sure the spot you’re pasting into really is italics. Given how these editors work, where formatting codes are invisible, you can have italics to the left and right of the point you paste into, while that point itself is something else.

But if I’m misunderstanding, just again to confirm: losing italics and bold is how it is meant to work. I’ve never seen it work any other way, but if you had some condition where it triggered a bug so that it didn’t work right, and now it is fixed—the best I can say is that it is fixed.

The use of the Convert Text to Default Formatting menu command has always been the preferred way to clean up text while retaining most inline formatting (links, italics, colour and so forth). Paste and Match Style has always been (or intended to be in 99.999% of cases) the scorched earth option that strips all formatting.