Formatting moving to the left

I have a problem in Scrivener: In many parts of my text, where I applied formatting (italics or bold characters), something really strange happened: the formatting is moved slightly to the left. In fact, my impression is that it has done it systematically. I have lots of occurrences of italics moving, in particular, as I am quoting titles of books, or simply putting foreign words in italics (Latin, French).

Example: instead of “the third man”, I might have “the third man”.

Does anyone know how this can possibly happen?

  1. I cannot see anyway of solving this automatically, which means that I now have to correct ALL the occurrences one by one, and I will inevitably miss some.

  2. I absolutely need to prevent understand how it happened to as to prevent it from happening again.

These “modifications” appear in the final text when I compile, unfortunately.

Thank you in advance for any help you can provide.

I think people will need more info:

  • Which version of Scrivener?
  • Which version of MacOS?
  • What font are you using?
  • What format are you compiling to?

Also, the example you give is unenlightening because what you are describing isn’t visible in the forum text. Can you post an image, please.


1 Like

@xiamenese Mark, the example does display the phenomena. The OP is not saying the characters are shifting left, but rather which characters get italicized is shifted left. It is the same result you would get if you selected the last letter of a word and all but the last letter of the next word and then invoked Italics.

I can’t think of anything that would systematically produce such a shift. It is my belief that spans of italicization are not tracked seperately like an overlay, but are written right into the text code underlying your text, so there would not seem to be a way the italics could all shift over at once because of some code glitch. And the fact that the shift shows in compiled output shows it is not just a presentational problem (whereby the Editor pane was showing things wrongly) either.

So, how you got this state, I do not know.

  1. I would definitely quit out of Scrivener and restart it. In fact, I would reboot my computer for good measure — since Scriv is using the text engine provided by macOS. Also, before you do more, I would duplicate the project file in the Finder so as to have a safety copy you could resort back to if need be.

  2. One small happiness here is that you can search by format in Scrivener, so at least you can hunt down all the italics to fix them and not miss any.

1 Like

This is indeed a weird one.

I got some additional questions:

  • When you write in TextEdit with the same font, does the shifting happen too?
  • Do you use any apps related to text in the background, like TextExpander, Typinator, Keyboard Maestro, or something similar?

Just stabbing in the dark.

1 Like


Thank you very much for your quick answer.
Version: 3.3.1 (15588)
Mac OS Monterey 12.6.6
Font: Times New Roman
Converting to .rtf, then opening with LibreOffice and sharing a .docx

Not sure how I can post an image. I will have a look…

Thank you for your answer

  1. The problem with a safety copy is that I am still changing the document every day. This will end up being a 300/400-page work, which needs to be finished at the end of August. The safety copy will not include future changes. Actually, I am saving my Mac every day with Time Machine, so I have plenty of copies, but I don’t think it will help me much.

  2. I tried to search by format, but it does not include italics or bold, only styles, coloured, highlighted text… :-/


Yes, really weird!

I have never have any issue with TextEdit, but I do not use it that much. The thing is that I have no idea how/when it happened.

A while ago, I had posted on this forum because I had used styles in the editor, and I was advised not to, so I converted my whole text to “no style”, except for block quotes.
I have no idea if it happened during this process, but why would it, anyway?

I have never heard of any of the apps you mentioned :slight_smile:

Hello again,

I have just checked, and despite the fact that I am using “no style”, some of my text is in Times New Roman and some of it is in Palatino. Strange. I will try to see how I can solve this. I would think that, if I choose “no style”, it just uses a default font.

Not sure this is linked to the issue anyway, but just wanted to amend my previous answer :wink:

My bad! I was taking a tiny break from doing family accounts. I saw the “d” at the end wasn’t italicised, but missed the italicised “e” at the end of the previous word. :upside_down_face:

Compiling to RTF doesn’t do any “conversion” as its Scrivener’s native format. I would follow your working method if I didn’t use Nisus Writer Pro (which also uses RTF as it’s native format), so I would think the error is coming somewhere in the LibreOffice end of the process.

But I’d still try: (1) try running Editing > Text Tidying > Zap Gremlins over the whole project; (2) shut down all apps and run something like Onyx > Maintenance over the system… that will shut down and reboot the computer when it’s done its job.

And I too would make a safety copy of the project first. I would want to try to eliminate what’s causing this before getting on with further work on it, and I’d have that around in case I messed things up in the process. I’d probably use File > Back Up > Back Up to… and Zip it if possible and send it to the desktop for easy access if I needed it or easy deletion if I didn’t.


1 Like

Font family, size, face, underline, color, background, etc. are character attributes; they are not styles. A style is a named bundle of paragraph and character attributes, enabling you to apply the lot of them at once. “No style” compiles as the default text format, but doesn’t always act like a style in the Editor. Changing the default text format doesn’t change anything in existing no style text, for instance.

1 Like

Things I am unclear about:

  1. Is the problem ongoing or historical? That is, does it (reproducibly) happen with new text, or is it just a feature of extant text?

  2. I thought this was something you were seeing in the Scrivener editor pane (and on into compiled output). But something later in this exchange made me think it might only be showing up in compiled output. Could you clarify which is correct?

Maybe at that time you did some search and replace (maybe involving some regEx expression that was not quite right) that was targetting your italics and that did it. Wild guess.

Hmm. Could it be there is some association/connection between the italics phenomenon and this?

1 Like

Thank you Mark,

Sorry, I mean “compiling”, not “converting” to .rtf.

I did not know about Zap Gremlins, so I have just read about it… and tried it on a bit of text where there was an issue :

(CITE Chapman albums Tracy Chapman, Crossroads, Matters of the Heart, New Beginning)

“Zap Gremlins” did not change anything. Maybe this, in itself, is a clue, I don’t know.

Sorry, just italicising here, because I have not found how I could attach a screenshot to my message…

I do not know of Onyx. I suppose it is something that has nothing to do with Scrivener.

Exactly! I absolutely want to understand AND eliminate what is causing the problem, or else I am looking for more trouble in the future. I have a safety copy made every day, but I am still writing it anyway, and my work is really not linear, so safety copies are not that useful.

  1. This is really difficult to understand. I have not found a pattern. My impression is that it happens “reproducibly”, but since I do not know the cause, it is very difficult to produce it artificially so as to check…

  2. You are right. It is definitely in the editor pane… and on into compiled output.

No, I did not do any search and replace.

I have just checked. When I change Palatino to Times New Roman, the issue remains.


Yes, Onyx is nothing to do with Scrivener; it’s a free system maintenance and interface tweaking app. I run it regularly to keep my system clean.

Can I ask, in Scrivener, where do the cites come from? I mean, do you type them in yourself or are you using a bibliography manager?



1 Like

Hi Mark,

I type them myself because there is no Zotero integration in Scrivener.
I have already planned to replace all the brackets that contain “CITE” in them with the citations from Zotero at the end.

FYI, this will be my workflow with Zotero:

  • compile to .RTF
  • open RTF with LibreOffice
  • Save a copy as .ODT
  • run ODF scan with Zotero
  • open ODT with LibreOffice
  • In document preferences in the Zotero plugin for LibreOffice, set the citation style to MLA 9
  • Save a copy as .DOCX under a different name (… TRANSFER)
  • In document preferences in the Zotero plugin for LibreOffice, select “Switch to a Different Word Processor…”
  • Save !!! (Cmd + S)
  • Open the DOCX with MS Word
  • Click Refresh in the Zotero plugin for MS Word

I have just checked some recent text, and the issue does not seem to be happening again, for the moment. I have checked some older parts and had to fix everything, but I can’t be sure if I had already fixed it before in those parts.

Really difficult to answer if the problem is ongoing or historical. I would need to keep a log of where I have corrected the issue to see if it reappears.
I have just written what I have corrected today and will check again in a few days (and again in 2 weeks?).
I find it very difficult to know when to check since I have no idea how such a thing can happen.

In the meantime, it is very stressful because my text is getting longer. Checking 60 pages is a bit time consuming, but checking 300 will be much worse.


Could you please tell me how Onyx might help in solving this issue?
Do you think that the problem could come from OUTSIDE Scrivener?
I have never had this issue anywhere else.

If you think it is any use, I can download Onyx.
I have just had a look and apparently it is free, or at least there is a free version.

I think if it is not happening when you type and you can’t reproduce it, it is extremely unlikely to be ongoing. Though not knowing yet how it came about is uncomfortable, I think you should not fear that your docs are being changed behind your back when you are away from them. Unless you have a poltergeist in your computer, of course.

BTW, Word has the ability to search for spans of italics. That might be useful to you in speeding your process of fixing the messed up parts.

1 Like

Thank you SO much for your support. It is greatly appreciated <3