Formatting paragraphs

I know that Scrivener doesn’t like to use the term formatting paragraphs. That said, I don’t know what else to call it, and I’m pulling out my hair trying to achieve a particular look in my books.

Example: I have a “chapter” called What Readers Are Saying which consists of a quote, followed by the person’s name, title, and location (all separate paragraphs. I’d like it to show up in the ebook (mobi) like this:

“Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc.”

                                                                                                                Person's Name
                                                                                         General Manager, A Company
                                                                                                             Los Angeles, CA

The name, company and city,state should be FLUSH RIGHT. I even tried to simulate that here but it comes out flush left.

I use the Essay Block Quote for the quote, and whatever the standard format is called “body”? for the name/address, and it looks like this:

 "Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. Blah, blah, blah, blah, blah, yada, yada, yada, yada, etc. etc. etc. "

Person's Name

General Manager, A Company,
Los Angeles, CA

EDIT: What isn’t showing here is that the Person’s Name is indented a quarter inch, or so. “General Manager” and "Los Angeles are flush left.

I want the person’s name and title and city, etc. to be flush RIGHT.

I’ve tried clicking on Flush Right in the ruler bar but nothing happens. It looks correct in the Scrivener window, but when compiled, regardless of what I try, it always looks like the example on the bottom, with a silly indent before the name, and the rest flush left.

What am I doing wrong? I’ve searched this forum and the web in general, and can’t find a solution. Thanks!

When you open the Compile window, click on the Formatting compile option pane. At the top of this you should see a checkbox for override formatting. That means basically anything you write will end up looking like the text in the mock editor below (you may need to click around between the various rows in the table to find the one that prints your text—most likely the single-page text icon). Now there are three routes you can take here:

  1. If you would like the compiler to do some clean-up, such as giving you the ability to swap fonts on the fly when compiling, then it’s best to leave the main override turned on. What you would want to do then is click the “Options” button to the right of that checkbox, and then check off “Preserve alignment”. Alignment is what sets whether text will be flush right or what have you. With that checked off, everything will look like the mock editor in Formatting, save for alignment, that will be left alone. You may also want to check “Preserve tabs and indents” too, for your block quotes.
  2. The second option is similar to the above, however instead of messing with the Options, you would use Preserve Formatting in the editor. In fact one of the provided block quote presets uses this by default. It’s the one that puts a blue box around the paragraph when you choose it. That blue box tells Scrivener to leave whatever is inside of it alone. None of the formatting will be changed within it. In an inverse fashion from the above, you can use that same Options panel to decrease how much is preserved. For instance you can have the preserved text retain its alignment and indents, but still receive font and line spacing adjustments. This option will work better if you do want to use the compiler to clean up your indents in the rest of the text.
  3. Finally the third option, which makes Scrivener act much more like a normal word processor, is to just switch off the formatting override entirely. Then however you type in the editor is what you will get on output. If you accidentally have five different fonts going on, or the line-height gets adjusted halfway through the book without your notice, then these flaws will be religiously reproduced—but you get full control as a result.

Amber,

Thank you SO MUCH for the detailed response. It means a lot to me that you took the time. I played with all the suggestions you list, and in the end, the easiest for me to do was what you covered in the opening paragraph - turning off the “Override formatting” command.

I tried the others, but couldn’t seem to make them work or figure them out completely, but since I found the solution with the Override Formatting command, I’m good for now.

My e-books are relatively short - maybe 18,000-20,000 words, so there aren’t too many pages, or chapters, to work with. I can make changes and check the whole document/file in a short period of time. (For example, I haven’t mastered the concepts of front and back matter yet, so I include “chapters” for things like the title, dedication, foreword, etc. and just tell Scrivener NOT to think of these things as chapters.)

Anyway, I’m good to go for now, thanks to your great post. I’ve kept a copy on Word on my desktop as well, so I can find it quickly when I’m ready to try the numbered suggestions again. :slight_smile: