formatting problem - spaces at the beginning of a line

Hi everybody,

I am new here and just bought Scrivener as I tried the test version and really liked it. However, I have one tiny formatting problem. I already wrote the support a - quite confusing - mail about it a few minutes ago, but to be sure, I’d like to post my question here in addition. (If somebody from the Literature-and-Latte-support reads this, please be patient with me and thanks so much in advance for your help!)

I try to explain this a simple as possible (please forgive me, English is not my main language): I use the text formatting style which - after pressing the “Return/Enter”-Key - gives the new line a little “space” at the beginning, like in most novels. I know “space” is not the correct English word, but can’t find out the exact term - in German, it’s called “Einschub”… It looks something like this (the underlines only symbolize the space - just there, because otherwise the posting would re-format all the lines to the very left and I can’t write HTML):

___“Hey!”, she said. “What are you doing?”
___“Me?”
___He was looking confused. What is this idiot writing here, the people on the “Literature and Latte”-Forum ask themselves. English isn’t even his first language and bla bla bla.

That’s nice and I want that. HOWEVER, Scrivener also puts spaces in the very first line of a chapter/scene/etc. and paragraphs separated with a blank line. These are the two exceptions I DON’T want this little space (cause it also isn’t in most books).

I DON’T WANT:

[i]___He went to the bathroom.
___“Hey!”, she said. “What are you doing?”
___“Me?”
___He was looking confused. What is this idiot writing here, the people on the “Literature and Latte”-Forum ask themselves. English isn’t even his first language and bla bla bla.

___A new paragraph starting after a blank line is a fine thing. Nevertheless, it doesn’t get better with this bullshit this guy is writing into this forum bla bla …[/i]

Instead, I WANT:

[i]He went to the bathroom.
___“Hey!”, she said. “What are you doing?”
___“Me?”
___He was looking confused. What is this idiot writing here, the people on the “Literature and Latte”-Forum ask themselves. English isn’t even his first language and bla bla bla.

A new paragraph starting after a blank line is a fine thing. Nevertheless, it doesn’t get better with this bullshit this guy is writing into this forum bla bla.[/i]

(assuming that the very first line really is the beginning of a chapter or starting after a blank line, of course)

I hope this wasn’t TOO confusing, but I’m afraid I’m not able to describe this very specific problem in English any better. Does anybody have a hint how to change the formatting to my explained perfect way?

Thanks SO MUCH in advance for your help!!! Please keep up the great work. Scrivener is a great program and this seems like the beginning of a new and long-living text processor love affair …

Hi,

These are generally called “indents”. In most books - in English at least - it’s standard for new paragraphs to start with indents too (and it’s standard an all e-readers as well, for instance). If you want only to use them for dialogue, then it would probably be best to set up Scrivener not to use indents at all and then just hit the tab key at the beginning of dialogue lines. To change Scrivener’s default formatting, go to the “Formatting” pane of the Preferences. There you can set the default indent (set it to 0 in your case) and change the line spacing, which is currently set up to leave a gap after paragraphs:

You’ll need to click on “Spacing…” at the bottom of the line spacing menu, which will bring up this:

Your changes will take effect for any new documents you create. You can assign the default formatting to existing documents by selecting them in the binder and selecting Documents > Convert > Formatting to Default Text Style.

As I say, this will set the indents to start left-aligned, and then you can just hit the tab key to insert a tab indent whenever you need it.

Hope that helps!

All the best,
Keith

Hey Keith,

thanks so much for your fast and detailed reply - really, really appreciated!! Now I know the facts and can decide which way is the best for me. At least in German books, it’s almost always the way I’ve described - that there’s NO incident at the very first line of the chapter and after a blank line. Mabye this is inspiration to include such an option in a future Scrivener version nevertheless. Would be great, however, it’s no big deal and I surely can live with it. It’s a very nice text program, thanks for the great work!

Hi,

We have a lot of German users and this has never been an issue to the best of my knowledge - Scrivener uses the OS X text system and so has all the features of a regular text editor, and I don’t know of any word processor that has a specific feature for this other than through styles, and you could do it that way too. You could set up two presets and assign keyboard shortcuts to them as follows:

  1. Create some text in the editor, some with an indent and some without.

  2. Select the text without the indent and go to Format > Formatting > New Preset Selection and name it something like “Regular Text”.

  3. Do the same with the indented text and name it something like “Indented Text”.

  4. Use Mac OS X’s “Keyboard” section of the System Preferences to assign keyboard shortcuts to “Regular Text” and “Indented Text”. (You can find instructions on how to assign keyboard shortcuts here: literatureandlatte.com/wiki/ … _shortcuts )

Now you just type away and then when you come to type a quote you hit the keyboard shortcut for “Indented Text”. To return to regular text, you hit the keyboard shortcut for that.

Hope that helps.

All the best,
Keith

Also if you use indents (rather than tabs), it is possible when you compile your manuscript to set it so that the first line indent does not appear on the first paragraph of documents you’ve set to start on new pages, which should work to get rid of the first “new chapter” paragraph indent. Though if you’re just switching formatting as Keith suggests, this is probably unnecessary.

Thanks a lot for all the help here, really appreciated. I will try all the things suggested - but mabye I’ll just end up to use the indents in the current complete automatic way (as I’d really like to not have to think about shortcuts, tabbing etc. at the right times while typing) and just have a look over the whole manuscript after compiling and deleting the “wrong” indents (which won’t be TOO much, I guess.) But I’ll have a deeper read again later to your suggestion - could be that I’ll still figure out an even better way.

However, what really surprises me is that I’m the only one with this. It DEFINITELY is the normal way in all German books that the first line of a chapter/scene/etc. or the first line of a new paragraph, separated with a blank line, does NOT have an indent. I just checked at least 10 books. And I even checked my English books - you are right, some of them have it the way Scrivener handles this, but for example “Fight Club” by Chuck Palahniuk (hardcover) - same thing, NO indents at the very beginning of the chapter and beginnings of separated paragraphs. Johnny Cashs autobiography - NO indents (at least with separated paragraphs, the first lines are always a little bit in the middle because of the chapter number) Bill Carter: “The War For Late Night” - same thing. etc.

Anyway, no big deal. I can live with that if really nobody else desires this option. This is a tiny personal problem, I guess and Scrivener stays a great program.

Well, it could also be that what you see in a finished, printed book in the store is formatted differently from your manuscript submission. Most times editors/publishers/agents ask for a certain submission formatting to make the manuscript easy to read and mark up which is going to be completely different from how it gets laid out and printed and bound when it’s ready to be published. When it comes to that final formatting, in most cases someone else will take care of the work for you.

Oh, wait, do you just mean the first paragraph for each new section? If so, that’s a layout option and you really shouldn’t be worrying about that while you’re writing (and really, that would be up to your publisher at the typesetting stage - that isn’t the business of writer). If you’re self-publsihing and need it, though, you just use “Remove first paragraph indents” in the “Options” area of the “Formatting” pane in Compile.

Hi Keith,

I meant both - not only the beginning of the very first paragraph of a new section, but also the beginning of every paragraph separated with a blank line. However, this option at least helps me with the first case. Thanks a lot for this hint, also to MimeticMouton, who suggested this, too. It really is no big deal, because you’re correct, of course - the final layout will be made by the publisher. I’m not self-publishing and my last book (written with Word) had a worse layout when I gave to to my publisher, so using Scrivener already is a great improvement for me!

I’ll play with all the possibilities and functions of Scrivener in the next few days to get an even better feeling for it. Please keep up the good work.

Well, I’m glad this subject has come up. I’m not German and I definitely want the first line of new paragraphs not indented, AND any paragraph within a chapter that is separated by a blank line. As far as I know this is very common, I’ve just picked up Anni Proulx’s Close Range, and yes, this is how it’s done.

And, for example, some of my chapters have a little subheading, the fix above helped that subheading to not be indented, but then the first line is indented.

And I get the advice about not worrying about formatting, but to me these seem like obvious necessities…:wink:

Sandra3, have you read the above - i.e. that you can already do everything you want via the “Formatting” pane of Compile? To repeat: Just click on the “Options” button in the “Formatting” pane of Compile and tick “Remove first paragraph indents”. That will handle most cases.

If you have subheadings, as you say you do for some documents, that will be problematic because Scrivener can only flatten the first line - and how can it possibly know which line you want flattened otherwise (until it gains full consciousness of course :slight_smile: )? If you have subheadings, then you will need to think about which formatting options will work best for you to achieve what you want rather than using the default settings.

For instance, you could have the subheadings added at Compile time (by using document titles for the subheadings and ticking “Title” for instance) rather than typing them into the document directly.

Or, you could centre the subheadings in your documents - Scrivener will flatten the first non-centred paragraph in the document, so this will allow Scrivener to skip your subheadings and flatten the paragraph you want it to.

Or, if you want more control, then either:

  1. Don’t override the text formatting during compile (untick “Override text and notes formatting…” in the “Formatting” pane) and set the indents and formatting up exactly as you want in the editor, so that they compile the same way. “Override text and notes formatting” is fantastic for reformatting all the text upon Compile, but if you need complete control then you can just turn that off and format things yourself in the editor.

  2. You keep formatting override on in Compile but tick “Preserve tabs and indents” in the “Options” panel of the “Formatting” pane. Then just set up the indents you need in the editor itself as you type, and they will be respected when you compile. Doing this will mean that all your formatting is still overridden except for indents (and tabs).

In other words, you can set up any indents you want in Scrivener just as easily as you can in other text editors or word processors, but obviously if you are using the “Override text and notes formatting” option in Compile (which is on by default for the novel format seeing as that is set up for standard manuscript format) then you will need to do a bit more work because you are telling Scrivener to override all of your formatting except this bit or that bit… But it’s still perfectly achievable.

In short, these “obvious necessities” are all already there, and easy enough to achieve: you have complete control over how the text is output in Scrivener. It might be helpful to check out the comprehensive section on Compile in our manual if you haven’t already.

Hope that helps.
Keith

Thanks Keith, your option 2 looks great. I will try to read more manual next time I post!

And I’ll put on my reading glasses - “Sandra3” indeed! :slight_smile: I do understand that the manual can be quite daunting. High on our list of priorities is put together a video tutorial showing some of the various ways you can customise the formatting in Compile, and this will be a good thing to cover.

All the best,
Keith

I’ll stick with the suggestions from KB und MimeticMouton, too, and I guess they’ll work fine - nevertheless, I don’t want to let this thread die without the suggestion that maybe in a future Scrivener update, there could be an added full-automatic formatting option be included: always indents EXCEPT at the very beginning of a chapter and EXCEPT after a blank line. I don’t think this is a very special wish of only us two users as it really is the common formatting in most of the books. Such an additional option would be nice as it would be even better, full-automatic and more convenient than the suggestions. (If I understand them right.) However, they will also work, of course, and it’s no dealbreaker for me considering the rest of the “package” when using Scrivener. Thanks for the hard work and support here. Scrivener is awesome.

Your suggestion would only work for your case - and the current options work for your case already. Your suggestion would only work for SandraJ if she had a blank line between her headers and the following paragraphs; if not, your suggestion would fail - it’s just not general-purpose enough, and would fail much more often than the current solution (which works superbly for the vast majority of cases).

It’s not a “special wish”, no - because it doesn’t need to be a wish at allsince Scrivener is already just as capable as any other word processor of generating text with the exact indents you want. You have total control: for overriding formatting, the current options work amply well for most straightforward cases; if you have more specific formatting needs, then you just have to turn off some of the auto-formatting options and handle them yourself, just as you would in a regular text editor or word processor. Sadly, software has not yet evolved to the point where it can discern the user’s exact intentions. Maybe in 5.0. :slight_smile:

Thanks for the kind words!

All the best,
Keith

I’ll add one other short thing, and that is to me “a blank line” means a minor scene or section break. Thus, something you can break apart in the Scrivener outline and then treat with an “Empty Line” in Separators for text file to text file joins (top option). Now you aren’t typing in your extra space in the editor but just putting the following text into a new outline item. You needn’t worry about indents or typing in anything special while writing. The compiler inserts the blank line for you, and with the aforementioned “Remove first paragraph indents”, these new first paragraph of these sections will not be indented, just as you require.

This method works whether you are using full format override in Compile, or not. Meanwhile you’ve built a “rule” for formatting using the provided tools, which is in my opinion superior to a special-purpose checkbox that does this and then only works for one very specific way of composition—but Keith has already held forth on that notion so I will not add any further to that argument.

Hi Keith,

thanks as always for your answer. To be honest, although my English is quite good, I have to study your “manual” ways to set up formatting the way I desire more carefully again - as I don’t understand it 100% completely yet. I thought the main difference still stays that - with your method - I have to manually have in mind while writing where to set indents and where not, in comparison to a full-automatic way where pressing “Enter/Return” and everything is automatically fine all the time. However, I’ll definitely figure this out, so no need to explain again. I guess I will go the route to write with the standard setting (indents all the time), so that I don’t have to care at all about that while writing and can concentrate on the writing only. My manuscript will be 95 perfectly formatted after that - especially when I also choose to leave out the first line indent after exporting. After that, I’ll simply delete all the leaving wrong indents (when starting a new paragraph with a blank line) in Word which won’t be too much work I guess. This seems the better way for me in comparision to manually have to keep an eye on it while writing as ridiculous as this may sound … (If I understood your suggestion correctly - I can’t get my desired formatting full-automatically to work with editor rules while writing, can I?)

Man, I’m sorry for being so difficult with this question. Again, my English is quite good, but this is a very specific “technical” thing which makes it so difficult for me to communicate in English about that. Sorry for that again, your help was really appreciated. Again: I’ll figure the best way out for myself. Whatever solution I will use, Scrivener helps me a LOT in comparision to other word processors. Thanks for that.

It should be pretty easy, actually, since if I understand you, all the instances that you might have to correct would occur after an empty line. So you could use Word’s search tool to jump to every instance of an empty line and then just fix the indent of the following paragraph if necessary. You might even be able to automate this with a search/replace, but I’m not so sure on that one since it’s a paragraph formatting replacement. (I don’t have Word for Mac, so I can’t check this easily for you, but I imagine it’d be covered in Word’s help.)

Hi MimeticMouton,

exactly - the wrong indents will only occur after a blank line within a chapter, so they are quite easy to trace. If there’s no way to have the text 100% formatted the way I desire while writing in Scrivener or when exporting (which is how I understood the suggestions - that I still will have to keep an eye on these unwanted “after blank line” indents manually, that’s why I still suggested a future custom option which works full-automatically), this solution will be okay for me.

But why have the blank line within a chapter, when you can break the chapter apart into smaller sections? If you break it into smaller sections - assuming these are scene breaks, then Scrivener can add the blank line in during compile and flatten the first line indent of each scene.

If you really don’t want to do that and for some reason wan’t to have blank lines inside each text file, then you will have to handle it manually - but then you would have to do so in any other text editor anyway.

All the best,
Keith