Formatting styles not updating when compiling

I’m breaking my head over this; not sure if it is a bug or if I’m just doing something wrong.
I’m using beta 11.

Compiling document for pdf or epub.
I assign layout styles for heading and section text. I use copies of the built in formatting, so that I can edit them.
I go to section layouts, select the layout for eg. section text, edit the formatting (font, font-size, indentation, spacing) and click the save button. Compile: nothing changed. No formatting applied.
Try again:
change the formatting, save. Open change the formatting again: nothing saved.

The e-book styles are the worst, at the moment: those deliver only a massive block of text, both the epub2 and epub3 (Freda, Kobo, Calibre). But for PDF it is bad as well, but I can use the modern format a bit (even though I hate Arial).
Yes, I have tried creating a format from scratch, same problem. Defaults to 'arial and doesn’t let me change any font/paragraph formatting.

I’ve tried ‘override the formatting’ checkbox (on/off), no difference. What am I doing wrong?

Might be a dumb question; so please bear with me. Do you associate your layouts to the different section types that you have defined for your chapters?

Because I do that and it works quite nicely.
Looking at my learning process with the new compiler, I can’t see any other reason.