Found solution for table column width greyed out and copying a list into a Scriv table

I’m running Scrivener

Up to today, table width worked perfectly. I could resize column width. However, I could not copy a list of items into a Scrivener table. The items would all go into the first table row cell. I tried to solve this by first copying the list into Excel and then copying that table into Scrivener. It worked, but when I created the table my column width was greyed out and I could no longer resize the table column width. In fact, all my tables had lost the ability to resize the column width.

I was able to get the resize working again. The culprit was the copying of my list of cells from the Excel spreadsheet. Deleting the Scrivener sheet in which I had inserted the excel cells, and restarting Scrivener restored resizing column width functionality.

However I still couldn’t get an external list into a Scrivener table, so that each item didn’t have to be retyped into the table. After some more messing around, the following seems to work OK. 1) Create a new Word document, and save in RTF file format. 2) Create a table in the Word document with the same or more number of rows as lines in the list. 3) Copy the list. 4) Select (highlight) the rows in the Word table before pasting. 5) Paste, with “Use destination theme”. The list should copy into the Word table, each line in a separate row. 6) Now copy the Word table that contains the list items into a blank area of a Scrivener sheet, Ctrl-V. The table with the list should copy over. The copied table will have all the functionality, including resizing column width, and resizing the whole table to window size.

If your column width is greyed out and doesn’t work, you may have copied an excel table into Scrivener at some point in time.