Freeze upon option-expansion in the tutorial outline

Hi Keith,

The new release is superb. Scrivener is the top tool in my drawer, and now here it is all shiny and streamlined with several great additions. Thank you very much.

Sorry to report the following hangup while I was working through the new Tutorial on my MacBook Pro 2.33 GHz Core 2 Duo System 10.4.11. The version of Scrivener I’m using is the NanoWire Preview which I downloaded and installed on Oct. 25.

Everything seemed hunky dory until reaching Step 10 of the Tutorial when I followed your directions by holding down the option key as I clicked on the expansion triangle in the topmost folder shown in outline mode. Instead of opening each child container, the triangle turned sidewise and just sat there. I toggled the triangle a few times, and then, unfortunately, a cascade of aberrant behavior kicked in. I have forgotten the precise series of commands I issued through icon-clicks and pull-down menu selections, but with successive commands, the behavior of the application worsened until the tutorial project became nearly unresponsive. Scrivener did not freeze entirely. A new mostly empty project I had created earlier was still open in the background, and when I selected that project (through the Windows menu) it came into view, and when I closed it by pressing the corner red button, Scrivener backed it up to the appropriate Library folder. But I could not close the Tutorial project by either pressing the red button or by the File/Close menu command. Nor could I Quit Scrivener by the File menu command. The Force Quit dialog screen did not list Scrivener in red letters as unresponsive. I have not yet tried to force quit Scrivener since I am hoping I can somehow prod it to write a report to the Crash Reporter (I know that would be of help to you).

Absent a crash report, I’m attaching three files:

  1. A screen grab of the frozen application
  2. The list of processes that were running while all this happened
  3. The console.log which does say (repeatedly) that a “selector” was not recognized throughout my ~1.5 hour session with Scrivener, including the first half-hour or so of normal behavior. The freeze-up occurred at about 8:28 on the system clock. Nothing was posted to the system.log in the time since I launched Scrivener this morning, but I have saved the system.log in case you need it (I can only post three files per Board message).

Wishing you great success with the new release. I know from personal experience (Scrivener 1) that you promptly work to eliminate the few bugs that inevitably arise. And so to anyone thinking of adopting Scrivener 2, I highly recommend a test drive of this outstandingly useful software.

Best regards,
Phil M.
screen_grab.jpg
console.log.txt (128 KB)
Exported Processes.txt (6.92 KB)

Hi Phil,

Sorry for the late reply. Now that the initial release is out of the way I’m concentrating on fixing all bugs as soon as possible for a 2.0.1 patch. Your console report seems to be the key - my guess is that clicking on the triangle was just the last straw rather than the cause, as there were a lot of errors reported in the background (well, I say “a lot”, but they were all the same error).

Do you have any old 1.x templates on your machine? (They will appear in the “Miscellaneous” category of the New Project panel - and if the “Miscellaneous” category won’t open at all, then that is a clue in itself.) The error looks like one I was looking at the other day relating to a stray template, although I had thought it was caused by an intermediary template format that was never made public - it could be that I was wrong and certain 1.x templates affect it too.

Or, had you tried creating a template using File > Save As Template during the session? The most likely culprit for the console messages are certainly template-related.

Can you reproduce these errors still?

EDIT: Also, did you create any keywords before this, or had you updated any projects? It may be related to this bug:

viewtopic.php?f=3&t=9233&p=74593#p74593

That bug seems to indicate that in some circumstances an image object can be created as the title for a keyword instead of a text object, and your errors are caused by an image object appearing where a text object is expected. This would be keywords-related rather than template-related - which may make sense seeing as keywords are covered as part of Step 5. Anything you can let me know to narrow it down would be great.

Thanks!
Keith

Hi Keith

The freeze happened while I was working with the NaNo version. And you’re instincts are correct: I had forgotten (but now remember) that I ran into the odd keyword behavior (described in the post you mention) when a string beginning with “NS…” found its way into the keyword HUD while I was playing around with keywords.

I did try to reproduce my reported freeze in the NaNo version, but when I re-launched the application, the expansion triangles in the outliner worked fine. I never thought about trying to reproduce the keyword bug. And to answer one of your questions, no, I did not create any templates.

Now I’m working with the Scrivener 2.0 installation. (I kept the the NaNo version but moved it to another directory in my Home directory). In 2.0, the Miscellaneous Template option is visible and functional in the New Project dialog screen (the listed templates are shown in the attached screen grab). I’m also attaching the template directory structure as a screen grab.

Hope that helps!

Phil

PS Sorry, I can’t get the screen grabs uploaded because of server timeouts – Nice to be part of this celebratory Scrivener traffic jam!

PPS I guess I honked loud enough. I have now attached those two screen grabs.


Hi,

I fixed a whole bunch of bugs today, including the keywords-on-Tiger one that you encountered, so try re-downloading and re-installing (clear your browser cache first). Once downloaded, ensure you’re on build 6076 (it says in the About panel).

Thanks,
Keith