Freezing

After awhile Scrivener Freezes up…and I can’t shut it down no matter what I do, I have to reboot the computer to start it over again
At first I thought it was because I was saving my novel on OneDrive and not in the computer or Scrivener folder so I totally removed Scrivener and reinstalled it where it wanted to go… but it froze up again last night. It was working fine for about a week but now I cannot trust it because sometimes it doesn’t save the last works I type before freezing up…
Yes even Crtl-Alt-Delete= task manager doesn’t work to shut it down…I have to reboot the computer.

This is totally unacceptable and makes the program not usable as a reliable Novel writing program…

If there is an error log I can send or something let me know…

I’m having this same problem, it started yesterday (22nd Nov 2015). Right now the only thing I can do that closes down the program so I can re-open it is to shut down my whole computer. I’m using the NaNoWriMo trial on Windows 10, if that’s any help, is there any way to fix this?

Mine started a while back but I wasn’t writing daily so I didn’t notice it was a on going problem…
But I think it’s related to Win 10 but I’ve tried the compatibility tool and it didn’t help…
I don’t know but I’ve taking everything out of it for my current novel and loaded in to Quoll Writer
Until I see some fix for this problem I won’t be using it…

I’m having the same problem too… but only as of this week (24/11/15). I can work on the page that’s already open, but as soon as I click on any item in the left hand menu it just freezes up! I can close it by manually killing the Scrivener process. And I can re-start it after that. But as soon as I click on the left hand menu again-- it just freezes. This really needs to be sorted out because I’m not sure I’m able to get all of my content out of it…

Okay I can’t help but feel relieved that other people are experiencing this too! Sorry, sounds kind of mean… :unamused: But I’ve had freezing since last wednesday and asked about it on this forum. I figured since no one else seemed to be having the same problem maybe it was just something I did. I have racked my brain trying to solve this problem, then gave up eventually.

I don’t know if it’s related to Windows 10, at least that’s not what I use (mine is Windows 7 Pro).

I get the feeling that it’s something more to do with Scriv 1.9 than Windows 10. I haven’t updated to 1.9 yet, and I have 1.8.6 on two Windows 7 computers and a Windows 10 computer, and I haven’t noticed any freezing issues such as described here.

I’d say that you could try uninstalling the 1.9 trial and installing 1.8.6 from here:
http://www.literatureandlatte.com/scrivWinChangeList.php, but I know that 1.9 uses a different file format, so I don’t know what kind of conversion you’d have to do to get your stuff to work. Also, I don’t know how the trial time limitation would transfer from the 1.9 nano version to a 1.8.6 non-nano version.

Maybe someone from L&L could weigh in?

I installed 1.86 over 1.9 and it worked fine… I’ll reinstall my novel later and see if it works…

Froze again… Sorry Scrivener is not going to get any use or praise from me until they fix this problem
I was just loading the front matter and it froze…won’t shut down nothing …

I’m having the same problem. I recently reinstalled Windows and was racking my brain trying to figure out what I’d done differently to cause this as it was working fine before. The only difference is a memory upgrade and loading 1.9.0 instead of 1.8.6.

I was wondering if 32GB of RAM was crashing it, but starting to doubt that now. Hope we can get this resolved. It’s nerve-racking, especially when you’re in the middle of a scene!

Same problem here. It happened in middle of writing text. I was able to still move the mouse around and open/close other programs like Google Chrome and a Word Document, but Scrivener was completely frozen, (Not Responding). I’d leave for half an hour, come back and it still said (Not Responding). Clicking the close button and using Task Manager to End Task didn’t do anything either and I have to restart my computer. I’m using Windows 8.1. 3-4 times it happened while I was working offline, so I tried working online in case it needed to be connected to the internet for some reason and it still froze up again. I even reset my laptop back to factory settings before getting this program and the only problems it’s having is with Scrivener. Getting tired of these bugs, and this is still only the one month free trial for me.

Update: Make that 6 times. Within 2 minutes of trying to get to work on my document, Scrivener froze.

So this is more common than I thought…
I’m not selling anything here but until they fix it…I can’t use it…
So down load Quoll Writer…it’s free like yWriter5 but nicer to use…and when they fix this move back to it…
I really like scrivener but this is unusable in its current state…

Uninstalled, tried to see if I could get my project to open with 1.8.6, no such luck. Went ahead and applied the upgrade. Finished up a section in a chapter, selected the next section and began editing. Eventually did the lock-up, nonresponsive thing. I’m like 90% done with my novel here, this is killing me! :confused:

Update . . .

So I opened my project folder and attempted to open the .rtf file for the section I was working on so I could continue to do so and possibly cut and paste it into Scrivener later. Interestingly enough, every section loads into Word save for the one I was working on when Scrivener froze.

Is it possible there’s some sort of file corruption occurring that’s causing the lockups? Just throwing out an idea for your software guys.

Same story as everyone - locks up & have to restart my computer - and now Scrivener won’t even open on Windows 10. Pretty sure I’m running 1.9.

I’ve been using Scrivener since 2011. Never had a problem like this. Very disappointing.

Also, this was happening daily for a few days, then I changed the auto save from 2 to 8 seconds. Worked great for about a week then locked up today.

I probably should have limited this reply to one paragraph and will likely regret it, but here we go. Hope it is of some assistance.

Simple version…

I would suggest that you each, individually, report the problem you are experiencing to Literature & Latte’s technical support, via email, as discussed here:
literatureandlatte.com/support.php#section-email
They may be swamped, what with NaNoWriMo and holidays, but I’m sure they’ll get to you.

If you haven’t already done so, you might consider seeing if compatability settings will help…
scrivener.tenderapp.com/help/kb … y-settings

If you are using a cloud backup/sync service, you should review the Cloud Syncing articles here…
scrivener.tenderapp.com/help/kb/cloud-syncing


Complicated version…

That said, a few comments from a cranky old burned out retired technical support person with a couple of decades experience in Windows PC/network deployment and support…

Plain and simple, the fact that one experiences a problem with a given application, such as Scrivener, does not prove or guarantee the problem is in the given application. It is as much or more likely that the problem is in the environment on the PC that that the app is running on.

As far as the app itself, one can uninstall it, then download a fresh copy and reinstall from it, which may help. A previous download or install might have gotten corrupted or something on the PC may have corrupted the installed version later.

As far as the environment on the PC, that gets trickier.
There are legitimate packages (antivirus, …) that can interfere, unless tweaked. And there are illegitimate and/or poorly implemented apps and updates that can interfere. Changes happen on PCs for a variety of reasons, often without the user’s intent or knowledge.

Trying to sort through possible causes gets complicated. If you know or can afford a knowledgeable PC tech with a good track record, consider getting them involved.

A review of Windows event logs may turn up something. Responsible well written apps report problems and details there.

A review of the installed programs list may turn up something. What are they? Are they needed? Simplify the environment as much as possible.

A review of programs being launched behind the scenes at Windows startup may turn up something. Read up on using the msconfig utility, regarding checking its Startup tab to see what all is being started, and temporarily disabling such, in order to rule them in or out as likely suspects. Likewise, read up on rebooting/restarting Windows in safe mode or diagnostic mode (in which all that extra stuff is not started) so as to see how Scrivener works without all the extra/optional stuff running.

Words/phrases worth searching for, both on the Literature & Latte forums and the Internet in general, to see what causes and fixes have proven to be, include freeze, antivirus, keylogger, not responding, msconfig, safe mode, etc.

The issue of an app that is experiencing problems not being killable via Task Manager’s End Task command is generic, not specific to Scrivener. A Google search on “end task not working” turns up discussions of this happening with a variety of apps. Two examples, with relevant quotes follow. You’ll also find discussions of techniques and utilities that can probably succeed in killing such tasks that End Task can’t handle.
stackoverflow.com/questions/4998 … in-windows
“If it doesn’t go away, it’s currently locked waiting on some kernel resource (probably a buggy driver)”
blogs.msdn.com/b/oldnewthing/arc … 83787.aspx
“A process only goes away when all I/O requests it issued are completed or canceled. A buggy driver can hold an I/O request indefinitely and not support CLEANUP. This will prevent the process’ address space from being destroyed.”

Leaping to conclusions and getting self righteous is easy. Getting results, not so much.

Six reports in this thread of this sort of a problem does not constitute “everyone” and does not necessarily reflect on Scrivener.

In my case, I’m running Scrivener 1.9.0.0 on Windows 10 Pro (64 bit), currently without any issues. A few weeks back, I had a couple of days during which I had to try to launch Scrivener multiple times before it would finally start successfully and present the project I’ve been working on for several months. The problem went away, so I didn’t get around to digging into what was going on. It could be Scrivener, but it’s more likely one the numerous other apps or utiities present, their interaction, malware, intermittent hardware issue (RAM, hard drive), general build up of crud, … was at fault.

If you follow Mac forums, you’ll find the same issues exist in the Mac world, too.

Agree with SpringfieldMH.

In years of supporting Windows as an IT professional, I have found that the most common cause of application instability is one of these:

  1. Bad driver code. If you’re seeing a BSOD, it’s code that is running in the kernel. Applications cannot cause BSODs in modern Windows. They can call a function that calls code in the kernel, which swaps into a driver to execute the task, and there’s a bug. BOOM. As a result, the two most common drivers that are guilty are the graphics driver or the storage driver, with the network driver a distant 3rd.

  2. Anti-virus/enhanced firewall packages. The easy test is to unplug your computer from the network/disable Wi-fi, disable your anti-virus/firewall/all-in-one protection whizamajig, and then try using your regular applications. Dollars to doughnuts, your problem disappears.

Well I appreciate it, in a sense, fellas, but no one here as far as I can tell has complained of BSOD’s. The problem is quite specific to the service for particular application freezing.

I myself have ~20 years in corporate IT, and if you have multiple users experiencing the same problem with an application, it’s generally an application issue, regardless of whether it impacts all users or not.

That said, after I did my install and upgrade of the prior version and back up to 1.9 yesterday I recalled that I hadn’t loaded KindleGen yet. I did that and experienced no lockups in a several hour long writing session last night. So for those of you who are having the problem, maybe give that shot as a troubleshooting option.

So your saying… too log into KindleGen to see if this works…

I have been running into a problem with Avast Web protection…protecting to much lately, maybe that has something to do with it(udating or ?)… I’ve turned it off for now…Lets see …

Go to File–>Compile–>KindleGen and see if you have a location set for it.

Maybe just a coincidence but I’ve had no lockups since adding it back in.

Yup, just a coincidence. Just had the lockup.

This time I had a Windows popup error available though, with the following info:

Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: Scrivener.exe
Application Version: 1.9.0.0
Application Timestamp: 56136372
Hang Signature: 5af8
Hang Type: 0
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Hang Signature 1: 5af81e1d429f3b55e736cf9cad1b2aea
Additional Hang Signature 2: 3c11
Additional Hang Signature 3: 3c11b9b6db0aad4b6a62fcd4a627889b
Additional Hang Signature 4: 5af8
Additional Hang Signature 5: 5af81e1d429f3b55e736cf9cad1b2aea
Additional Hang Signature 6: 3c11
Additional Hang Signature 7: 3c11b9b6db0aad4b6a62fcd4a627889b

Read our privacy statement online:
go.microsoft.com/fwlink/?linkid= … cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

So far so good…When I started it up this morning I reverted back to the current version…made sure Avast Web protect was off… and it’s been on since morning and I loaded everything back into it…no problems yet…

Avast Web protect was not letting me go to some known good web sites…(Not Porn:) ,and stopping some pages from totally loading…
Now all this could be that I’m running a second virus type program Baidu and Avast thought some actions of it were a virus…
My guess is there is a conflict between the virus programs and the program updating of Scrivener or some other reason it would go online…
I know that if Avast says somethinig is a virus,a page or download it will not open…in fact you can’t find the downloads…

So maybe I brought this on because of software that I’ve loaded lately…??? Time will tell