Frustration with Splitting Editor

I generally split my editor vertically. When I do this, every time, the original pane appears in the right side editor, which I must then go to View->Editor Layout->Swap Editors to move back to the left side of the split.

Is there any way I could always have my current (single) editor appear on the left side when I split it? It matters because I generally want to use it for navigation which I have set up to flow from left to right. It also matters because my corkboard customisations (size, spacing, etc.) go with the original pane, and I want that customised corkboard on the left-hand side.

Yes, I know about saving a layout under the Window menu but as I’m always visually tweaking (bigger index cards, smaller index cards, new monitor, different monitor, etc.) my layout list grew longer than the screen before I gave up on the function.

So if my only option is to use saved layouts, please just tell me “No, there’s no way to do that.” Thanks in advance!

1 Like

I’m pretty sure it has more to do with which split you left remaining the last time you closed it. The last split standing is the one that becomes the left split, because opening a new split does so to the right—the left is considered the primary side. Thus if you continually close from the right, you’ll get this kind of rotating effect because you are in effect moving the secondary editor over into the primary slot every time.

I.e. if you want the left split to be dedicated to one purpose, then close the right split when you’re done with split views for a while. In my experience closing from the left/bottom split provides a stable experience.

Now on that, don’t get me started on how weird it is that the bottom split is the primary!

But yeah, otherwise, Layouts. One of the many reasons I use them is to keep the environment stable, as having to choose which side to close based on where I want it to appear next time never really fit right in my head. To my brain, the left side should just always act like the left side always does, etc. If I close from the right, then toggling splits open and closed causes the left side to open and close, where it is, not round and round.

But… I’m reasonably certain that I close from the left almost every time, i.e., the left split is the one I want to have “take over”, so it’s the unsplit icon on the left that I click. Is that not what you just said?

Ah that explains it! It’s the other way around. You click on the side you want to retain. The same goes for the keyboard shortcut, if your focus is in the left side, when you press ⌘' to close splits, it is the left side that will remain.

If we meant it to be the other way around, the icon would probably be a little ‘X’ or something, to clearly indicate you are closing the thing you clicked on.

I’m still confused, but I’ll play with it a bit and see if I can figure it out.

Part of the problem here is that I almost never use keyboard shortcuts. I’m very visual and have few shortcuts memorised. Until you mentioned it, I had never considered that there was a keyboard shortcut to close splits. As soon as this thread is over, I will likely forget it again…

So I tried your keyboard shortcut and indeed it works exactly as you suggest. If I were to start using the keyboard shortcut I would have no problem. But no, what I do is click the split/close split icons in the header bar. And the header bar icons work backwards. It’s like the icons are wired up opposite of the way the you describe, and also opposite to the way the keyboard shortcut works.

For example, I start out with my corkboard showing in one editor. I click its split icon. The corkboard I was working on, which had the focus, ends up on the right side, when I’d prefer it to be left. (I can tell it’s not my corkboard on the left because the card size and spacing are wrong, and besides the highlighted “open in” icon is in the right editor footer bar.)

So fine. I use View->Editor Layout->Swap Editors. I switch the evil twin corkboard (now on the right) to Scrivenings view and work happily along. Then I decide I want only the corkboard view. I switch focus to my corkboard (on the left, remember) and click the close split icon in the left editor header bar. My preferred corkboard takes over the entire editor. After adjusting my synopses and having lunch, I come back and click the open split icon.

My corkboard opens in the right split. It’s even more frustrating because the danged keyboard shortcut would have opened it on the left. (I know. I tried.)

I suggest that there might possibly be a bug in how the split icons are connected to the split open and close routines. I could use the keyboard shortcut as a workaround, but I truly loathe keyboard shortcuts and will do a great deal to avoid them, including starting a long forum thread…

I gave up trying to memorise shortcuts – there are simply too many of them, especially if one regularly uses a number of complex programs. They just mount up until it is impossible. So I was very glad to stumble across this solution (it takes some effort to set up, but I find it beneficial): https://forum.keyboardmaestro.com/t/bettertouchtool-call-macros-macro-groups-with-applescript/13939

I realise it will not be for everyone, but maybe it is at least worth knowing that such a solution exists. It has certainly made my life easier. And it is very visual :slightly_smiling_face:

1 Like

Just to be clear, I was not mentioning the shortcut as a way of saying that is how you should work, but as a point of reference with expected behaviour—that the shortcut that toggles splits off and on (to their previous configuration) should function the same clicking on the split icon within the active editor you wish to retain (and as you note, interestingly enough it does not in all scenarios, which is probably a bug).

That said, I have a mind for shortcuts. I pick them up almost instantly and have probably several hundred shortcuts in my head across dozens of applications and three operating systems, and even websites (like here!). So it’s hard for me to understand why anyone would, from my point of view, stop typing to laboriously aim a tiny little arrow at a tiny little button. :wink:

Anyway, back to the topic at hand:

So that’s weird, I’m not really seeing that—in a way I’m seeing the opposite of what you are :laughing:. I wonder if using Swap Editors at any point makes a mess of things? I’m testing from a new blank project that hasn’t really had anything special done to its UI, other than making two outliners sufficiently different enough to tell which is which. I did try using Swap Editors, and while that disrupted things initially (because the content was swapped), after one cycle it went back to putting what I consider the primary content into the primary/left side, persistently.

  • Mouse A

    1. The split icon in the editor header bar is set to vertical, so I click it once.

      The primary is on the left, secondary on the right.

    2. I click the toggle split icon in the left/primary editor to close splits and retain this one. These two steps can be repeated indefinitely with the same result every time.

  • Keyboard A

    1. I press ⌘' to toggle splits on, using the previous orientation.

      The primary is on the left, secondary on right. So we remain in parity thus far.

    2. I press ⌘' again to toggle splits off, retaining the active left/primary split.

      At this point I repeate the “A” cycle, and everything remains as expected. I always get the primary setup on the left, and the secondary setup on the right, and switching methods between keyboard and mouse does not disrupt the pattern.

  • Mouse B

    1. I click the split icon to restore the previous split configuration. No surprises here, everything returns as expected with the primary/left editor active.

    2. This time I click on the toggle split button in the right/secondary split. Now what I’m looking at is the content of my secondary split, since I chose to retain that one.

    3. Click on the split icon to restore configuration.

      Now this is an interesting point of divergence from all of the other logic. We chose to retain the right split and promote it to the primary split side. However it doesn’t restore that way, it stays in the secondary spot on the right, and our previous primary (the one we want) appears to the left of it and deactivated (which is another point of divergence from the logic where the left/bottom split is active when opening splits).

      I wasn’t aware that it worked this way (again, I never use these buttons unless I’m testing them once every six or seven years), and while it could indeed be described as you did—as being the opposite of the expected behaviour—the weird thing is that it’s nevertheless the behaviour you want.

      I.e. whether I click on the left or right header bar’s split button, the primary sticks.

So in the end, I actually cannot get the secondary editor to migrate over to the primary slot with the header bar buttons. It’s impossible. I don’t understand how you are getting a different result, but I must be missing something obvious.

Ultimately it seems that the keyboard shortcuts (and the menu commands, since they are one and the same) are a royal mess. If you close a split with the right/secondary split active, it migrates into the primary/left the next time you open splits. If you toggle orientation with the keyboard, what should be primary ends up in the secondary spot (if you toggle orientation with the buttons it works logically).

In short I think the split code is haywire when it comes to the difference between the buttons and the menu commands. The way it works from the keyboard is counter to expectations and awkward. The way it works with the buttons seems fairly straightforward to me, and much like I was saying above: the configuration of the splits should never migrate and always be where you left them. That should be one of the advantages of a strict dual-pane setup—it is variable split interfaces that must suffer with floating settings.

But I realise you’re seeing something different entirely, which has me puzzled.

Just trying to understand.

If I have one editor with the draft folder in corkboard view and then click the split icon at the top of editor, I get the same corkboard view in both editors.

If I have one editor with the draft folder in corkboard view and then option click a file or folder in the binder, the editor splits and opens the selected file / folder in the right-hand split.

Both of these keep the original corkboard in the left-hand split.

What do I have to do to make the original corkboard open in the right-hand split only?

Thanks

Merx

Try being about seventy years old. I have been known to think “I must do x”, stand up, and think “what was I going to do?” And it can take several minutes to retrieve the information (when I actually achieve that). My hippocampus is shot. I find I sometimes cannot recall information I have known for decades, including names of people I worked with, important elements of subjects I researched and studied over several years – you name it. Shortcuts are a lost cause for me. Hence other solutions are a godsend!

Hey, I have my struggles as well, for me it is icons and too many unnecessary graphical flourishes that do me in, and I have to stand up and get away from the screen to calm my brain back down and regain my sense of balance. All of the rounded rectangles and bright colours in macOS 11 are really bad for me, for example I can’t remain productive with all of, what is for me, noise on the screen. Even the wireframe icon style that was used for a while was difficult.

But that’s why good software has plenty of alternatives, since we’re all different and get along with software in different ways. Some people right-click to copy and paste, others use the menu, others use the shortcuts, others use gestures, others use assistive interfaces… the more mechanisms the merrier, I say. And good tools like the macro setup you’ve got makes it even better.

Hmm, that specifically may be difficult, at least with how I think it’s meant to work, where the left is considered the primary and interface builds outward, rightward. Then again it seems Silverdragon has that going on somehow, so maybe there is a way, but I’m not coming up with a way of doing that, which is the confusing part of all this.

I heartily concur!

Interesting that you have trouble with the visual elements. I come from a family of painters, and my first degree was in history of art. So visuals are very much what I am used to.

Thanks, Ioa.

Indeed.

So many settings; perhaps something different in the options offered in the Navigate menu. Interesting niche thread.

Merx

It really depends on the style I think, I am a very visual person as well (I have a love of photography and sketching), which may be more the root of the problem than it being a generalised aversion to visual approaches. A sensitivity you might say, to the visual nature of things, to the point where certain approaches overload my brain. I have to turn the toolbars off in most programs, for example, because it’s just too much chaotic and competing information on the screen at once. It’s really hard to put into words, almost more of an intuition than something that can be easily analysed.

I must admit I was a little baffled by your description, “close from the left,”… does that mean click on the left editor’s un-split icon or the right editor’s?

Also, when I split a single editor, the right editor is the one that seems off; if I had split before, and then un-split and modified how the cork board is configured, that configuration remains on the left (adjusting for the editor’s new 1/2 width), while the right side uses whatever the settings were when I last split the editor. What you’re experiencing (the tweaks you made in a single cork board editing pane go to the right split) is exactly opposite what I’m experiencing. I’m using the little split editor icon in the upper right header bar of my editor, in case you’re using some other method to split, btw…

What I did notice, is that when I was fiddling with the splits, I habitually left my mouse in the same spot to split and un-split, which has the opposite effect of what my brain wants; it “expands” the right editor to take over, essentially acting as if I’d swapped editors and then clicked on the left split icon to go back to single-editor view. What my brain wants is “restore what I had when I clicked on the button at this location in Scrivener’s UI in single-editor view.”

So a potentially more convenient way to deal with what you’re experiencing: when you split vertically (getting editors on the left and right), and it comes out backwards to what you want, you can just double-click (without moving your mouse at all), and that should essentially swap editors without using the menu.

I noted that this phenomenon doesn’t happen with horizontal (top/bottom) splits. The new editor’s header doesn’t appear under my mouse in that configuration, so split/unsplit/split clicks don’t swap the editor. It’s probably too late to make vertical splits use that button to “close” the right split and let the other editor take over. Too many people are already accustomed to this behavior.

Digging deeper, I’ve found that this problem only affects one project. It’s an old fanfic project, one I pick up occasionally and add a story to when my brain runs dry on newer stuff. I may have even have brought it in from Scrivener 2 many moons ago.

So, I’m going to make a zipped backup of it right freaking now, import the old project into a new one, and see if that fixes the problem. If it does, @AmberV , would you like an obfuscated version of the hosed project for dissection?

Huh, you know that might be an old legacy problem as there was a switch when v3 came out. It used to be the other way around, where the primary editor was considered to be on the right/bottom. Maybe the project upgrade process didn’t take that into account or something.

I’ll give it a quick whirl in a test project using v2 and see how it goes, before bothering you with that.

Cool. If you do want it, fair warning, you may need shades to look at it as I have bright colour measled all through my documents… :wink:

1 Like

Experimental confirmation! Importing to a new project shell cured the problem. Now I have the collections etc. to transfer or re-create, but the irritating split behaviour is gone!