Full-page view: menu disappears and doesn't reappear

Hi there,

I just bought Scrivener, after enjoying the free trial. I installed 1.02 and now when I enter full-page view and move the cursor to the bottom of the screen, the menu (heads up display, HUD) doesn’t appear. (It appears when you enter full-page view for a few seconds but then vanishes). I’m pretty sure it was appearing before. Is this possibly a bug, or am I missing a switch somewhere? I restarted, but that didn’t help …

Any tips? OS 10.4.9, Powerbook G4.

It’s still a great program!

Best,

Andrew Sparling
Durham, NC

Strange. I can’t recreate this - I’ve tried it on a G4 and on an Intel and the conrol panel HUD works fine for me. Nothing really changed between 1.01 and 1.02 as far as full screen is concerned, which makes this particularly odd.
Best,
Keith

Hi Andrew, I’m using the same configuration you are, and am not able to replicate this behaviour. Full screen works as it always has for me.

Tim

Curious. When I installed the update last night, I was connected to an external monitor, which is my primary monitor when I am not working in a coffee shop (as I am at this minute). I did not play around much with the program last night, but I think the HUD came up as it should.

I will see what happens when I plug in to the external monitor again late tonight and let you know.

In the old days I would zap the PRAM, but I’m not sure if that’s still something one does, and I don’t know how anymore.

I had Safari, Eudora, Word, and Endnote running simultaneously. Eudora doesn’t always play nicely with others, but I can’t see it interfering with display.

Is there a keystroke that will bring up the HUD?

aws


Okay. When I shut down and reconnect my external monitor, which is set up as my primary monitor, and restart, the HUD works as it should, appearing when I move the cursor to the bottom of the screen. And when I move the Scrivener window to the laptop monitor, it works there too.

To reiterate, when I installed the update and when I installed the original version, the external monitor was connected. I may not have shut down when I disconnected the external monitor, but I did restart a couple of times with the external monitor disconnected and the HUD did not work after restart.

When I first noticed the problem, before restarting, I went to the system settings, chose displays, and hit the “detect displays” button to make sure that the OS took note of the current configuration. That did not wake up the HUD in Scrivener.

I hope this is helpful. I can try other things, including trashing preferences (if I can figure out how to do that properly in OS X) and reinstalling the program, tomorrow.

P.S. I LOVE full-screen view. It really helped me clear my mind today and hash out a couple of key sentences for my chapter intro for my diss.

Thanks!

Update: I shut down with the external monitor attached last evening and restarted this morning with the external monitor detached. The HUD no longer comes up in full-screen view when it should.

I tried deleting the preferences list (plist) file for Scrivener that I found in the preferences folder of the library folder of my user folder. That didn’t solve the problem.

Sorry, I’m still confused. Is this a dual-screen setup issue, or is it just an external monitor issue? Does the problem only occur when you connect to an external monitor after you have used Scrivener in full screen on another monitor? Can you give me step-by-step instructions to reproduce?
Thanks,
Keith

Sure.

When I have the external monitor connected, things work fine, on either screen. I have the two screens configured as two parts of a contiguous work surface, i.e., the laptop screen is not set up to mirror the external monintor.

When I am using the laptop without an external monitor, the HUD disappears when I enter full-scrreen mode after ca. 3 sec. and does not come up when I move the cursor to the bottom of the screen.

I installed Scrivener originally (and installed the updated version) with the external monitor attached. I first noticed the problem after installing the update and with the external monitor detached.

Shutting down before disconnecting the external monitor and cold restarting with no external monitor does not make the problem go away.

If you could tell me which files to delete to do a complete uninstall, I could see if a clean install banishes the problem.

Much obliged. If I can provide further info, please let me know.

I continue to write constructively and thankfully in the crystal-clear mental environment of full screen mode.

aws


This is really weird. The only files to uninstall are Scrivener itself and com.literatureandlatte.scrivener.plist (the preferences file). You could delete the Scrivener files in Application Support too, but that wouldn’t make any difference. The really strange thing is that no code changed in this arena between 1.01 and 1.02. And you are saying that if you have no external monitor attached, the HUD does not appear when you move the cursor to the bottom of the screen on your PowerBook? Weird. The only reason I could think of this not working is if the screen resolution changed while using full screen. Very odd indeed.
Best,
Keith

I suspect the problem may have been there all along for me but it was only yesterday that I tried using full-screen mode with the external monitor detached. Therefore it may not be an issue with the update at all.

I suppose I could try toggling through different screen resolutions, but I doubt it will help. Is there something I can do to zap any Apple prefs?

Some Apple preference file with bezel in the name had changed recently, but I was afraid to mess around with system files.

The only Scrivener plist that I deleted was in my home directory library, not in the root. Did I miss one?

If I could remember the keystroke for a screen shot, I could send you one of full screen with the cursor parked at the bottom, but it wouldn’t actually convey any new information (other than that I am not a lunatic–at least about this phenomenon, at any rate).

I also tried turning off the dock and moving it to the side (I normally have it at the bottom). That too didn’t seem to make any difference. But if yhou can propose a more systematic approach that might help to isolate the problem, I’ll be happy to follow it carefully and report back.

Could you open Console.app and see if any errors are getting written out to the console when you move the cursor to the bottom of the screen?
Thanks,
Keith

You may have to walk me through this, I’m afraid. See if I’ve done this right. I’ve opened console. Now I go into Scrivener. I enter full-screen, I wait a few seconds, the HUD disappears. I move the cursor to the bottom. I toggle back to Console using cmd-tab. I see nothing new, only the following:

Mar 30 12:58:16 Andrew-Sparlings-Computer /Applications/Multimedia Æ’/Adobe Reader 6.0 for OS X/Adobe Reader 6.0.app/Contents/MacOS/Adobe Reader: Invalid color: colored pattern specified with uncolored pattern colorspace.
Mar 30 12:58:16 Andrew-Sparlings-Computer /Applications/Multimedia Æ’/Adobe Reader 6.0 for OS X/Adobe Reader 6.0.app/Contents/MacOS/Adobe Reader: Invalid color: colored pattern specified with uncolored pattern colorspace.

I try again: move the cursor to the bottom of the screen. Return to Scrivener. Hit “reload” in the top menu. Nothing new. And I quite Acrobat a few minutes ago, incidentally. Current time is 13:04.

I’ll be offline for a half-hour to an hour, but I should be back on after that.

You did everything fine - it just looks as though no errors are getting written to the console. Which sort of suggests that the HUD isn’t detecting the mouse going to the bottom of the screen at all. Hmm. Presumably the full screen wndow has focus? Click on the full screen window before moving the mouse to the bottom to be sure.

I am away on holiday tomorrow, so this issue is probably going to have to wait a week or so, I am afraid.

Best,
Keith

A little further detail on what the cursor actually does: as I move it to the bottom of the display, it remains as an insert bar until about halfway over the black line at the bottom of the full-page view and above the screen’s bezel. At that point it changes into an arrow.

Yes, the screen definitely has focus. Thanks for your help and enjoy your holiday. I will work with the external monitor as much as possible over the next few days. But even with the HUD not working, I dan always toggle out to get back to the controls.

If this were a Microsoft problem, I’d still be trying to cut through to a human–I’d be getting bot-produced e-mail messages back that parroted my own but with the pronouns reversed and the verbs reconjugated, like Eliza, I think it was, the old psychiatrist program. “You say your problem is …” Your first reply came last night 7 MINUTES after I posted my first query.

Meanwhile I am telling everyone how great Scrivener is. For writers, I think it’s pretty much sufficient justification to buy a Mac, all other considerations aside.

You can still zap PRAM, which comes in handy now and then - just restart and hold down Command-Option-P-R, and keep it held down until you hear the startup chime a total of 3 times, then let go.

But I seriously doubt it will help in this situation.

Not to hijack your thread or anything, but I LOVE that program! I used to spend endless hours seeing what kind of stupid things I could make Eliza say.

My favorite so far:

ELIZA: What seems to be the problem?
ME: I am an idiot.
ELIZA: It seems we have much in common!

Sorry. Back to the topic…

Why three times? Just because that’s the magic number?

Actually, I was wrong about that. Your question made me wonder, so I looked it up, and you only have to do it until the second chime. I was always taught to wait for three, but that was back in the day so maybe it’s different now.

There’s a helpful article about zapping the PRAM here:
http://docs.info.apple.com/article.html?artnum=2238