Full-Screen Background Photo

I put up a background photo for my full-screen, but I don’t like it. Plus, I cannot make it fade with the slider bar at the bottom right. I tried to replace it with (first) a different photo, and (second) the default background color. Neither of these attempts has worked for me at all. I’m not sure what the problem is. I’ve done this before with no problems.

This is a new install of the updated Scrivener onto my new Windows 10 computer.

Thanks!

Hey, just bumping this up.

I don’t know if I’m following your question, but if you wish to remove an image you don’t like, you would select the “No Backdrop” option from the View/Full Screen Backdrop/ sub-menu.

Thanks Amber. I was trying to do it in tools-options. That worked, and I’m happy with it now.

I still can’t make it fade, though. Any idea what I might be doing wrong?

I’ve noticed that there’s a difference between what Amber suggests, and the method using the Tools/Options menu. Using View>Full Screen Backdrop doesn’t allow any fade, as far as I can tell. But if you go to Tools>Options>Appearance>Colors>Full Screen>Background>Choose Texture, you can pick a picture that will then fade in full screen.

The first method seems to stretch a single picture to fill the background, but it won’t fade. The second method allows you to fade, but you must use a picture that is as large as the resolution of the monitor you’re using or it will be tiled (and I don’t see a way to choose not to tile). The second one seems an easier problem to fix, though, and that’s what I’ve done with my own background. You can resize pictures using GIMP, Photoshop, or many other variations of editing software. Just make the pixels the same as the resolution on your monitor and you should be fine.

Sanguinious, Thanks!

It worked the way you said, more or less. I had a backdrop turned on the way Amber said. I left the backdrop turned on, then went the ‘options’ route and put up the same picture (figuring that it would override my former command.) It still wouldn’t fade. So I thought, maybe I have to turn off the backdrop in the ‘view’ command chain. I did that. When I checked to see whether this had worked, I discovered that I now had a partly faded backdrop. I guess maybe each of these command chains applies a backdrop, and when I turned off the ‘view’ backdrop, the ‘options’ backdrop was still there. Funny. I wonder whether it was set up this way by mistake or on purpose.

Thanks again. Very helpful. :smiley:

Yes, on purpose. :slight_smile: You can think of it like “layers”. There are your software settings, the stuff in Tools/Options which impact how all projects work immediately. Then there are things that projects can do on their own, and each project has their own unique setting for it. We use this for things that make sense in a per-project context. For example, you won’t find a setting in Tools to colour icons with the Label colour, rather, each project can set that with the View/Use Label Color In/ menu. With some projects you might want that features, with others it might be annoying.

For these features the layers work like this:

  • Background colour.
  • Texture (covers background colour).
  • Backdrop (covers texture and colour).

Thus if you remove Texture while leaving Backdrop in place, nothing appears to change because the Backdrop is still overriding, or covering up, all of the other options.

Thanks for explaining that, Amber. That makes sense. :slight_smile: