Full screen not in "sync" with regular window and

Keith,
I have been using Scrivener for the past few days, and all I have to say is that is a wonderfull app. For years I have searched for something like Scrivener, and finally it is here. Here are a couple of suggestions:

  1. There seems to be a small bug/non feature when going from and to full-screen mode. The position of the cursor is saved between regular and full screen modes, which is great, but the windows differ, making it a bit confusing. Perhaps the full screen mode should try to be “in syncâ€

[quote]

  1. There seems to be a small bug/non feature when going from and to full-screen mode. The position of the cursor is saved between regular and full screen modes, which is great, but the windows differ, making it a bit confusing. Perhaps the full screen mode should try to be “in syncâ€

[quote]

[quote]

  1. There seems to be a small bug/non feature when going from and to full-screen mode. The position of the cursor is saved between regular and full screen modes, which is great, but the windows differ, making it a bit confusing. Perhaps the full screen mode should try to be “in syncâ€

Hmm, strange - that shouldn’t happen. For me, going into full screen scrolls the text to where it was. True, the cursor may be at the bottom of the screen rather than in the middle of the screen, but it should at least be in the visible area…

Just to pipe in that I have been having the exact same issue - except I hadn’t realised that pressing a keyboard button would take me to the cursor so I’ve been scrolling through with the mouse.

Is the cursor/text not on screen at all? Are you sure it’s not right at the bottom?
Thanks,
Keith

Not at all. Since both regular and full screen windows are not in sync, sometimes the cursor is out of sight. This should not be hard to test. Just create a document that is longer than one screen. In the regular screen go to the bottom, then switch to full screen mode.
I’m sure it’s just a small glitch.

The problem is that I have tested it, and it works absolutely fine for me. Whenever I go into full screen, it shows me the area where the cursor is (which is where it was in the main screen). Now, if you scroll to the bottom of the screen in the main window but your cursor is still at the top, then yes, the full screen window will show where the cursor is rather than where you scrolled to, but that is as it should be. So, like I say, the problem is that I cannot reproduce this.

No, this is not how its working for me. I am working on a long document (20,000 + words). In normal, binder view I am working at the end of the document, which is also where the cursor is. When I switch to full-screen the cursor stays at the end of the document, but the view has switched to some random point in the document, not at the end. As Amaru pointed out, pressing a key will then take the view to the end of the document where the cursor is.

What do you mean by “binder view”? Scrivener doesn’t have a binder view, only Scrivener Gold has that. Are you using Scrivener beta 2 or Scrivener Gold?
Thanks,
Keith

Keith, try turning the scroll bar on. I tried everything from wildly disparate zoom settings to ridiculously huge documents, and nothing worked. But as soon as I turned on the scroll bar and positioned the cursor in the lower part of the text, it de-synched. I think the only merit to having a larger document is that it requires a certain amount of space before the bug kicks in. Up until a certian point, it does remain synched for me.

Ah, okay, I have recreated this. Nothing to do with the scrollbar, and in fact it would only happen in certain situations - not all the time by any means. I think it was caused by my scrolling too early. As soon as full screen was entered, the code set the selection and scrolled the text view. But after that, the paper size, scroll bar and all that stuff would get set up - all of which could potentially change the part of the text view that would get displayed. So I’ve moved the code that scrolls the text to after all that set up stuff, which I hope will do the trick. So far it seems to, but we will see when you put beta 3 through its paces. :slight_smile:

Keith, Thank you for fixing this bug. It was driving me crazy.