Full-screen scroll bars have gaps at ends

When in full-screen mode, the scroll bars have an odd gap near the endpoints. The attached screenshot shows the effect (I rotated the bars 90 degrees so they’d fit better here, and in the lower copy I filled the black background with orange so the gaps would be easier to see).

-Andrew

I’m not seeing this - what platform are you on? (Tiger, Leopard?)

I’ve got them as well. I usually have auto-hide on, which looks fine, but when switching over to standard scrollers, I get the same gap—looks to be the same pixel dimensions as the black one rather than the orange one. I also noticed in the recent user-submitted screencast that David posted, when he was demonstrating full-screen, there were gaps in the scrollers there too.

Maybe try defaulting your settings and set up a new project? It might disappear with the right page size and other possible configuration options.

Further details: It looks like adjusting colour preferences while FS is open will cause the appearance seen in the orange screenshot. The gap will fill in with the paper colour if the paper colour is adjusted, or if text override is toggled. If, after doing that, you switch out of FS and back in, the gap will return to the background colour.

This might be academic, but try this:

  1. Go to full screen
  2. Open preferences
  3. Change background colour to orange
  4. Now switch to paper colour and start changing that

The gap will acquire the previous paper colour selected. If you click on three different colours, the gap will be one step behind your selection. Like I say, it probably doesn’t matter as that spot should be hidden anyway so who cares what weirdness happens—but maybe it is a clue.

Wait, you mean you’re seeing them all the time? I still can’t reproduce this, on either my MacBook 13", a connected 24" monitor, or on my MBA 11"… Weird. I thought the clue might be having arrows at top and bottom, but no, I tried that and mine are still fine. I’ve tried switching to another full screen scroller type and then back again, too.

Is there anything else I can try to reproduce this?

Thanks,
Keith

Got it. I’m not sure if this is the only trigger, but I set up a vanilla test account on my system and was able to reproduce it as I gradually changed things to how I prefer. There is a hidden system preference that not only puts the scrollbar arrows together—it puts a pair at both the top and bottom of the scrollbar. Here is what my scrollbars look like:

Here is the command to enable it:

defaults write "Apple Global Domain" AppleScrollBarVariant DoubleBoth

I would imagine, for most people (if this is the only trigger), they are using Cocktail, Onyx, or some other power tool.

defaults write "Apple Global Domain" AppleScrollBarVariant Single

Will get you back to default; once you are done testing. You will need to restart Scrivener after each command, and the Finder as well.

That is some mighty fine detective work, AmberV. That’s exactly the problem. I use the double-headed arrows, in both top and bottom locations, because they’re so convenient. Turning off that preference eliminated the gap. Turning it on brought the gap back. So I can confirm that this system option appears to be the cause for me as well.

KB, it’s probably moot now, but to answer your question I’m using Scrivener NaNo 2010 on a 15" MacBook Pro (technically, model 2,2) with OSX 10.6.5 (and all the latest updates applied), a 2.33 GHz Intel Core Duo processor, and 3 GB 667 MHz DDR2 SDRAM memory.

Ah, okay, I see the issue now. Quite a few applications don’t support this scroller style. Just check out the scrollers in iPhoto '09, for instance:

It’s the same in TaskPaper and elsewhere - generally only the standard Aqua scrollers support it.

I’ve just put together a fix of sorts for 2.0.1 though (although it won’t affect the auto-hiding scrollers, which still won’t support this style for now). In 2.0.1, if you use this hidden preference scroller style, then Scrivener will use a darkened version of the standard Aqua scroller for the background (but still with the black knob) rather than custom-drawing the arrows. It looks okay and at least gets rid of the gap for those using this style. It’s notoriously difficult to create custom scrollers in Cocoa, and given that it looks as though Apple are changing scroller styles for Leopard, I’m reluctant to put a whole day or two into this at the moment.

All the best,
Keith