Full Screen slows down

Hello Keith, it’s a fantastic application! I have now made it the program to do my daily work on.

Something I noticed in Full Screen mode:
after some time, maybe an hour or so, the typing get’s slower and slower and the erasing becomes very, very slow. I have had to close Scrivener and open it again in order to correct this.

The document I am working on has ca. 20.000 characters.

I work on an iBook 1,2 GHz, PPC, Mac OS 10.4.6

Does it happen consistently, and if so, how is the memory usage compared to when you started?

It happens consistently, yes.
The second part of your question relating to memory I don’t understand.

If I may…(and forgive me rochefore but I make no assumptions when I’m trying to provide tech support, something I did for more than two years. Oh, and almost everything is preprended by a “please” below)

There’s a utility called Activity Monitor, in /Applications/Utilities folder. Launch it, then open up the said document in Scrivener

In the top search box of Activity Monitor window, type Scriv, you’ll see only Scrivener showing up with some values.

Now note the Real and Virtual Memory columns on a piece of paper.

minimize Activity Monitor

Continue working on your document until the time you think/feel full screen mode starts slowing down

maximize Activity Monitor, look at the Real and Virtual Memory columns, note them again, and post your results here.

…sounds awfully complicated but I will give it a try.
Thank you very much for your thorough reply, Amber V.

Oh! Sorry musti, I thought it was AmberV replying! javascript:emoticon(’:oops:’)

Musti said exactly what I was going to say, down to the letter. Let us know if anything comes of this experiment.

Another thing you can try after the memory test is splitting up your document a bit. 20,000 is a pretty large file. Scrivener is designed to work better in smaller parcels. I have noticed a little sluggishness with larger documents, but absolutely nothing when they are split up. You can still edit it all at once using Edit Scrivenings, and I’ve never seen slowness doing that. It takes a second to load them all, but once they are loaded, they are all still treated as individual files.

But that would be too bad. I like being able to scan through what I have written, to get a quick overview. 20.000 characters is not very much.
Hope there will be a solution for this.
But thanks for you comment!

Oh, 20k characters. I’m sorry. I misread it to mean 20k words. That should be no problem at all. There would be no reason to split it up less than 20k characters. Forget that suggestion. :slight_smile:

I think Keith is going to have to help you out. Something beyond ordinary file size problems is going on.

Re using Activity Monitor: Actually, while it sounds complicated, I think if you give it a try it won’t be nearly so much so as you think.

Another option that makes it even easier: with MemoryCell (it’s free), I have an Activity Monitor ‘gauge’ running on my menu bar all the time and it’s very easy to pop the program open and closed when needed. You can find it here:

http://www.macupdate.com/info.php/id/16989

It’s not a real ‘hack,’ and has been running on my system (Tiger) through several updates without any problems at all. It gives you a menu bar item that lists the memory usage for whatever program is active and it gives you a menu selection that, among other things, quickly opens Activity Monitor. I need it less now that I’ve upgraded my RAM, but it’s still pretty handy. Makes checking on memory usage extremely fast and easy.

Hope this helps!

Alexandria

PS I agree 20K characters is not really that long. I have many documents or sections that long or longer that aren’t broken up. I haven’t had any slow downs to speak of, but I haven’t been using full screen all that much. I’ll do so, though, and see what happens.

This should not be happening at all, certainly at 20,000 characters, which is nothing. Can you give me more details? Are you using Edit Scrivenings? Or is this just with a normal document? Is this only in full screen? Do you have other applications running in the background that might affect this? There is no good reason why this should be happening, as nothing is happening in Scrivener other than normal typing…

Thanks,
Keith

P.S. Although I am doing most testing on a MacBook now, most early testing was done on an iBook 1Ghz (and I’ll be back to that soon while my MacBook is in for repair again, it seems, sigh), and it was always fine… Although, of course, the trouble is that I have never actually had time to spend an hour in full screen mode. Perhaps when I get chance to start using Scrivener for myself it will be easier to fix things like this. Please do let me know if there are any other significant factors, though.

Hello everybody, it seems I found the cause of the slow down:
I usually have an application open called BigBang Checkers which I play for distraction sometimes when I am writing.
I turned this off now and the problem with the slow down is gone.
Concerning the memory I noted down these values:
when I started writing real memory was 15,57 mb and virtual memory was 134,90 mb.
After an hour this had changed to 15,81 and 136,75.
But as I said: once the game was off the problem was gone.

All the best to you all, and thanks again for your efforts.

R.

Phew! Those Big Bang games consume a lot of memory, and it sounds like it must be consuming more the longer it is on. Good to know this is a bug in another program. :slight_smile:

All the best,
Keith