Full Screen Switching Bug?

Keith - Impressive software, and congratulations on getting to 1.0 and making some sales.

On my iBook G4, if I [edit: if I am in FS mode and] hit cmd-~ (within-app window switching shortcut) the binder appears. If I hit it again, the FS appears - only it’s blank. I can now toggle back and forth between my current document in the binder, and a blank full-screen using cmd-~. If I want to see the text of my current binder document in FS mode, I now have to hit the (cmd-opt-f ) FS shortcut - twice. The first time, the blank full-screen flashes and I am returned to my current document in the binder. The second time, I can now see my current document and its text in FS mode.

Don’t know if this is a bug or not, and the truth is, this behaviour is just fine with me (gives me a quick’n’dirty way to use the blank screen as a frame for other app’s windows, a’la Backdrop, FocusLayer, or SpiritedAway). However, thought I’d let you know in case you didn’t.

Keith - never heard anything more about this one and am still curious. To try and explain it more clearly…

  1. Select a document in the binder to view in the editor
  2. Hit [cmd-opt-f] to switch to full-screen view
  3. Hit [cmd-`] as if you were switching between windows in frontmost app, and notice that you switch back to binder/editor view
  4. Hit [cmd-`] again, and notice that you switch back to full-screen view, but that your document is now blank
  5. Hit [cmd-`] to toggle back and forth between regular view and this blank, full-screen view
  6. From binder/editor view, hit [cmd-opt-f] - notice that it doesn’t work properly (blank full-screen view flashes on and then off)
  7. Hit [cmd-opt-f] again - notice that it now works properly - you’re back in full-screen view, with your text in your document
  8. Repeat steps in the order you find most pleasing and enjoyable

I just tried those steps and saw exactly the behaviour described.

Is full screen mode not treated as a normal application window? If it isn’t, it could explain why the normal application-window-switching doesn’t work properly with it.

Hi edmo - sorry I didn’t reply to this one, I thought I had. I saw your post, and the bug you describe has been on the list of things to fix for 1.01 since then. In fact, at the weekend I e-mailed the Cocoa dev lists about this exact same problem, but it’s trickier than it should be. For some reason, although everything happens fine normally if the main window gets the focus during a full screen session (this, the full screen session ends in this event), this particular key-combo (the “next window gets focus” shortcut) seems to cause things to act differently. I have tried everything I can think of to no avail, so far, so whether or not it will be fixed for 1.01 I cannot say. All I can say is that I am trying to address this one. :slight_smile:


No worries, Keith. I was just curious about whether or not this was expected or desired behaviour, from your point of view. As I said before, I actually like this behaviour, as it provides me with a quick way to get a full-screen black background as a frame for isolating other apps windows.

Glad to “hear” your bouyant tone on the forums these days. You certainly deserve - and deserve to be stoked by - the rewards you reap from Scrivener, both in terms of the time, effort, and energy you’ve invested, and in terms of its quality as a ‘finished’ product.