Gaps between docs in Screenings mode

In scrivenings mode, there’s always a significant gap added to the end of each document, equivalent to 3 or 4 extra lines before the horizontal separator line. These are in documents with only one extra line at the end (I’ve checked). I want only ‘real’ empty lines to appear so I can instantly see if I’ve added too many returns (and I don’t want invisibles turned on all the time).

Is there a setting to change this? If not, will there be?