German Umlaut & LaTeX

Hi all,
I´m new to Scrivener and trying to make it work with my LaTeX Environment TeXShop. I have the following problem:

I installed the System (Scrivener)
put my own header and footer in the export options (LaTeX Options)
put my TeX files into Scrivener
*** everything fine up to now
compiled my text

Now all the German Umlaute (äüö etc.) are not correct transferred to the exported file and i can´t compile the file via TeXShop. I use an UTF-8 Coding on TeXShop but it did not help. Does anyone have a hint for me?

Greetings from Germany

Mike

I would love to have an answer to this problem as well. I tried to use the replacements option in the compile window to transform characters with umlauts into their LaTex equivalent (i.e., ö to {"o}) but after the compile {"o} gets turned into {\textbackslash{}"o}.

Any help would be appreciated!

FWIW, I also tried wrapping the latex commands in comments, , but no luck either.

This sounds to me like another possible version of the UTF8 encoding of non-ASCII glyphs. This has appeared in these forums in relation to French ≪ guillemets ≫ and for me and a collaborator on sharing a project with Chinese text between Mac and Windows systems.

It appears that there are two ways of addressing glyphs above U+007E, and different apps use can different ways. It’s my belief that the Apple text engine uses one for output but can read both — so any app that is based round that, including Scrivener, Nisus, Bean, Yojimbo … transfer data without problems — whereas other apps, for instance the text engine used in the Windows version of Scrivener, use the other coding system and cannot read the one used by the Apple text engine. So collaborating on a single project across the two platforms with upper end glyphs doesn’t work. Maybe this problem is there with TeXShop.

Liang Li’e and I have sent a fair amount of data to the team through Jennifer (Mimetic Mouton) who is co-ordinating the search for a solution. It might be worth emailing her directly with your findings.

:slight_smile:

Mr X

I have a couple of things for you to try:

  1. You mention putting LaTeX files inside Scrivener, is that meant literally, as in your Draft has LaTeX content? Because if so you probably shouldn’t be using the MultiMarkdown conversion engine. That will produce LaTeX but isn’t the most efficient for handling it in bulk. If you are using Scrivener as a LaTeX authoring environment, stick to compiling using plain-text output, and writing the entire document (including preamble) in the Draft folder.
  2. If you are using MultiMarkdown, then try compiling with one of the built-in document class selections, like “Memoir (Book)” instead of your custom boilerplate (don’t worry, it will not be lost but saved in the background). If that works better for you, then have a look at the default preambles that MMD uses. They will be in the compile folder as .tex files, or if you have installed the MMD LateX support package, then you should know where to find them.

I’m pretty sure all you need though is the following code in your preamble:

\usepackage[utf8]{inputenc} \usepackage[T1]{fontenc}

Note, TeXShop may not display accents correctly in the editor. I use an older version out of preference, and I have to tell it specifically what encoding to use when opening the file; it uses Mac-Western by default. Even so if I don’t edit the file at all I can still typeset it with Cmd-T and all will be fine with accented characters and such. But if I’m going to be editing the file with TeXShop, then I make sure to open it correctly.

  1. Make sure you’re using XeLaTex in Texshop.
  2. Make sure “Substitutions” are unchecked in Texshop. This may not seem obvious, but the author or Texshop proposed it as a fix to the problem of bringing in Mac-Roman encoded text over and trying to use it in a UTF-8 environment. The fix was specifically addressing the apostrophe/quotes issue but I find it affects letters with diacritical marks not found in 7 bit ASCII. Worth a try.

Hi everyone, thanks for the help! Amber, you were right. It had something to do with the encoding.

I pasted this into the header, and everything works great now.

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

Thanks again!

Hello @all and thanks for the replies.

Just to make the problem clear:
The text in scrivener shows all the special characters äöü (German Umlaut) correct. The (via scrivener) compiled output has no (or better the wrong) special characters. But this file can be compiled via e.g. TexWorks, TeXshop etc. (with XeLaTeX)

I also can compile it with my own preamble, which uses the \usepackage[ansinew]{inputenc} in combination with \usepackage[T1]{fontenc}. Maybe the problem is the process of compilation. When I use lists in my text (bullet-points) I do not get an {itemized} environment in the compiled text but a {verbatim} environment ???

Another reason for the problems could be that I´m using LaTeX for a really long time (about 25 years) and moved my source files through various operating systems (and encodings). Since I migrated from windows to Mac OSX everything worked fine with the ansinew-encoding, so it maybe that the step to Scrivener ist not so easy as I thought. But I´m still on the test-phase and trying to manage it.

Greetings from Germany

Mike

…coming closer to a solution.

As far as I can see, the encoding issue is solved. I did:

Change the encoding of my input files via “iconv” on the Mac-console
Changed all settings to utf8 (Editor, TeXShop etc.)
now using:
\usepackage[ansinew]{inputenc} … \usepackage[utf8]{inputenc} also works (* wondering why *)
\usepackage[T1]{fontenc}

So this works fine. Still not working:

  1. boldface text is simply ignored by the compiler (as is for italics)
  2. itemized lists are not correctly translated

So my Question is: Is this normal that itemized lists are not (correctly) translated to LaTeX, dito for text attributes?