Getting Rid of Page #s in End Matter when Compiling to Word

I’m compiling my manuscript to Microsoft Word preparatory to uploading it for print publication to CreateSpace. I want the page numbers to stop at the end of my novel and not continue into the end matter (“About the Author”, previews of my other books, etc.). Is there any way to do that on Scrivener before I compile? I do have all the end matter in a separate folder.

I don’t think Scrivener has a way to suppress page numbers in back matter, because it doesn’t yet have any concept of ‘back matter’. I assume that some day in the future, if that feature gets added, you’ll be able to suppress page numbers in the compile settings. For now though, you’ll have to bring your output into a word processor and adjust the page number settings there.

Probably too late to help you - given that this was three months ago - but I’ve recently been trying to sort out exactly the same problem, and offer this in case it helps anyone else doing a search.

What worked for me …
in COMPILE settings, under PAGE SETTINGS, check the ‘no header or footer on single pages’

Bit of a hack, and there will be many cases where this won’t work, but in my novel, the only single pages I have are several single pages in my front matter, and one single page of end matter (about the author) so no headers or footers on any of those works fine. Obviously, if you have single pages within the main body of your document, ‘my’ method isn’t going to help.