Getting rid of spell check

I mostly write in an obscure language not available for the spell check, so I want to turn of the check to make my text legible. 've tried the following:

Edit⇒Spelling and Grammar⇒Check Spelling While Typing

File ⇒ Options ⇒ Corrections ⇒ Spelling ⇒ deselect “Check spelling as you type.”

Neither option is visible on my Scrivener. I have version 3 for Win. Thank you!

Scrivener 3 for Windows DO have those options.


You said you tried them, but options are not visible… how did you try those options if you can’t find them?

I’m confused.

In any case, you could add each of your obscure words to the ignore list, or add them to your dictionary. It’s WAY safer this way, than completly shut down spell corrections. In the end, your manuscript must be readable to humans, right?

I picked out those from other answers. They are not visible to me.

…wrote them down just so no one should have to suggest them in vain.

Also, adding every single word with the 20 odd different grammatical forms each has in Finnish would take a few lifetimes. Which is why I asked for help to turn off spellcheck.

You sure you have version 3? I don’t think it’s possible to not have that options panel.

image
What does Help -> About says?

Also, please post a screen of your options panel.

If you are writing entirely in Finnish, then yes, you’re right.
If not, you could just add/ignore words “as you type”. Writing without a spell check turns proofreading into a bloody nightmare. Just my 2 cents.

Naturally I do that when writing in English. As I’m writing a (very thick) book in Finnish, I NEED to turn off the bloody thing.

I’ve always felt otherwise. I find writing with a hovering grammar nerd constantly reaching over your shoulder and stabbing at the paper with a red/green pen to be very distracting. :joy: I don’t care if I misspell things while I’m writing, or if the computer thinks my tone is too passive. I can pick up those issues in one sweep once I’m done, using the “find next” style dialogue box.

2 Likes

But these options should be available, and what you’re requesting (turn off spellcheck) should be easy to do.

So–

You’re either doing something wrong OR your Scrivener v3 installation is broken.

Help us determine which is the case, by posting the following screenshots:

1 - Your Scrivener Version (Help > About)

2 - Spelling Options available to you under Corrections (File > Options > Corrections > Spelling).

Best,
Jim

This is the first time sussa has posted — let’s welcome them to our community!

She could upload an image, showing the issue, but will receive “Sorry, you can’t embed media items in a post.”

3 Likes

@sussa , instead of uploading screenshots, you can post the version information as text. If need be, you can link to a screenshot that you store on some other website (like Imagur, Dropbox, or your own website) until you’ve posted enough for the forum software to decide that you’re not a spammer. :smiley: Hope this helps!

Example link to image on Dropbox:
[screenshot](https://www.dropbox.com/s/bxucyeao1nmdl8t/Screen%20Shot%202021-08-08%20at%2000.27.51.png?dl=0)
screenshot

2 Likes

Agree totally. Writing time is for writing, the grammar, spelling etc can wait, otherwise I find it too easy to lose the flow and get bogged down.

Agreed. Meanwhile, you may find this post of mine about Finnish corrections interesting. It has the instant hunspell magic but it goes along with what AmberV says above as well.

I tried to post links to the relevant screenshots, but I’m not allowed to do that either, so if you take the time to puzzle together this string into a meaningful web address, you might get there.
https [colon slash slash] photos [dot] app [dot] goo [dot] gl [slash] FQDYoqrDutbPidh56
And thanks for the kind welcome!

Click here:

@sussa good job circumventing L&L’s anti-spam measures! :nerd_face:

Thank you for the screenshots, they make all the difference in figuring out what the issue is.

As @Canne points out, you’re almost there. From the options screen you need to click on Spelling. As I mentioned in my post upthread, the full path to the options you want to change is File > Options > Corrections > Spelling.

That will take you to the screen that @mattarmon displayed in this post upthread, which I’ve copied below.
image

On this screen, you can turn off spell check by disabling the following two options:

  • Check spelling as you type
  • Correct spelling errors as you type

Be sure to press OK or Apply when you’re done.

Best,
Jim

1 Like

@JimRac & @Canne ,

Unbelievable! I managed to stay absolutely blind to the word “Spelling” at the left. No matter how many timed I opened the Corrections window, I only saw what was in the gray square.

Thank you for curing my blindness (and making my Scrivener experience much better).

1 Like