Getting Started / Tutorial Issues

Just downloaded the demo and interested in giving it a whirl, but having some strange issues:

  • Choosing Help --> Tutorial either reveals nothing, or a blank document.
  • Upgrading to the latest Beta as outlined in these forums didn’t solve this.
  • Creating a new project doesn’t appear in the same manner as in the help file in the following ways:
  1. The dialog doesn’t go away after I hit “create”, and the project doesn’t automatically open
  2. If I find the project file or select it in the “recently” list, it opens, but with nothing in the left column, and choosing “add text” or similar does nothing. Everything but the 'add", inspector, and “keywords” icons are grayed out.

Running Tiger 10.4.10 on a MacBook Pro.

Any thoughts?

This sounds to me as if you have created a file in one version of Scrivener, then opened it in a newer version (e.g. a beta) and updated it as requested, then opened it up again in an older version of Scrivener (e.g. 1.03).

There was a bug in all versions of Scrivener prior to the current beta whereby Scrivener would mistake a newer project for an older one, try to update it, and thus corrupt it.

Fortunately, backups are made so no work is lost.

I suggest deleting all copies of Scrivener from your hard drive and emptying the trash. If you haven’t created any proper Scrivener files that you want to keep yet, delete any .scriv files you have on the hard drive. If you have something you want to keep, keep the ones with “Old_Backup” appended to the filename, as these are the uncorrupted backups.

Now reinstall Scrivener - the latest beta - and try again.

If this does not help, it may be a fonts issue. Go to Scrivener > Preferences > Fonts & Colors and make sure that all of the pop-ups are set to a font that you actually have on your system. There were some issues many moons ago where this could cause blank windows if you didn’t have the fonts set in Preferences, but I thought I had fixed this.

Hope this helps.
Best,
Keith

Afraid not-

I’ve never gotten to the point of a working document, so I have nothing worth keeping. Deleted the app, the prefs file, and all test .scriv files, including my extra copy of the tutorial. Then redownloaded 1.1b8 and installed. Skipped the “extras” installer in case that was the problem.

Relaunched, and same thing:

  1. toturial won’t come up the first time.
  2. second time, it comes up as a blank document.
  3. creating new project or attempting to edit the tutorial one result in nothing happening trying to add text or folders. The dialog will come up to add a web page, but nothing shows up once you submit it.

Any other thoughts? Screen shot of the so-called tutorial file attached.

FYI: did one more clear and reinstall, reboot, etc. and same thing. Did so with both current release and 1.1B8.

Could you open up Console.app (Applications/Utilities) and see if anything is getting written to the commandline when this occurs?

Did you check the fonts weren’t the issue in Preferences?

Thanks,
Keith

FONTS:
It’s using Lucida Grande, which I clearly have installed and activated on my system. (FYI: I am a designer and am using fontAgent to manage my fonts.)

With Console open, I tried to launch the tutorial from the help menu. The first time, nothing happened, and Console was silent. Did it a second time, and got the following in Console:
2007-09-13 11:42:14.515 Scrivener[505] *** -[NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil value

Reproduced this 2X.

Is that any help?

Sorry, maybe I didn’t make myself very clear. What I should have said is, in Fonts & Colors in Preferences, are any dropdown menus blank (that is, do any of them have nothing selected)?

The error message on the console is in keeping with what would happen if the default Preferences dictionary had any blank objects in it (i.e. a font that doesn’t exist on your system).

The problem for some others has been that they don’t have the Chalkboard font installed, which is what is used by default for media index card titles (“photograph titles”). Check to see if any pop-up buttons are blank in Preferences > Fonts & Colors. If so, choose a font and OK the change. Then quit & relaunch.

Best,
Keith

None appear blank, and most have defaulted to Lucida Grande or helvetica, which both are showing up on the preferences screen, as well as when you click on the pull down and choose them (and prove to be active in my font manager.)

Looking through the other preferences, I don’t see anything else blank that I can tell…

Hmm…

When you deleted everything, did you make sure that you emptied the trash?

Please try the following:

  1. Again, move any copies of Scrivener you have lying around to the Trash (including any DMGs).

  2. Do a Finder or Spotlight search on .scriv and move all .scriv files to the Trash.

  3. Do a Finder/Spotlight search for com.literatureandlatte.scrivener.plist and trash that file, too.

  4. Empty the trash.

  5. Re-download the 1.08 beta and re-install it.

(Before trying this, you could just try deleting com.literatureandlatte.scrivener.plist - it may be that the error you are experiencing is caused by a corrupted project that is still on your disk and which Scrivener is trying to open on launch; deleting this file will prevent this.)

Sorry you are experiencing these problems. I do want to help you get to the bottom of it…

Best,
Keith

Keith:
Thank you very much for your help. Still no dice.

  • Started by JUST removing any scriv files and the preferences. Same result, and console showed:
    2007-09-13 14:37:49.558 Scrivener[736] *** -[NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil value

  • Followed your directions explicitly, downloaded a new copy of the beta, installed, and again, I get the following in trying to open the tutorial:
    2007-09-13 14:43:09.040 Scrivener[788] *** -[NSPlaceholderDictionary initWithObjects:forKeys:count:]: attempt to insert nil value

…and of course, creating a new document results in no actual folders/text/etc. in the project/binder/whatever it is.

Any more ideas? In the meantime - I’ve got a research paper to write. :wink:

Would you mind contacting me at support@literatureandlatte.com? Once I have your e-mail address, I’ll send you a special copy of Scrivener which, once run, will spew an error on the console that will give me a better idea of where the error is. If you don’t mind that is.
Many thanks,
Keith

Might I make a small suggestion.

Follow Keith’s instructions. Download new copy. Before installing it. DISABLE Font Agent and rebott with it off. Install Scrivener. Run the app once with Font Agent Off and see if the problem goes away.

Or Get a list of the Fonts that Scrivener is required to use to run and copy them into the HD/SYSTEM/LIBRARY/FONTS folder

Then Follow Keiths Directions and see if the problem is Font activation related. (Could be a needed font is set to Auto Activate instead of always on or a FONT ID conflict may be occuring)

I haven’t heard from you, bbushman - did you get it working? Or are you just busy on your research paper?
Thanks,
Keith

Keith:
You should now be getting an email from me- let me know if it doesn’t show for some reason.

Also, as an FYI for the thread: per Wock’s suggestion, I haven’t fully disengaged FontAgent yet, but did make sure all my chosen fonts are present in /System/Library/Fonts and reinstall/reboot/relaunch Scrivner, with the same results.

ANother thing to check is Mail.app and Text Edit. See if they are acting funny.

I remember awhile back in OSX Panther that a font related issue was with Helvetica and Lucida. I also remember many problems with Font management tools causing havoc in Apple programs (Mail, Text, etc).

An easy check to help narrow down this anomoly is to create a new user account (making sure FA is not set not manage fonts for the new user). Then download SCRIV and install on the new user account and see if the problem goes away. If it does then open the HD/USERS/NewUserName/LIBRARY/FONTS folder. Select all (Command+A) then go to HD/SYSTEM/LIBRARY/FONTS and PASTE (Command+V) [you may need to authenticate in order to do this].

Then Switch users back to your main account. Make Sure FA does NOT manage SYSTEM FONTS.

PS: I am willing to bet it has to do with Helevitca and Lucida Fonts and Font Agent. I had a simular bug back in 10.3 days and a font management tool. (I am a designer myself)

So an easy possible workaround [if it works] is to create a new user and install SCRIV on the new user account. Write on this account. Switch Users to you main account for other activites. Otherwise I am willing to bet it is a font related issue and those can be painful to narrow down. Especially for designers because the first thing we usually do is replace Helvetica TT with a Postscript version :slight_smile:.

Wock:

Yeah, I’ve definitely had my fair share of font woes. :slight_smile: (and yes, Helvetica TT is indeed banished.)

My current setup has been quite solid though… Mail and text edit are happy as clams, and even iCal (which required the original apple-installed copy of Helvetica Neue) is happy.

But I agree that’s always a possibility, so it’s worth a shot, and in general, you do bring up a fairly standard troubleshoot technique that I TOTALLY ignored with installing and testing for a new user account. And definitely a great way to check on fonts without screwing up my production environment. :slight_smile:

Keith is helping me with some debugging on his end privately, but if we don’t get anywhere soon, I’ll definitely flip into a new user for comparison and report back.

Thanks and peace.

As a last ditch effort if the bug is still persiting It my be the Font Book Bug cropping up its ugly head. It was “supposed” to be fixed in Tiger but it since you are dealing with large amounts of fonts it may be creeping its ugly head back up in some rare celebration.

here is a link to the work around I gave to apple back before tiger released on How to replicate the bug (symptoms) and a workaround.
discussions.apple.com/thread.jsp … 48&#607348

It may help you resolve the issue you are facing if it turns out to be a font related conflict.

Yeah the New User trick is neat but I usually forget to use it as well :slight_smile: