Getting Update Error message when trying to update from 3.02 to 3.1

When trying to update Scrivener I received this error message

I don’t know why I got this message. The app is running on my hard-drive and resides in my Applications folder.

Any suggestions?

Tnx

Scrivener 3.02 (1506)
Mac OS High Sierra 10.13.6

Have solved problem.

Apologies for taking your time.

Saw that others had encountered similar issue and resolved it by downloading new update .

I did this and it resolved the problem.

One thing to try if you see this in the future is dragging Scrivener to another folder. Apple has a new security feature whereby if you don’t move an app from its download location to another folder, it can be seen as “read-only”.

Glad you got it sorted, though!

All the best,
Keith