Grammar and spelling corrections in tutorial [BUG LOGGED]

I don’t know if this is normal (I’ve never used Scrivener before), but in the program throughout the tutorial there are random red lines everywhere.

Like for the words “It such” it underlines “t s” and wants to correct it as “T’s”.

No idea if this is a bug or normal, but I just figured I’d mention it. It’s done things like only underlining “hoosing” out of “choosing”, wanting to correct “of” with “of”…

And so on and so forth.

I’d like to confirm this bug. The spellchecker is highlighting parts of words and the words next to them as being misspellings of a single word. I found this bug in the Scrivener tutorial. I’m not sure yet whether it does so elsewhere. For me it highlighted “a corkboard, an outliner and text editor…,” and continued to do so randomly throughout the tutorial.

This is happening in my tutorial, too, but so far it hasn’t shown up in the other file/document I made to play around with.

What I’ve done is both typed out random things in the new document as well as copy and pasting one of the lines that spell check was messed up with.

Thanks. I’ve been able to duplicate this as well and will add to bug fix list. You can disable spelling features in the options dialogs last tab. Thanks again.

This is happening in my work that I’ve copied and pasted in. It’s underlining combinations of words as misspellings.

I’m also having this problem. I thought it was just me being odd due to the British English, but I’m having the spell check problem as well.

Hi everywone,

This seems to be the most accurate place for the problem I encounter.
I installed Scrivener yesterday. It is great, and works much better thant one would expect looking along all these interesting posts.

Since hours now, I’m searching for a way to get the spellchecker to work.
I would be so glad to be in your case and have those troubles.
I cannot get any spellcheck, although the box is checked in the options.
And I cannot believe that I made no mistakes at all.

This is a problem for me too. I don’t have it on to correct automatically as I type because I hate the wavy red lines all over the place but I usually do a spell check after I’ve completed a document. When I ask it to check the document all it does it highlight a word and put a wavy red line under it. It doesn’t offer a spell check menu as is usually the case. I prefer to check spelling in Scrivener and not Word as when I export to Word it doesn’t set up a document with my normal preferences and uses US rather than UK English which kind of defeats the purpose for me.

Spelling & Grammar worked fine in Scrivener 1.


Sorry - have resolved my issue! I thought ‘show spelling and grammar’ meant ‘as you type’ :blush:

Well, I simply can’t get it to check anything : I find no visible command to do so.
The only thing I can do is to check “spell check while typing” or “correct while typing”, and that’s the one I’m NOT liking.

Is there a hidden command somewhere ?
I checked all the menues and contextual menues. The only places, where the spellcheck is mentioned, are these two options.

Should I maybe reinstall Scrivener, just for a try ?
Or is there something additional I should have added and didn’t know ?