Growl 2.1.3 Not Working on Scrivner 2.6 Mavericks

Hi,

I have had this working in the past and although it would periodically stop working, a quick Growl reinstall would solve all the problems. Now it seems that matters have been complicated by the Mavericks in-built notifications and I can’t get this working at all, even after reinstalling Growl.

These are the things I’ve tried to no avail:

Reinstall Growl
Turn off the in-built notifications for Scrivener in Mavericks preferences
Run defaults write com.literatureandlatte.scrivener2.plist AlwaysUseNotificationCenter 1 (from bug report)
Ensure Show Target Notifications is turned on

I have no idea what else to try and love using Growl, it’s like a little high-five every time I reach the day’s target, so I’d be so so grateful for any help.

Thanks!
Gilly

One thing to note is that the defaults command line you referred to actually forces OS X Notifications no matter what, even if you have Growl properly installed and set up to work with Scrivener. Here is what you would use to reset that (with the software closed of course):

defaults delete com.literatureandlatte.scrivener2.plist AlwaysUseNotificationCenter

After doing that, you may need to log out and back in to your Mac account, owing to a 10.9+ bug that causes preference caches to be used in all cases over what is on the disk.

Hi Amber,

Thanks for getting back to me. Yes, the 1 on the defaults command did throw me a bit, but yesterday I tried it set to 0 as well and it made no difference.

Looking back over the bug report, I realise I misread it now, and as you say, it forces it to use the notification centre instead of Growl. DOH!

This morning I tried:

Exit Scrivener
Run defaults delete com.literatureandlatte.scrivener2.plist AlwaysUseNotificationCenter
Log out
Log in
Open Scrivener
Achieve document target

Still nothing.

Interestingly, looking at Growl, I have the history turned on and it’s completely empty, as if it hasn’t had any requests at all.

Is there a log file or something I can check to see if Scrivener is sending the notification to Growl?

Thanks so much
Gilly

I’ve now done a complete reinstall of both Scrivener and Growl, right down to a full system search for every file related to either app so they’re both completely clean reinstalls.

Still no joy. It will only work with the Mavericks OS Notifications, looking at the Growl history there is no log of any request coming through from Scrivener.

I’d be so so grateful for any help on this.

Thanks!
Gilly

Are you getting any error messages in Console, or does Growl have a log file you could examine for errors? One thing that comes to mind, I do know that the internal Growl library we use may need to be updated in the software, it may be that a recent Growl update is causing additional problems for you. I have heard that this can cause an inability to communicate between sandboxed applications, did you purchase Scrivener from Apple, or did you download it from our site? If the former, try downloading and running the direct-sale version (no worries, it will detect Apple’s receipts and unlock itself). If that works, you could go on using it indefinitely.

Hi Amber,

Thanks for sticking at this …

No, no errors at all. I found a script that supposed to provide additional logging for Growl and ran that, the script seems sound, no errors when running it, yet no logs are created when you try to force a notification. It really is like Growl is receiving nothing at all.

Do you know anyone that has this working with Mavericks? I’m wondering whether this is a bug that’s been caused by a mismatch between the built in notifications and growl or whether it’s something specific to my machine.

Should I have the OS Notifications for Scrivener disabled or enabled? I’ve tried both, but what is recommended?

I tried updating Scrivener Growl FW using the Growl Version Detective yesterday, it didn’t make a difference bringing it up to 2.0.

I purchased Scrivener direct-sale from your site.

I’m at a loss, with no log files to go by, how can we figure out what’s happening?

I think it comes down to how it’s supposed to work. Scrivener is sending out notifications. I know this because if I enable the OS Notifications, both the sound and the banner work without a problem. Is Scrivener also supposed to send notifications to Growl as well as the OS Notifications? Or is Growl supposed to listen for OS Notifications, interrupt them, and do it’s thing instead?

If Scrivener is supposed to send notifications to both Growl and the OS, is there a log file we can check to see if it went out?

I’ve logged a case with Growl too, but by the looks of their forum, I’ll be very lucky to get any response.

The only other thing I can think of is a complete system reinstall. But that’s a hefty amount of work if it isn’t going to help and this has never worked with Mavericks at all.

Be so grateful for any more ideas!
Gilly

Amber, if I can’t get this working, I have a question for a workaround if I’m stuck with OS Notifications:

The sound that OS Notifications plays when receiving a notification, is that sound chosen by Scrivener?

Can it be changed with a Scrivener command?

At the moment I’m thinking of dropping Mavericks altogether but I think I’d have to go back to Snow Leopard to avoid Notification Centre, I think Mountain Lion has it.

Seems like a lot of hassle for a simple feature, but it really kept me going each day.

Thanks
Gilly

Thanks for checking these out. So to make sure I understand you correctly, you ran a specific tool that is meant to check Growl’s functioning, and provide verbose logging while doing so, but nothing happened? Does anything work with Growl on the computer?

That shouldn’t matter. Scrivener will check for Growl first, and if it is present it will use that no matter what. It will only switch to using Notifications if Growl is missing, or if you’ve set that hidden defaults flag.

Did you check for messages from Scrivener, in Console.app? It’s hard to say without any system feedback on why it isn’t working, especially after a full environment reset as you describe. There will only be warning message though, routine things such as whether a notification was sent or not will not be spammed to the system log.

Yeah, and unfortunately I don’t know for sure if it does. People don’t tend to write in to tell us when things work. :slight_smile:

I can’t stand Notification Centre either. I don’t like the implementation—that huge sidebar, and the fact that certain things cannot be disabled. I couldn’t care less what the App Store has to say, yet on a daily basis it would pester me about software upgrades. Anyway, what I’m getting at is that I disliked it so much I researched how to nuke it, and in fact on 10.8 – 9 it will even remove the icon from the status menu bar area (unfortunately on 10.10, even if you completely disable it at the system level, the button remains, doing nothing when you click on it).

Now if I could just get rid of the Spotlight icon. :imp:

I’m not sure if that will make Growl suddenly start working, as I said it should be already—but if you don’t want to be pestered by Apple’s whims, it beats going back to 10.6 to do so.

I don’t believe so, all I know is you can disable sound on a per-program basis in the System Preferences panel.

Just a simple suggestion, for which you’ll probably cast your eyes up to heaven, but …

I’ve just moved up to Yosemite, but I’ve never had any problem with Growl not working in any of the OS-X iterations over many many years. I’ve just done a complete HD erase and done a clean install of 10.10 and my apps, as my late 2010 MBA is “challenged” by Yosemite and it was taking 4 minutes to shut down; I presumed it was partly down to cruft from successive OS upgrades in place.

Anyway, in the process I downloaded a new instance of Growl 2.1.3 and installed it. As always, I went straight to Preferences and found a switch to have Growl take precedence over Notifications, which I set, also a switch for turning on or off Growl for Growl-aware apps … initially it was empty, but if I run Growl in the foreground while one of them is running, Scrivener for instance, it immediately appeared in the list.

Nowhere in this discussion have either of you mentioned looking at the Growl Preferences, so …

Mr X … rapidly donning flak jacket … :laughing:

It’s not a tool, it’s a very basic script to enable logging, but I’m pretty sure it doesn’t work!! :unamused:

#!/bin/zsh -f
function growl_setdefault { defaults write com.growl.growlhelperapp $* }
#Force-quit Growl’s background process so that the change has effect.
killall GrowlHelperApp
growl_setdefault ‘Custom log history 1’ “$HOME/Library/Logs/Growl.log”
growl_setdefault ‘GrowlLogType’ -int 1
growl_setdefault ‘GrowlLoggingEnabled’ -bool YES
#Relaunch Growl’s background process, in case it was running before.
open -b com.growl.growlhelperapp

I don’t use Growl for anything but Scrivener. But just to check its functionality I installed the Google Notifier and the Growl add on for the notifier, and yes, that worked.

Yes, there’s absolutely nothing in the log. I’ve attached a screenshot for you.

From the first marker to the second is where I have added today’s Wordcount to Scrivener. As you can see, there’s nothing there. But then I’m not sure I’d expect anything to be there since the Notification Center was enabled and gave it’s alert without a problem, yet the console still remained empty.

From the second marker to the third is a test of a new mail. Although Google Notifier isn’t supported any more, you can see it interacting with Growl and sending out the message to say it isn’t supported. You get the growl display and sound without a problem.

That sandbox error at the very bottom… that popped up after all the tests were finished, and it does appear periodically throughout the log, I googled it but came out none the wiser.

LOL, yes, we should make a point of doing that more, emailing you on a weekly basis to let you know everything is working! :smiley:

Yes, it’s the one good thing that’s come out of this … I now know how to disable Notification Center entirely! Yay!

Ahh, now that one I can help you with, if you change its permissions it won’t load, and if you ever find you miss it :laughing: , you can always change them back again:

Disable:
sh-3.2# sudo chmod 600 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
sh-3.2# killall SystemUIServer
Enable:
sh-3.2# sudo chmod 755 /System/Library/CoreServices/Search.bundle/Contents/MacOS/Search
sh-3.2# killall SystemUIServer

Unfortunately not. Nuking Notification Center was one of the first things I tried. It doesn’t make a difference. I’m at a loss. I would imagine that if people were having the same problem, they would be logging it here and we could be sure there’s a problem somewhere. The fact that I’m waving my little flag alone suggests it’s something specific to my system. I’m not sure it’s worth you and I wasting any more time on it without trying a reinstall, so I’ll get on with that.

If you do think of something, let me know. Once I’ve had a chance to reinstall, I’ll come back on here and put an update to let you know if it worked.

Thanks Amber
Gilly

Mr X, ROFLed at the donned flak jacket!!

As it happens, I always appreciate a response on forums, whether they are helpful or not. People have to take the time to post and it’s nice for someone to do that for a complete stranger, so thank you.

I’ve been using Scrivener with Growl for many years now. I’ve only had this problem since upgrading to Mavericks. My Growl and Scrivener preferences are unchanged. Scrivener does appear in my Growl preferences, and is enabled. In the general preferences tab for Growl, my OS X Notifications are turned off.

I think Amber hasn’t asked for screenshots of this because they haven’t changed and were working perfectly before the upgrade.

You may have hit on the ultimate solution though … a clean install! Watch this space …

Thanks for responding!
Gilly

Amber, I’m now on El Capitan but having exactly the same problem so a full OS Install, new Scrivener install and new Growl install hasn’t changed the issue. It still doesn’t work.

Although I’ve had almost 100 views on my El Capitan / Growl post, nobody has anything to add, nobody has even posted if they’ve managed to get it working.

Is there anything else you can think of that I could try?

I’d be so grateful for some help. I’ve logged a case on Growl Support but they haven’t come up with anything as yet.

Thanks so much and Happy New Year!
Gilly

You mentioned a clean install of the OS, are you using the old user folder however? Something you could try is creating a new Mac account and once you’re in there, try testing the two together using a very low word goal or something. If it works there, it probably means something in your ~/Library folder needs fixing, but Growl support may know more about that.

Hi Amber,

Thanks so much for coming back to me. I’d so like to get this working again.

No, wasn’t the same folder. Everything was completely blown away as my disk failed and everything had to come down from backups.

But, just to be sure I created a new user, new Scrivener file, set a low word count target and left Growl with all its default settings. It still didn’t work. As you can see from the screenshot, as soon as I reach the goal, the notification goes straight to the Notification Centre bypassing Growl.

Do you know of anyone who has this working. I asked in the post about El Capitan but nobody has replied, not even to say its working for them. Do you have El Capitan there somewhere you can test it on. It would be interesting to know if this is a universal issue or something specific to my set up.

Thanks so much.
Gilly

I don’t think many people use Growl these days since that concept already exists on the Mac as a default. I had a thought though, are you using the Mac App Store version of Scrivener? If so, try downloading the direct-sale version and see if that works.

Hi Amber,

I am already using the direct sale version. Though I have seen people on the forum get this working by switching to the direct sale, I wonder if it would work if I bought the Apple store version but to get that I’d have to buy Scrivener all over again.

Unless there’s a way to credit it somehow?

Thanks!
Gilly

If anything the direct-sale version would have a better chance of connecting, hmm. I tried getting Growl working yesterday on my other Mac, which is running 10.10, and never could get Scrivener to favour Growl over Notifications. Everything seemed to be configured correctly, but it just wouldn’t take. So it looks like at the least we have a system that we can test your findings with and perhaps find a resolution.

That’s great Amber, thanks for trying that. At least I know it isn’t something I’m doing wrong now. I still have a case open with Growl but they are struggling to find a reason too, I’ll keep pushing them for assistance, though they do take a little bit of pushing. Hopefully you can get to the bottom of it, I’ll wait to hear from you.

Thanks again - I really appreciate it.

I know it seems like a small issue but when you’re writing a novel, the Growl notifications are a real boost when you hit your word count for the day. Esp. for me right now as I’m writing 2,500 words a day to a really tight deadline.

Speak soon.
Best wishes
Gilly

Hi Amber,

Just FYI, Growl support asked me to try it with another application so I kicked of a Handbrake encode set to notify via Growl and it worked straight away with no problems at all.

I suspect Growl will now come back and say they can’t help any further as it’s a Scrivener issue.

Just wanted to let you know.

Thanks for your help.

Gilly

Okay, my very preliminary guess is that there is something wrong with the logic that selects which notification service to use, making it so that it never even tries Growl, hence the complete lack of logging and evidence of attempts. That it happens on multiple OS X versions suggests a simpler problem like that.