Habitual constructions

I like the word frequency listing (and the ability to list common words, eg “as” in Scrivener (shift-alt-command-s). I have two questions about it.
One: the dialogue disappears below the screen and there’s no way to move it - how can I fix this?
The other: is there any facility for looking at habitual structures (eg double-phrases starting with a subsidiary phrase) “As she opened the door the monster leaped”, “While the monster was distracted, Amelia turned into a monstance”)? I know this is a bit of an ask, but forever hopeful…

Sorry, forgot to add the picture of the dialogue box. Here it is, I hope.

To my knowledge, Scrivener doesn’t handle any content analysis per se. This is something you’d get – to some extent – from a third party app. Say Antidote, for example.
I don’t think it gets that specific, but it has a lot of analytical tools; way beyond the standard spellcheck.

If, on the other hand, all you want is to be able to locate them within your project, there might be a solution possible conducting a search using RegEx. If you can identify redundant patterns within those sentences (structure, single coma, no coma, etc), it might then be possible to develop a formula.
But don’t expect a miracle.

ProWriting Aid has tools for identifying overused words and I think something similar for sentences. It’s not so much an AI as a move advanced grammar/spellecheck.

I’ve played with it on the web (free) and intend to try the desktop edition when I finish my current WIP.

The word frequency feature is useful and helped me to realise, amongst other things, I overwork “so”. Occasionally I have dragged my Scrivener documents into a corpus analysis tool and looked at multiword overworks.

This is good, I’ll try these.

What about the dialogue box? Can anyone help on this, please?

Never heard of it. What is that?

See above. Or see here, perhaps this image is clearer. Only half of the dialogue box appears on the screen, and it can’t be moved, so you can’t easily scoot up and down it.


The size of the box is controlled by the display settings on your Mac operating system. You can adjust it by going to Apple menu ▸ System Preferences and click on Displays. In the Displays window you should have two choices for your resolution. “Default for Display” and “Scaled”. I think yours might be set to “Scaled” with larger text. See if setting it to “Default for Display” enables you to see the entire dialogue box.

Damn, this is a big fault in Mac’s settings - I can either be able to see the text or be able to work the dialogue boxes.