Have to compile twice to get a useable Word formatted document

I have a weird Compile problem in Windows 3 beta (current beta, and last several versions since I downloaded beta). I’ve set up a Compile project format that works for me to move a chapter of text from Scrivener Windows beta to Word. However, the first time I compile each chapter, it saves it in a blank format (see bottom line in picture below). This blank format can’t be opened in Word, Notepad, or any other program I’ve tried.

Then I compile the same text again, and it saves in a DOCX format the way it is supposed to (see top line in picture below). I don’t change anything in the set-up of the format or the text to compile. All I do is run the same compile again. The second time I run it, I get a DOCX file, which I can open easily in Word.
compile problem.JPG

Can you explain what is going wrong in the conversion the first time and why I have to compile everything twice to get it to work?

Can you please upload a small project that reproduces the problem?

I’ve made a project with just one chapter in it that I’m happy to send you, but I don’t know how to upload it – do I send you all the folders or just the SCRIV file? You might need the Project format I’ve set up in the Compile screen as well. Just let me know what to send.

This might be a Windows Quick Access issue. When I compile the first time, what appears in the Quick Access menu is a blank file which I can’t open in Word. If I compile again, that’s when I see the Word file (along with the blank file) in the Quick Access menu. But if I just compile once and go to the Windows Documents folder where the compiled document goes, I can see a Word file that I can open. But I usually use the Quick Access menu to open the compiled file, so that’s why I notice the problem.

Thank you.

You should archive the complete project folder, and upload the archive in a message within this thread. The project folder contains also the compile format, if you are using a Project compile format.

To have two documents/files with the same name, the file extension must be different. What is the file extension of the file that does not open upon the first compilation attempt?

I am attaching the zipped mini-project for you to examine.

In response to your question as to what the extension is on the file I can’t open, it has no extension. This phantom file shows up in Quick Access, but not in the actual folder where my compiles are stored. So it might not be a programming problem in Scrivener beta; it might be some quirk in how Scrivener beta works with the Quick Access menu. But it doesn’t happen with any other programs I use that I open from the Quick Access menu. And it doesn’t happen with Scrivener 1.9.x for Windows files.

Thank you.
Beta test project.scriv.zip (785 KB)