Having compile issues :(

Hi all.

I have a three part serial split up in the same file. Part 1 and 2 compile just fine, with the front matter centering, include the ToC, but when I’ve started part 3, not touching the compile elements at all…it won’t work. Nothing is centering, not even the ToC, and I’m at a complete loss. Even when I try to copy and paste into a file that compiles correctly, the same thing happens. I am very frustrated right now, and on the verge of tears. What can possibly be the problem?


I started a new file completely. Put in some text files, typed a few words, set up to compile, clicked to make sure ToC is centered, saved. It’s not centered, and neither are the chapter headings. I don’t have the override settings turned on, there is NO reason it won’t do what I want it to do. I am at a complete loss here.

Based on a quick search of the forums on “centering”, a couple of possibilities… I could be wrong.

In Parts 1 and 2, where it is working, you may have employed one of two possibilities to accomplish this…

  • In the expanded Compile dialog, under Contents, you may have clicked (put a checkmark in) the As-Is checkbox for the item(s) containing the front matter/TOC. As I understand it, this tells the compiler to honor the centering formatting you did there. If so (i.e. if you see As-Is checkmarked for those Part 1 and 2 items in the compile contents tree, click the As-Is checkbox for the corresponding item(s) in Part 3.

  • In the editor, in Parts 1 and 2, you may have selected the centered material and done a Format > Formatting > Preserve Formatting. If you did, the centered material will likely have dotted box(s) around it (and perhaps a background color other than white). If so, in the editor, in Part 3, select the centered text and apply Format > Formatting > Preserve Formatting to it.

Post back, to let folks know how it goes. Good luck.

You’re not wrong. I checked both those things.i do the as is, but I didn’t do the preserve formatting. I am honestly at a complete loss. It’s even doing the same thing in completely new files. I appreciate the response though, thank you! I’m still trying to figure it out. :\

Can you post a picture of your binder structure?

Okay…I’ve included it but not sure if that’s what you need.

I have done everything including uninstalling and reinstalling. I am a complete loss and honestly, quite frustrated.

Is the “Sacrifices” folder the only one that has blank text files?

If yes and if it is the folder that is breaking Compile, does Compile work if you drop a word or two into each of the blank text files?

I just did it to check…and no. Same issue. It won’t center the ToC, nor the chapter headings. I’ve posted what it’s doing.

and here is my settings:

Also, I zipped the file and sent it to my PC with Scrivener on it…and it still did it there. :neutral_face: If I copy and take out the formatting and repaste…STILL does it.

Secrets and Suspicions compile as you want, yes? Sacrifices doesn’t?

If you duplicate Secrets or Suspicions to create a new third folder, does compile work as you want?

If yes, does it work if you keep the new third folder and copy and paste content from Sacrifices? (One text file at a time, in order to identify if one text file is causing an issue.)

Alternatively, if you move Sacrifices so it is the first folder, does it work okay?

Anything unusual in the text being copied and pasted? Just plain text? Does it work if you use “Paste & Match Style”? Was the “problem” text typed in Scrivener, or did it come from another program originally?