having problems importing videos

When I import a video from a web page, the video comes through twice. Help!

You’re importing the web page, not the video - you’ll need to find a way to download the video from the site and import that separately. What is happening currently is that you are importing the web page and not the video, which gets stored as a web archive. For some reason when reloaded, web archives don’t show videos so well. But if you want the video, you wouldn’t normally want it embedded in the rest of the web page anyway. So as I say, download the video as a standalone video file and import that.

All the best,

Any clue how to save just the video? I have a Mac?

Well, obviously you have a Mac, or you wouldn’t be using Scrivener. :slight_smile: It really depends on the website. On some web pages you can just ctrl-click on the video and select “Download”. If it’s embedded, it’s more difficult. One thing you can do is look in Safari’s Activity window (available from Safari’s “Window” menu), as this shows all web pages and files currently in use and open by Safari. If you can locate the video file there, you can double-click to download it. For YouTube, I believe there are websites out there that allow you to download YouTube videos, but I don’t know any off-hand. The trouble is that a lot of sites don’t want you downloading the videos but only streaming them, so they make them difficult to download.
All the best,

Ha! Of course I have a Mac . . . see how tech savvy I am.

Thanks for your help. I’m working on it.

If you could provide us with a sample (or a page that acts similarly), it would help us give you some more concrete instructions. There are dozens of ways of sharing video on the Web, and nearly all of them have different techniques for extraction, some much more difficult than others.

there are two videos I’m trying to download.
Here are the links to their pages:


Okay, for the YouTube video you can use an online download provider, like SaveVid. It will scan the full YouTube URL you provide it, and give you a number of download options, saving you the step of having to convert the FLV file later. MP4 is a good format for working with Scrivener.

For the second video, you don’t have to work around the website’s artificial restrictions. They give you full access to the video. Simply click on the little down-arrow after the clip fully loads, and select “Save as QuickTime Movie”.

I already tested both, and was able to get them both into Scrivener without any difficulty.

My quicktime wasn’t the right edition and I didn’t want to buy the quicktime 7 pro if I wasn’t sure it was going to work. Is that what you used?
Also, when I’m importing it to Scrivener, do I do it as a “webpage” or as a “file”?

Thanks for your help.

I am just using the standard QuickTime player, not Pro. While it is version 10.0, the feature I referenced is something that has existed in the QuickTime player for many years, so it should be available. The main thing to watch for is that the clip has completely loaded. The menu items will not be activated in some cases until that condition has been reached.

If you can’t get this method to work, Keith’s tip for downloading stuff from Safari’s activity browser would probably be the next easiest thing to try. Look for the item that ends in “.mp4”.

After downloading the files to your drive, just drag and drop them into the Binder from Finder, or you could use the File Import feature if that is easier for you. You don’t want web import though. Once downloaded, the files are local movies on your disk.

Okay - I used Savevid and that worked.
Now, how do I get it from savevid into scrivener??

Did you click on the blue “MP4” button in SaveVid? If so, you should have a file in your download folder. If you don’t know where that is, you could check Safari’s preferences. Once you know where it is, use “File/Import/Files…” menu item in Scrivener, navigate to the folder where it downloaded, and click on the movie. Click “Okay” and a moment later you should have the file in your Binder. Make sure you select the Research folder first, before doing this. You can’t import movies into the Draft. Repeat these steps for the other movie as well.

Oh, Oh! I got it to work!!
Thank you! You’ve been very helpful.

You’re welcome!