Having Problems with Indention During Compile

I looked, but couldn’t find this topic so forgive me if it indeed is posted on the forum, but I’ve overlooked it.

Okay. I am compiling my thesis (novel) and have run into a rather frustrating problem more than once during the compiling process.

Workflow is as follows:

  1. I arrange all of the settings within the Compile menus, including formatting of course, and press compile to Print/PDF format and view in Preview so that I can … well…preview it before it goes to print or export.
  2. I then notice an indention problem (paragraphs indented much too far in) within my draft, even though I had set the indention to the correct number on the ruler. It may be different than the formatting I use during the writing process, but I thought it shouldn’t matter what format the initial draft is written in, when I comes to the compile phase.
  3. I’ve then tried highlighting all the documents in my draft and use the format>convert>Multiple Space to Space command, but it still comes up the same in the compilation preview.

Why aren’t the compile settings holding or reformatting my documents, even though those documents might have too much indention applied to them while I was writing?

Please help! Must send this out today, Express.



Stab in the dark, here, but were you indenting by pressing the Tab key, while writing? If so, that will be impervious to the compiler’s reformatting features, as it is an actual character in your draft, just as important as any character of the alphabet, from the compiler’s point of view. If you don’t otherwise use tabs in your document, and this is the case, you could do a global search and replace to knock them all out of the original text.

The other things to check are those flags in the compiler that impact indentation. Obviously, make sure “Override text notes and formatting” is turned on, and when you click the Options button beside it, make sure “Preserve tabs and indents” is off.

Hi Amber, and thank you for your immediate response!

I most likely have used tabs during writing, subconsciously. Oops. However, I’ve tried search and replace, but it won’t allow me to type in a tab in the search field. What am I missing?

I have definitely unchecked the appropriate boxes in the compiler.

Thank you again,


If you don’t use tabs anywhere else in the manuscript, then it is safe to use the Project Replace tool to wipe them all out in one shot. If you are unsure though, I’d make a backup first, probably isn’t a bad idea to do that before using Project Replace, anyway. To insert special characters into the search tools, hold down the Option key before tapping the appropriate key. So Option-Tab will insert a tab character which can then be found and eliminated with an empty replace field. You won’t see anything when you do this, the tab character will be invisible, but it’s there. You can also use this tip to search for carriage returns.


Was that tip in the manual? I remember reading that a tab is in fact a character, but I had no idea it was impervious to the Compiler’s format settings.

And that tip about entering in the special characters, Option + the key in question…

You’re a life saver, my man.


All the best,


You’re welcome! The manual does discuss inputting special characters into search fields, but I don’t think it talks about not using tabs to indent paragraphs. I try to stay away from discussing negatives as much as possible as there is no end to the list of negatives one can conjure. I think there is a spot where using the first-line indent marker on the ruler is mentioned as being the way to indent paragraphs—and this is the default state of Scrivener when you unwrap it—all paragraphs are indented with 0.5" or so in the factory settings—so there is a little implication by demonstration there, too. I’ll have to verify that though, as reaffirming that in the documentation would be the right thing to do.