Header and Footer settings not working

So here’s a conundrum. I’ve got my file ready to print, and I need to export it into a pdf format. The last page needs to be completely blank.

I can’t find a way to insert a blank page at the end that doesn’t have the header and footer. I’ve changed all the appropriate settings (please see attaching images) and it’s STILL printing a header and footer on the back matter page.

It’s a book of poetry, so I can’t use the option of checking “no header or footer on single pages” or none of the poems will have page numbers.

Does anyone have a brilliant workaround?

Thanks in advance for any help!
Compile selections.png


Someone else might have a better idea, but with the header and footer settings you already have, the fudge suggested in sample project attached should work.

Slàinte mhòr.

Blank Page.zip (459 KB)

JoRo! Now I definitely have to buy you coffee!!

So here’s the craziness - I did exactly this as I was trying everything I could to get that flipping blank page to print. But since I was making it up as I went along, I didn’t type a space, I hit space and return - and the page header and footer still showed up. Taking away the paragraph return and JUST leaving the space was the magic bullet. So weird. And thank you!!! :smiley:

Good to hear it worked. As I said before, someone else might have a more elegant solution for you.

There is a blank-page tag that can be used to create a blank page that compile will not attempt to remove, but in my tests, the text of the tag printed to PDF rather than creating the blank page that it is meant to do. The single space was enough to convince the compiler to leave the page in situ.

Slàinte mhòr.

There are two things triggering this:

  1. There is a limitation whereby the first regular document after front matter and the first back matter document must contain text in order to be recognised as such and for the header and footer to therefore be printed differently. If there’s no text, then Scrivener cannot find the page number the document ends up on. So, if you want a blank page, you should use <$BLANK_PAGE>.

  2. There is a bug whereby the <$BLANK_PAGE> tag is not working as it should if it’s on the very last page of the document. I’ve fixed this for the next update. JoRo’s workaround is just as good, though, since it works around the limitation of (1).

All the best,
Keith

Thank you, Keith.

When time allowed, I was going to start a thread asking if the blank-page tag was behaving as it should, but your reply has pre-empted the need to do that.

Glad the fudge works without creating anything unsightly or unwieldy. Scrivener’s ability to flex and dance its way around a billion different compile options and use cases never ceases to delight.

Slàinte mhòr.

Thanks, Keith! I can’t imagine the amount of coding that goes into this. I appreciate the info, I’m looking forward to the next update, and I love that there’s a workaround until then. :slight_smile: