Header/footer/page number help please

I am having difficulty getting the header/footer/page number to work as I want. I go to compile, page settings, first pages. I check 'different first pages header/footer" I type in my title for the header and <$p> for page numbering. Both the header and page numbers begin on ‘page one’, where I do not want them. I want them to begin on page one of my text, which is like page 10, after my title, preface, table of contents.


Have you told Scrivener where page numbering should start?


Yes, but probably did it wrong. I want it to start on page 13, but I tried as you advised, using page 10. Didn’t work. I will try again now. Thanks for the reminder.


This post might help if you have used front matter outside the draft (not the references to a bug, of course!).

Briar, I just looked at it once more. It was still set to start on page 10, yet the header and page number begin on page one.

Is your front matter in a separate folder? Seen the post above?

Page numbers count first pages is checked as well.

I tried the front matter as a separate folder yesterday, probably did that wrong as well. Let me spend some time this morning on it, see if I can learn how to make it work. Thanks.

Good luck.

FWIW, these settings work for one of my novels, using front matter, Roman numerals on front-matter pages, and standard numbering (page 1) from the start of the novel.


[attachment=1]Page Settings.png[/attachment]

The front matter sits outside the manuscript folder.


Thanks Briar, got the header where I want it.

Now the page numbers are not as I want. It begins as page 10 on page 10 (the front matter does not show any page numbers). I would prefer it be page 1 on page 10. And it only shows the page number on every other page. I can live with it beginning with ‘10’ instead of ‘1’ where I want the page numbers to begin, but obviously it needs to show a page number on each page. Suggestions?

Briar, I need to get you in my writing group, we need you! (theironwriter.com)
We use flash fiction as a way to improve our writing (not saying yours needs improving, just us) But several of us use Scrivener but we keep defaulting to Word. I am determined to toss Word overboard. Hence my questions this morning. Thanks for the help.

So how do I get the page numbers to be on every page? Not ever other page.

Another question. My front matter is 9 pages long. No blank pages included. I would like to add blank pages, but this would put the page numbering to begin on one of those blank pages. Is there a way to begin page number beyond page 10?

Possibly the setting indicated below.


Unchecked that box. Page numbering now begins with ‘1’ on the page I want. However, it still puts a page number on every other page, all the odd numbers. No even page numbers.

Also, in case you missed it Briar, I want to put a couple of blank pages in my front matter, but this forced the page numbering to begin in the front matter. How do I make the page number begin at the beginning of the novel (in this case an anthology for my writing group). As far as I see, it limits me to page 10.

You need to make sure that <$p> tag is included (in whatever position you want) in the Header and Footer setting and in the Facing Pages setting.

[attachment=1]header footer.png[/attachment]


Looks like the site is doing well. Congrats. Don’t write flash fiction, but I’d join if I did.

Yes, good idea (IMO) to ditch Word.


Perfect. That was it. Thank you.
Now to get the front matter blank pages working and I am ready.

Agreed on ditching Word. Hence my determination to master Scrivener. Any ideas on expanding my front matter. And I need to learn how to make what I want begin in recto.

Using the settings mentioned earlier, my front matter has 15 pages. The novel proper starts on page 16, and it is numbered 1. So, yes, it should be possible to get the numbering to work as you need.

Sometimes, Scrivener needs a few trial compiles before a user finally reaches utopia. The problem can be stopping…there are so many permutations and possibilities. I have gone through endless test compiles.