Hello, how do you undo? :)

Hi,
New user here.

I’m experimenting a bit with the basic Tutorial and can’t figure out how to UNDO edits:

If I edit a document in Single Document Mode, then switch to Corkboard and back again, I can’t undo that edit.

Related: When I switch back to Single Document Mode, I don’t ‘land’ in the same location again. Is there a way to do that? (When I realized this, I tried to Cmd Z to find my original location again, which is how I usually ‘go home’ in Word if I’m lost; that’s how I realized that I actually couldn’t Undo, either…)

Thanks in advance for any insights on this…

Hi. Welcome to the forum Visitor.

First, note that undos are only for edits. They won’t navigate back.

In your case, to go back to single document view, click here :

To navigate back/forward the editor :
image

For the undo of your previous edits, to take a guess (I’m under Windows) I’d say click in the editor after navigating back to it, prior to Cmd-Z.

Hi Vincent_Vincent,
Thank you for your fast reply!

  1. Regarding Undos for navigation: When I’m lost in a large Word document, I always Undo my last edit to ‘go home’. I just checked in Scrivener and that trick also works here. But that obviously only works when Undo itself works…

  2. I know how to switch between modes – but I don’t know how to return to the exact position I left; e.g. if I switch between Outline and Print Layout in Word, my position isn’t changed. But when switch from Single Document View to Corkboard and back again, I’m not returned to the exact position I left. This means that it would take a lot of time to find that exact position again in a large document, unless there’s some trick to do that.

  3. Regarding Undo: As mentioned in my first post, I can’t undo edits in Single Document View if I switch to Corkboard and then back again; Cmd Z doesn’t work, and Undo/Redo functions are greyed out in the Edit menu…

space - backspace :wink: That’ll take you back to cursor position. Maybe using left/right arrows would be safer (in case you had a text selection).
If what you meant is that you lose scroll position, take the habit of positioning the cursor to your reading position before navigating away from your document.

For your other issues, being a windows user, I’ll leave the matter to better able forum members.

Thank you again! Could I ask what you mean by space - backspace? I tried those keys after returning to Single Document View, but they didn’t bring me back to my original position. Perhaps it works differently on PC…

I just made a short screen video that illustrates these two issues – but the forum software doesn’t seem to accept video files.

So, I’ll explain what the video shows instead:

  1. In Single Document View, I delete the word “Mode” in chapter 3 “Outliner Mode”
  2. The video shows that Undo is now possible.
  3. I switch to Corkboard mode.
  4. I switch back to Single Document View – but two unfortunate things happen now:
    a) I’m not back where I left in that document at chapter 3. Instead I automatically land in Chapter 1. Which means it could take a lot of time to find the correct position again, unless there’s a trick to do that.
    b) The video shows that Undo is no longer possible.

I edited my previous post.

Thank you very much :slight_smile: – I did try this and it sounds like a clever idea, but I think it works differently on Mac; no matter where I place the cursor before I switch to Corkboard view, it’s placed somewhere else when I return…

That shouldn’t be. Just like being unable to undo.
Probably some setting wrong in your system.
A read-only setting for your files or something…
@kewms

Agree, it seems weird to me because the rest of the app is so clever and seems to work completely as expected.

But I just installed the app yesterday for the first time, and I literally haven’t changed any settings.

I have, however, looked through all the dialogue boxes before signing up here, and I simply can’t find any settings that pertain to enabling/disabling basic edits, nor to landing at the expected position after switching between modes.

EDIT: Thank you for your last edit – since the file I’m testing is the app’s tutorial, it may in fact work differently than custom files. I’ll try a new file and see what happens…

I’ll just add that I tried the same procedure as described above in a new custom project made from scratch – but it behaves the exact same way.

… I asked Support for their help on this; I’ll post an update if I find a solution…

One thing you can do is split the screen and in one screen switch to cork board mode and do your business, and when you are finished you close the cork board window. This way you don’t lose your position in your document.

1 Like

Thank you Orpheus, that’s certainly a work-around – and it solves both issues! :+1:

Scrivener also has the ability to navigate forward and backwards in your document; rather than “undo/redo” to find your place as we might do in word, just hit “cmd-[” to go back to where you were.

image

However, I find it surprising and a bit awkward that navigating away from a document clears the undo buffer entirely, so I’d be quite interested to learn what Support tells you about that.

1 Like

Thank you for your reply, dondo!

I tried your trick, but I think there’s a dark side to it: After using Cmd-[ or ], the undo buffer is also cleared.

I’m glad that Orpheus suggested split-screen as a work-around, because I’m using undo-redo extensively to scroll through changes experimentally to see what works.

Clearing the cache feels like a computer crash. And it would’ve been a turn-off to me without the split-screen option.

But I’ll let you know what Support has to say…

1 Like

⌘[ and ⌘] don’t navigate back and forth in a document. They navigate between documents in a project.

I’d just let you know that Support could replicate the behavior.

Scrivener’s Mac development team will now look into the issues. I’ll update this when I know more.

Bottom line, so far: This is not expected behavior; it probably only appears on Mac under certain unspecified circumstances.

UPDATE:
This has been a little confusing:

First, the issue couldn’t be reproduced by Support, then it could – and now it turns out not to be an issue at all. Instead, it is expected behavior.

The primary “work-around” is split screen, as mentioned above – thanks for that again, Orpheus! – plus History and Snapshots.

Like I said earlier, I think split screen is a good solution. I just needed to be completely sure that my version of the software wasn’t corrupt in any way.

I’m sure of that now, and I’m very happy to start a large project in Scrivener today. :+1:

1 Like