[help]-[about fronts]-Need auto-switching fronts types between english letters and Chinese words


Actually, I have a specific front for english and another special front for Chinese. How could I set these fronts for both languages at one time and I hope when I type , the content about those two languages can be presented as i’d set for separately.


Set the English font as default in Preferences > Editing > Formatting. Then set up a character style for Chinese … quickest way is type some Chinese in a document and select it, or select some Chinese you’ve already typed, then Format > Style > New Style from Selection… In the dialog that opens:

[attachment=0]Screen Shot 2020-10-05 at 11.29.39.png[/attachment]

Give it a name—“Chinese” or is good or 汉语 if you prefer :slight_smile:— then set a Shortcut either by opening the dropdown and choosing an available one there, or by setting one up in System Preferences. Click the next dropdown so that “Save character attributes” is shown and click save.

Then, when you are working, every time you are going to enter Chinese, just use the shortcut.

All that said, since Scrivener separates the text creation stage from compiling into the final document, I often use the Aplle default of PingFang SC—ugly, I know—as I’ll sort it out in the compiled document through stylesheet in my word processor.



EDIT: Without knowing your purposes, there is one caveat about using a character style for this: if you are using footnotes and prefer the “Footnote Marker” approach you can set in Project > Project Settings… > Format, you’ll find stretches following the footnote marker will also be superscripted. So: (a) don’t use the footnote Marker and use highlighting as the footnote anchor; or (b) don’t use a character style and sort the font out in post-processing; or (c) sort out the random superscripting in post-processing.

Incidentally, for anyone else who reads this: (1) this bug affects any designated paragraph style + character style—e.g. Ingredients + Emphasis, in my recipe collection—where the footnote marker immediately follows the character-styled text; (2) if I remember rightly, it occurs with compiling to RTF, but not to DOCX, I presume KB’s DOCX compile doesn’t go through RTF on the way; (3) I spent some time with a member of the Scrivener team working this out, so presumably it’s on the huge list of things for KB to look at!

Thanks a lot dude. The hardest thing you have done with perfection is understanding my poor english and you amazingly and expanded the explanation for more situations i would meet in future. Well done,

My pleasure.