Help! Collection Not in Binder Order?

Version: (1274647) 64-bit - 28 Apr 2021


I’ve made a collection with a number of scenes selected from various parts of my WIP, intending to focus in on the events related to a specific faction of the story.

I have gone through and, going back and forth through the WIP, selected chapters & scenes to populate the collection with. This aspect seems to have worked okay, no issues.

However, when I go to actually use the collection, I find that the items are sorted in the ORDER I SELECTED THEM, and not in binder order, which is what I expected.

What have I done wrong, and how can I fix this-- apart from outright deleting the collection and re-making it ??



Just clicking on the Collection header and choose Edit > Sort > Collection into Binder Order from the main menu should do it. (At least, it does on the Mac and I don’t have the Windows version to hand to check, sorry…)


Thanks for the reply, and that’s what I figured… but I looked and looked but can’t find / don’t seem to have anything that will change the sort order to binder order. I’m using the Windows version.

I see — I think it must be missing from the Windows version at the moment then, because it’s definitely there on the Mac.

I imagine it’s on the ‘Catchup’ list, but support will have to give you a definitive answer on whether it’s planned for the future or it’s just not possible, given the toolkits they have to use.

Sorry for the confusion.

With regards to that concern itself, yes that is how it is intended to work. As you drag items into the tab, or use the menu command to add them to a collection, they are meant to be added to the bottom of the list. In general I would say standard collections are a tool aimed primarily at stuff not meant to be in binder order, but that is of course not the only way they can be used.

So as for getting them into binder order, at the moment you can take advantage of a bug in the software that causes the underlying order of any multiple selection to always be in binder order, regardless of its visual order. You can see this in front of you by using Ctrl+A in the collection sidebar. Note how the multiple selection in the main editor is out of order (or in order, if you consider the binder order correct)? So considering that, simply create a new collection from the selection, delete the old one, and there you go.

That’s obviously not always going to work, as I say it’s a bug, but hopefully when they do fix that, it is in conjunction with adding the menu command so that this does not become a blind spot.

Going forward, I’d also suggest that if you want a collection that is always in binder order no matter what, that making use of a temporary keyword, and setting up a keyword search collection, would be the preferred and best approach. That’s what I do when I need a binder order list. Then assigning things to that collection becomes a matter of simply adding the keyword to it, rather than interfacing with the collection directly.

If you reach a point where you are done collecting items, you can use the Navigate ▸ Collections ▸ Convert to Standard Collection command, and delete the keyword.


Hi Amber,

CTRL-A doesnt’ work for me. I guess they’ve already fixed it ?? I can understand how/why you might want collections to be how you add them. BUT, I would suggest that the option to SORT them should always be available, even if there’s a notice that it’s a ONE-TIME deal and you can’t go back.

I did think to use tags, and that was going to be my workaround if you didn’t have a better answer. But in trying to use tags, I have all of the documents in the collection selected (I did a CTRL-A and they’re all highlighted), and I pulled up the document tags (keywords) and selected one, and right-clicked and told it to apply to “All Selected Documents” and nothing happened. So apparently using the keyword trick as a workaround won’t work either.

I don’t want to change the labels, because that is my master thread assignment mechanism. I don’t mind adding keywords but they don’t seem o work when I have them selected in the collection.

AHHH - What DID work was to select them all in the collection and add them to a NEW collection. PLEASE DON’T FIX THAT BUG!!!* It is a fine workaround. Document it and call it a FEATURE !!!



BUT, I would suggest that the option to SORT them should always be available, even if there’s a notice that it’s a ONE-TIME deal and you can’t go back.

Yup, that’s how the menu command will work, with an option to no longer badger you with the warning once you’ve read it.

So apparently using the keyword trick as a workaround won’t work either.

That worked fine for me—perhaps your selection ended up in the editor when you were looking at them there. This keywords panel command targets the active selection, which can end up being nothing if you click into the editor corkboard, for example.

But to be clear I meant that suggestion more as a thing for going forward, where one would be tagging items as they come across them, much as you did when creating the collection the first time around—rather than as a way of sorting a collection after the fact as a work-around for not being able to do so at the moment. I.e. if you want collections that are binder sorted always, that approach is the best way to do it since search collections always keep themselves sorted; it isn’t something you have to do over and over whenever you add new items.

AHHH - What DID work was to select them all in the collection and add them to a NEW collection. PLEASE DON’T FIX THAT BUG!!!* It is a fine workaround. Document it and call it a FEATURE !!!

At the risk of going way off topic, the ramifications of it not working correctly are very broad, and break a lot of intended workflows throughout the software. You’re looking at it, I think, from the point of view of it “solving” this one very specific missing menu command, but consider the following intended capabilities meant to be provided by the ability to organise items:

  • You have a carefully organised collection you want to duplicate. How do you go about doing that right now?

  • Say you take a chapter’s text items into a collection with the purpose of reworking the flow of information within it. You shift things up and down until you get them just right, and then what? What you’re supposed to be able to do is select the collection and drag it back into the folder they came from. As of now, you have to laboriously do this yourself in a locked editor, duplicating your efforts. Funnily enough, this use case right here was the entire impetus for designing the Collection feature itself, back in the day. Obviously it has grown beyond the focal point of giving one a freeform place to experiment with text flow and then implement it (or not), but that it still does not work is a problem.

  • Sorting in the outliner is meaningless outside of what you can see with your eyes. Outliner sorting is meant to be a tool you can optionally use to sort items permanently, by any field of metadata you please (staving off endless requests to add dozens of options to the sort tool above the sidebar or the Sort menu).

  • Merging a selection of reorganised items ignores the order and merges in binder order always. That’s a bad one since backing out of a bad merge requires manual labour to undo.

  • When copying text from an organised list, the copy ignores the order and copies in binder order.

  • Compiling a current selection should use the order of that selection rather than the binder order.

There are probably many other circumstances and combinations of features that would benefit from being able to organise items freely and then take action on those things in a way that respects the work you’ve put into putting them into that order. Much the above can be boiled down to the question: what is the point of organising the text via the diverse means of doing so if all you can do with it is look at it?

But I think chief among the reasons is that it follows basic human expectations. If you pick up a basket of fruit organised by colour, when you set it down you expect the fruit to be in the same order, you don’t expect it to magically re-order itself according to how they were when sitting on the counter.

So to conclude, for those cases where you do for whatever reason want to set the basket down in a way that doesn’t match how things are in the basket, there is the sort menu command—which changes how the basket is organised. Clear, simple and back into the realm of human expectation.

I don’t disagree with a single word of what you just posted :slight_smile:
I would like to know though why I was unable to select the whole (collection) group and apply a keyword to it. That would have been an acceptable solution, albeit with an extra step. When I tried doing it though, it didn’t work.

I would need a clear set of steps to understand why that didn’t work for you. For me, if I select in whole or in part some items from a Collection list, open the Keywords pane, right-click on a keyword and apply them, they get assigned to the selection in the sidebar.


– I opened the collection and pressed CTRL-A. All of the items in the collection were selected

– I went to the Object Inspector and opened the keywords editor (Show Project Keywords)

– I selected a keyword (I already have one defined I’d like to use, f_OLIVER)

– I right-clicked on the keyword in the editor and then clicked on “Apply Keywords to Selected Documents”… and nothing happened.

I tried it several times and several ways, and they did not get set with the keyword. I looked at several of the documents individually, and they were not set.

CRAP. How come when I report the problem, it stops BEING a problem ??? :slight_smile:

Never mind. I have no idea what I did differently before, but it just worked now, so I know it must be something I did (or didn’t did)


Classic! :laughing: If you figure it out let me know! I am aware of some bugs with keyword assignment failing, but I think they are all in drag and drop rather than right-click.

My guess though is that in the process of opening the panel that way, you inadvertently clicked somewhere in the project window, which moved the focus away from the binder sidebar. For example so much as clicking in the keyword list in the inspector would move the focus there (where you could then press Enter to add a new keyword, or Shift-Arrow to select and Del to remove).

In fact, that you could even take the route you did is a bit of a bug in that selecting 15 items in the binder sidebar should immediately switch the Inspector over to project-only mode, offering only Project Bookmarks—the current behaviour incorrectly suggests one can inspect multiple items at once. But that is beside the point.

Yes, that is what it was doing. Whatever the first chapter was in the collection, is the one that I saw in the inspector, even after they were all selected (via ctrl-a). I flipped to the keywords tab, told it to show me the project keywords, picked one and then told it to apply to all selected.

That’s what I thought I did earlier when it didn’t work. But of course when I did it just now to tell you about it… it worked.

Just goes to show that the computer and software is clearly more afraid of you than me :slight_smile: