Help compiling 3 levels (part, chapter, subchapter)

Hi, I have been struggling to achieve this for 2 days. Anyone that could help me? I am not a tech guy, so a “step by step”-run through would be DEEPLY appreciated:

I have a manuscript I would like to organize this way: Level 1: Part (a folder?). Ranging from 1-4 (say). In Part 1 I would like to keep my chapters (folder?). And inside those folders - sub-chapters. (Just need to see the headings for them in the compile as it makes me better remember where I am in the book.

The Parts and the Chapters - I would love them to be autonumbered. The subchapters can be retrieved from the text name. Like

PART 1 (part)
CHAPTER 1
Subchapter
Subchapter
Subchapter
Subchapter
CHAPTER 2
Subchapter
Subchapter
Subchapter
Subchapter
CHAPTER 3
Subchapter
Subchapter
Subchapter
Subchapter
PART 2
CHAPTER 4
Subchapter
Subchapter
Subchapter

And so on.

Deeply appreciate help. Hope for a quick answer as I am on a deadline. Thanks a lot, lot, lot :smiley: :smiley: :smiley:

I don’t know of a way to autonumber them on creation. I typically title them as I create them. Relying on auto-numbering can get tricky when you starting moving documents around – should it get renumbered or stay the same? Numbering can be applied at Compile, when your format is locked down.

Hi there,
Tanks for an answer. I was speaking about the compile-process. Not autonumbering the folder/binder-structure :slight_smile:

I’m assuming you have the parts and chapters as folders, with the subchapters as documents within the chapter folders and the chapter folders as children of the the parts folders. Basically, like this in the binder:

Part (as folder)
Chapter (as folder)
[list] Subchapter (as document)
Subchapter (as document)[/list:u]
Part (as folder)
Chapter (as folder)
[list] Subchapter (as document)
Subchapter (as document)[/list:u]

If so, then it’s fairly simple. In the Compile box, click Formatting. In the upper right pane, you should have a number of levels of folders and documents (titled Level 1, Level 2+, etc). The Level 1 folder is the Part folders. The Level 2 folder is the Chapter folders. The Level 1 document is any document that is on the same level as the Part folders in your binder. There probably aren’t any of these. Likewise, the Level 2 document is for any documents on the same level as the Chapter folders. The Level 3 document will be the Subchapter documents in your binder.

Click to highlight the Level 1 Folder. In the bottom right pane, click the “Section Layout” button. In the “Prefix” box, type “Part <$R>” without the quotes. This will autonumber all of the Part sections with uppercase Roman numerals. You can also use <$t> to spell out the number as a word or <$n> to use the Arabic numeral. Click “Ok” to go back to the previous window. Now click the “Title” button next to the Level 1 Folder so there’s no X in it. This will prevent whatever title you’ve used for your Parts folders to be added to the compiled output. If you want them, though, then leave this checked (if you choose to do this, I’d recommend putting a colon after Part <$R> from earlier, so you’ll get “Part I: Title,” or whatever you use). Whatever you decide to do, the output will be previewed in the bottom right pane under the “Section Layout” button. Tweak until it looks right.

Do the same thing for the Level 2+ Folder, but in the “Prefix” box under “Section Layout,” type “Chapter <$R>” (again without the quotes, and using whatever numbering format you’d prefer here). You can add the title again, if you want. Just like for the Level 1 Part folders, the title will come from whatever you’ve chosen as the name for each individual Chapter folder in the Binder.

You can ignore the options for the Level 1 and Level 2 documents in this window, since you probably won’t have any. Now click to highlight the Level 3+ Document. You don’t have to do anything with “Section Layout” for this one if you only want the title. Simply check the “Title” button box next to the Level 3+ Document and you’ll get the title of each document added at each section break.

That will make the numbering and titling work right. Then click “Contents” in the left pane of the Compile window and make sure all of your Parts and Chapter folders and Subchapter documents are checked. Everything should then compile the way you want it. Hope this helps.

Thanks a lot. I will give it a try. Your summary of my binder was totally correct :slight_smile:

If you end up getting confused by all the settings, try experimenting with the compile presets*. Select something from the Format As drop-down list and compile with those settings. Examine what it produces, and if it’s nowhere near what you’re after, try another promising preset. You should find something that approximates what you want your final output to look like. At that point you can begin changing the settings as described above, but you may find that much of the work has already been done for you!

From your explanation above, the presets I’d recommend are Paperback Novel with Parts or Nonfiction with Sub-heads.

  • Please be aware that choosing one of the compile presets will wipe out all of the compiler settings that you’ve been working on, so don’t do this unless you want to start over.

Hi again. This works - greatly. But something goes wrong with the first chapter. It says “Part I (my folder name for the part)” - followed by NO text document or chapter heading.

This takes first takes effect when Scrivener compile the NEXT folder, part II. Here I get "Part II (my folder name “På vei”. Followed by thish “Part II: På vei (which is my folder name)”, then again followed by Chapter III (3?) and the name I have given the Chapter in the folder.

Seems like the first folder confuse Scrivener and make the autonumber just start from from folder 2? I hav tried 1) Indenting the folder below the part 2) Putting the folder with chapters INSIDE the part 1. Nothing helps?

Could I be that frankly to attach my file as I do not understand it? The first Part is empty. Then it starts rolling from part 2? I see no option to attatch files here - so we might have to exchange email adresses? Best, Mads.

I love this software, but I really want to understand the structure of folders combined with the formatting options on compile. Any suggestions? I have searched and searched. The advice given above on using the preset “Novel with parts” got me closer than anything. But still I feel very unsecure about what settings to apply to the underneath folders/docs. I want a Scene header, for instance - so I can see what scene I am reading when readin through. Thanks anyway.

I have a long-abandoned blog that I had meant to write up advice like this, but never followed through. Maybe I should resurrect that effort, because this is the kind of thing that pictures help a lot with. But since I don’t have time for that right now, let’s talk about “levels”…

In the Formatting section of the Compile window, you’ll see icons and rows of check-boxes. Some rows with the folder icon preceding the checkboxes. Other rows will have the document icon, and yet other rows will have a stack of pages as the icon. Each of those corresponds to the very similar icons you see in the binder, but usually only apply to the contents of the “manuscript” folder that you started with when you created the project (sometimes it’s named Draft or other things).

In the compile window, you’ll also see “level 1+” or “Level 2” and the like next to the icon. If you see a “Level 2” or “Level 2+”, then {Folder icon} Level 2+ is indented beneath a row that shows {Folder icon} Level 1. The “level” part of that is how far it’s indented in the binder.

In Sanguinius’s example indentation, (which is exagerated compared to the indents in the binder), Your part folder is going to be at “level 1”. It will likely be a folder icon, and thus in the Formatting section of Compile, its settings will be governed by the “{Folder icon} Level 1” row. I assume this is how you have things structured because using the Novel with Parts compile preset seemed to help you, so let’s delve into that a little.

Click on the {Folder icon} Level 1 row in the compile settings. Below that area, there’s some Lorem Ipsum sample text, which probably starts with “Part I: Title” or something similar. Click on the Section Layout button. You’ll see there that the “title prefix” area has some stuff in it. That’s where the “Part” and the auto-numbering comes in. The “Title” part comes from the name you gave the part folder in the binder. Every time it comes across a folder at the first level of indentation (beneath the Manuscript folder), it will apply all of the settings in the Section Layout and the row you original clicked on with the folder icon and the check-boxes. You can change the the checkboxes on that row, for instance, to eliminate using the folder’s name from the binder, and just have the “Part I” bit show up in the compiled output. Experiment with that a bit, and then check out those settings on the “level 2” folder row to see how that affects the Chapter folders…

Hopefully that gets you started exploring the compile options. If you mess them up, you can always reset to the “Novel with Parts” preset and start over, so don’t be afraid to experiment and learn.

Thanks a lot!